Window snaps to full screen

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
lvdave
Level 1
Level 1
Posts: 8
Joined: Thu Oct 18, 2012 1:03 pm

Window snaps to full screen

Postby lvdave » Thu Oct 18, 2012 1:18 pm

I'm running Cinnamon on Ubuntu 12.04, as I absolutely detest Unity. Having said that, there is a "feature" that apparently both Unity AND Cinnamon have that drives me batty. I was able to find out how to turn it off in Unity, but so far have had no luck in finding the same "off switch" in Cinnamon. The "feature" I'm referring to is a when a window gets close to the top of the screen the screen flashes redish momentarily and the window goes full screen. I detest that "feature" in Unity and likewise in Cinnamon. It's VERY annoying when you drag a window up to get it out of the way so you can see another window and it decides to fill the screen.. Several people on the Ubuntu forums chastised me for disliking the feature, when I was looking for the switch to turn it off in Unity. They seemed to think that "feature" was one the most useful additions to Unity. I did not agree.. PLEASE tell me there is a way to shut that off.... Other than this "feature" I love Cinnamon...

LVDave

lurkatron
Level 3
Level 3
Posts: 124
Joined: Tue Nov 01, 2011 2:18 pm

Re: Window snaps to full screen

Postby lurkatron » Thu Oct 18, 2012 1:56 pm

totally agree. its annoying, like if i drag a window to the top of the screen its because i want it to at the top of the screen, not something totally different.

...and i dont know if/how u can turn it off either sadly

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Window snaps to full screen

Postby zerozero » Thu Oct 18, 2012 7:48 pm

open cinnamon settings > windows and there untick Enable Edge Tiling ("Aero Snap")
Image

[ bliss of ignorance ]

lvdave
Level 1
Level 1
Posts: 8
Joined: Thu Oct 18, 2012 1:03 pm

Re: Window snaps to full screen

Postby lvdave » Fri Oct 19, 2012 4:48 pm

zerozero wrote:open cinnamon settings > windows and there untick Enable Edge Tiling ("Aero Snap")


Ummm.. I figured that was probably what it was, but I have nothing in Cinnamon Settings/Windows anything even close to "Enable
Edge Tiling (AeroSnap)"..

All that is there are dropdowns for "Action on title bar double-click", "Action on title bar middle-click", "Action on title bar right-click","Windows Focus Mode", "Left Side Title Bar Buttons" and "Right Side Title Bar Buttons". Had I seen such a checkbox, I would have instinctively known THAT was what was causing this "feature", as there is a similar "feature" in Ubuntu Unity that you have to go into Compiz settings and turn off. Seems like everybody, Windows 7 included, have this braindead "feature" and everybody seems to want to hide how you turn it OFF.. /rant off

This is Mint Maya 13 64bit. I experienced the same problem on another machine running Cinnamon on Ubuntu 12.04...

LVDave

naike
Level 1
Level 1
Posts: 13
Joined: Sat May 14, 2011 12:48 pm

Re: Window snaps to full screen

Postby naike » Fri Oct 19, 2012 5:10 pm

I think it's only a feature in cinnamon 1.6

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Window snaps to full screen

Postby zerozero » Fri Oct 19, 2012 7:20 pm

:shock: yep i'm sorry for the misleading info; i wasn't a regular user of cinnamon 1.4, this option it's definitely there in 1.6.x
if you decide to upgrade see this >> http://blog.linuxmint.com/?p=2177
Image

[ bliss of ignorance ]

lvdave
Level 1
Level 1
Posts: 8
Joined: Thu Oct 18, 2012 1:03 pm

Re: Window snaps to full screen

Postby lvdave » Sat Oct 20, 2012 12:01 pm

Lovely.. Came to Mint/Cinnamon to get AWAY from brain-dead display behavior like this, and even though I installed the latest version of Mint, I'm getting an old version of Cinnamon.. I read the link you posted and it states "These technologies are brand new and we do not recommend you upgrade to them."... I read THAT to mean that unless I'm feeling like experimenting, I'd be better off staying away from that version.. Since this machine is my daily work machine, I don't need to play with alpha/beta stuff on it.. On the other hand this window snap "feature" is driving me nuts.. Is there ANY way to disable it otherwise? I'm pretty spry with a command line... HELP!!

LVDave

lurkatron
Level 3
Level 3
Posts: 124
Joined: Tue Nov 01, 2011 2:18 pm

Re: Window snaps to full screen

Postby lurkatron » Sat Oct 20, 2012 12:59 pm

lvdave, remember cinnamon is brand new, features and things like this gets added on almost a daily basis. it cant become perfect overnight. im running cinnamon 1.6 on my only machine now, its rock stable and no problems with it, i wouldnt hesitate upgrading if i were you (but dont kill me if it screws smt up - but id be very surprised if it did)

lvdave
Level 1
Level 1
Posts: 8
Joined: Thu Oct 18, 2012 1:03 pm

Re: Window snaps to full screen

Postby lvdave » Sat Oct 20, 2012 1:39 pm

Never mind, I installed MATE instead and fortuantly, it doesn't seem to have that "feature"... I do prefer Cinnamon over MATE, but until I can install a released version of Cinnamon 1.6, I'll stick with MATE... When I read as clear a disclaimer as that, I limit use of that software to a test machine, of which I currently don't have any...

LVdave

registereduser
Level 2
Level 2
Posts: 65
Joined: Tue Aug 23, 2011 3:40 pm

Re: Window snaps to full screen

Postby registereduser » Mon Oct 22, 2012 3:43 pm

I just installed 1.6, went into cinnamon settings, unchecked the Aero feature in the window settings, closed the settings panel and dragged a window up, it still snaps-to so you're not missing out on much

zerozero
Level 16
Level 16
Posts: 6514
Joined: Tue Jul 07, 2009 2:29 pm

Re: Window snaps to full screen

Postby zerozero » Mon Oct 22, 2012 3:54 pm

interesting, that feature (the option to check or uncheck the "aero-snap") works as expected here
Image

[ bliss of ignorance ]

stefanvbs
Level 1
Level 1
Posts: 2
Joined: Sun Oct 28, 2012 10:03 am

Re: Window snaps to full screen

Postby stefanvbs » Sun Oct 28, 2012 12:35 pm

This worked for me (Linux Mint 13, Cinnamon 1.4.0): Install the Gnome Configuration Editor (package "gconf-editor"). In the editor find the key "/desktop/cinnamon/windows/edge_tiling" and unclick it (Set its value to false).

lvdave
Level 1
Level 1
Posts: 8
Joined: Thu Oct 18, 2012 1:03 pm

Re: Window snaps to full screen

Postby lvdave » Thu Nov 01, 2012 5:24 pm

Ok.. tried the gconf-editor, fixed... Didn't know gconf-editor worked on Cinnamon... Thanks for the info

Dave

nzlemming
Level 1
Level 1
Posts: 5
Joined: Wed Mar 04, 2015 11:05 pm

Re: Window snaps to full screen

Postby nzlemming » Sat Apr 25, 2015 7:40 am

Thank you thank you thank you
I have been going insane with this. Win7 did something similar when I first used it but I managed to turn it off. Couldn't find anything in Cinnamon settings.

User avatar
gibbs1984
Level 5
Level 5
Posts: 760
Joined: Mon Oct 27, 2008 2:40 pm
Location: Hemel Hempstead, England

Re: Window snaps to full screen

Postby gibbs1984 » Wed Apr 29, 2015 5:30 pm

Isn't the option Settings > Window Tiling and Edge Flip then untick Enable Windows Tiling and Snapping?
Linux Mint 18 (Cinnamon) 64bit.

dkpw
Level 1
Level 1
Posts: 3
Joined: Wed Dec 03, 2014 8:17 am

Re: Window snaps to full screen

Postby dkpw » Tue Apr 19, 2016 10:29 am

I've just upgraded from Mint 17.1 to 17.3 MATE and hated the snap to full screen option.
I resolved it by going to System\Preferences\Look and Feel\Windows on the Windows Pref's Placement Tab, disable "Enable side by side tiling." That description is misleading but it works.

Hope that helps someone.

Cosmo.
Level 20
Level 20
Posts: 11691
Joined: Sat Dec 06, 2014 7:34 am

Re: Window snaps to full screen

Postby Cosmo. » Tue Apr 19, 2016 10:41 am

dkpw wrote:I've just upgraded from Mint 17.1 to 17.3 MATE
...
Hope that helps someone.

Unlikely in the Cinnamon-board.
Image


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 3 guests