Strange artifacts in panel text

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Metus
Level 1
Level 1
Posts: 3
Joined: Thu Oct 18, 2012 8:41 pm

Strange artifacts in panel text

Postby Metus » Thu Oct 18, 2012 8:45 pm

Hello,

I just installed Linux Mint Cinnamon and I noticed some artifacts in the panel texts, see pictures. I have no idea where they come from. Additional drivers says that no third-party software is needed for my graphics chip. How can I remove these artifacts?
Attachments
artifacts.png
artifacts.png (54.46 KiB) Viewed 1223 times

naike
Level 1
Level 1
Posts: 13
Joined: Sat May 14, 2011 12:48 pm

Re: Strange artifacts in panel text

Postby naike » Thu Oct 18, 2012 9:06 pm

I would start by taking a look at your fonts.
Maybe there's a way to "reset" your fonts in general.
Does changing fonts do anything?

Metus
Level 1
Level 1
Posts: 3
Joined: Thu Oct 18, 2012 8:41 pm

Re: Strange artifacts in panel text

Postby Metus » Thu Oct 18, 2012 9:31 pm

I am not sure how to change the fonts in the menu. Changing the fonts in Cinnamon Preferences (not sure that this is the correct english term, I am using the german version) does not change anything in the panel.

naike
Level 1
Level 1
Posts: 13
Joined: Sat May 14, 2011 12:48 pm

Re: Strange artifacts in panel text

Postby naike » Fri Oct 19, 2012 4:23 pm

I've noticed, that sometimes cinnamon doesn't apply changes on the fly.
Sometimes you need to reload cinnamon after changing settings.
Alt+F2 and run "r", try to change fonts and then reload.
Could also try

Code: Select all

sudo fc-cache -f -v
to rebuild font cache.
But tbh, it sounds like a gpu driver problem.
What card/drivers do you have?

Metus
Level 1
Level 1
Posts: 3
Joined: Thu Oct 18, 2012 8:41 pm

Re: Strange artifacts in panel text

Postby Metus » Fri Oct 19, 2012 5:42 pm

Changing fonts and reloading does not fix the issue. Output from lspci yields

Code: Select all

01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS600 [Radeon Xpress 1200 Series] (prog-if 00 [VGA controller])
        Subsystem: ASRock Incorporation Device 7941
        Flags: bus master, fast devsel, latency 32, IRQ 18
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Memory at fdff0000 (64-bit, non-prefetchable) [size=64K]
        I/O ports at c000 [size=256]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: radeon
        Kernel modules: radeon

loudgefly
Level 1
Level 1
Posts: 2
Joined: Wed Jan 18, 2012 1:53 pm

Re: Strange artifacts in panel text

Postby loudgefly » Sun Mar 31, 2013 5:33 pm

Same problem here, with Cinnamon on both LMDE and LM 14, same graphic card (X1250), "radeon" driver.

User avatar
catweazel
Level 7
Level 7
Posts: 1669
Joined: Fri Oct 12, 2012 9:44 pm

Re: Strange artifacts in panel text

Postby catweazel » Sun Mar 31, 2013 7:21 pm

The first step should always be to let Cinnamon scale the panel.

Cinnamon Settings > Panel
Mint Testing Team & Mint Donor #3606

homerscousin
Level 5
Level 5
Posts: 531
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: Strange artifacts in panel text

Postby homerscousin » Tue Apr 02, 2013 5:27 pm

I had some similar type artifacts back a couple months ago. Posted in the KDE subforum if you want to see my screenshot. End of January I think. Small white lines... was the title. Don't know what caused it or what cured it, but the system update did cure it. All those hundreds of update files.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 2 guests