How to logon automatically

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Sugarat
Level 1
Level 1
Posts: 13
Joined: Mon May 02, 2011 7:17 am

How to logon automatically

Postby Sugarat » Mon Feb 04, 2013 3:02 pm

Hi All,

I have just installed Linux Mint 14 Cinnamon and I need it to login automatically.

Therefore, I went into Preferences -> User Accounts, and on my account I clicked the slider button to login automatically. Strangely, if I then close the GUI and load it again (Preferences -> User accounts) it has remembered my selection and shows automatic login as being activated for my user account. If I restart the system, it does *not* automatically log me in. If I login and go back to user account preferences it has returned to automatic login being turned off.

What's going wrong here?

Many thanks

User avatar
xenopeek
Level 23
Level 23
Posts: 19212
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How to logon automatically

Postby xenopeek » Mon Feb 04, 2013 4:11 pm

Automatic login is configured in the Login Window application, on the Security tab.
Image

Sugarat
Level 1
Level 1
Posts: 13
Joined: Mon May 02, 2011 7:17 am

Re: How to logon automatically

Postby Sugarat » Mon Feb 04, 2013 4:47 pm

Okay thanks.

Then what is the point of the auto-login switch in the user accounts panel?

User avatar
xenopeek
Level 23
Level 23
Posts: 19212
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How to logon automatically

Postby xenopeek » Mon Feb 04, 2013 4:49 pm

Well, I'm not sure. I'd guess it is feature in the program, but the program doesn't know about MDM (the Linux Mint login window).
Image

Sugarat
Level 1
Level 1
Posts: 13
Joined: Mon May 02, 2011 7:17 am

Re: How to logon automatically

Postby Sugarat » Mon Feb 04, 2013 6:04 pm

If this option does not work it definitely needs removing. It is things like this that drove me away from Ubuntu recently, so I'm a little disturbed to find it in Mint as well.

klick
Level 1
Level 1
Posts: 15
Joined: Fri Feb 01, 2013 8:56 pm

Re: How to logon automatically

Postby klick » Tue Feb 05, 2013 8:12 pm

Sugarat wrote:If this option does not work it definitely needs removing. It is things like this that drove me away from Ubuntu recently, so I'm a little disturbed to find it in Mint as well.


+1

I just about pulled my hair out with a similar problem. Had to go to Menu >System Tools> Administration> Login Window> Security Tab.

Going to User Accounts wouldn't do it, although the settings are there.

subbass
Level 1
Level 1
Posts: 1
Joined: Fri Feb 15, 2013 10:44 am

Re: How to logon automatically

Postby subbass » Fri Feb 15, 2013 10:52 am

Is there a way to correct this via SSH.

I've just been this morning to upgrade a PC and enabled auto login, in the wrong place it seems as it wouldn't work. If I can fix it via SSH then it will save me a trip.

Edit: Sorted it via SSH, for anyone else who may come looking for an answer.

Code: Select all

sudo nano /etc/mdm/mdm.conf


Under the [daemon] section:

Code: Select all

AutomaticLoginEnable=true
AutomaticLogin=TuxIsKing


Change "TuxIsKing" to the username you want to auto login.

MichaelJohn
Level 3
Level 3
Posts: 169
Joined: Fri Dec 12, 2014 6:46 am

Re: How to logon automatically

Postby MichaelJohn » Thu Jan 22, 2015 6:55 am

Thank you for this - it was really helpful :D My laptop needed another login without the ability to change change configuration and software. I was starting to think I was doing something wrong via the 'Users & Groups' module. This inconsistency needs addressing if Linux is really going to penetrate market! :(

yawnfest
Level 1
Level 1
Posts: 25
Joined: Tue May 03, 2016 3:37 pm

Re: How to logon automatically

Postby yawnfest » Thu May 05, 2016 11:38 am

How do you get auto login to work on 17.3 Cinnamon (Rosa)?

There is no security tab in the login window... just Themes, Auto Login (which does precisely FA), and Options (which, if i set the default monitor to the one that isn't the 2nd desktop, still displays the login window on the wrong bloody monitor...)

Cheers

User avatar
Moem
Level 6
Level 6
Posts: 1488
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands

Re: How to logon automatically

Postby Moem » Thu May 05, 2016 11:45 am

System settings => Administration => Login Window => Auto login => [X] Enable automatic login.

By the way, it's fine to start a new thread in cases like this.
My other machine is a Thinkpad too.

yawnfest
Level 1
Level 1
Posts: 25
Joined: Tue May 03, 2016 3:37 pm

Re: How to logon automatically

Postby yawnfest » Fri May 06, 2016 8:12 am

Hi there,

The problem with Auto Login is that, as I said, it does precisely FA. I've had auto login ticked pretty much since I installed it, and I still have to input my password every time the computer comes out of sleep mode (it does log me in automatically when I boot though, as I had to do today because this problem happened again today: https://forums.linuxmint.com/viewtopic.php?f=18&t=221432 - so, to be fair, I guess it half works).

Is it just for when you boot the computer only? It's tiresome to have to type your password every time you open the desktop lid, especially if it won't accept anything you type and you need to reboot your PC.

Cosmo.
Level 19
Level 19
Posts: 9630
Joined: Sat Dec 06, 2014 7:34 am

Re: How to logon automatically

Postby Cosmo. » Fri May 06, 2016 8:26 am

You can disable in the screen saver settings for the request of the password after resuming from suspend: Turn of the first option in the settings.

yawnfest
Level 1
Level 1
Posts: 25
Joined: Tue May 03, 2016 3:37 pm

Re: How to logon automatically

Postby yawnfest » Fri May 06, 2016 8:34 am

Hi,

Yeah, I just found that option. I turned the first three options off. And do you know what it did?

You see this problem? https://forums.linuxmint.com/viewtopic.php?f=18&t=221432

This problem happened to me again this morning. So, I thought, if I auto login, not only do I not have to keep typing my password, but this error will never occur again, right? WRONG!

I press the power button to awake my computer (it would be nice to just open the lid, but anyway...), and.... THE KEYBOARD DID NOT WORK AT ALL!! I needed to reboot. Brilliant!

edit: think I found solution, posted in in thread linked in this post


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 6 guests