Keep Screen Active

Please post suggestions for improvement of Cinnamon here
Level 1
Level 1
Posts: 11
Joined: Thu Apr 04, 2013 12:20 pm

Keep Screen Active

Postby buster2209 » Thu Apr 04, 2013 12:27 pm

I'm currently running LMDe with Cinnamon 1.6.7

In the menu, Preferences > Brightness & Lock, the option 'Turn screen off when inactive for:' doesn't have an option that says 'never'.

Is there any way to prevent the screen from turning off or keeping it turned on?

I have found that Transmission doesn't download when the screen is turned off...

User avatar
Level 8
Level 8
Posts: 2353
Joined: Sun Feb 24, 2013 2:41 pm

Re: Keep Screen Active

Postby roblm » Sat Apr 13, 2013 12:21 pm

You can try this method. However, I only tried it while running LMDE in a virtual machine. Copy the following lines of code.

Code: Select all

      <col id="0" translatable="yes">Never</col>
      <col id="1">0</col>

Go to "/usr/share/gnome-control-center/ui". You may want to copy the file "screen.ui" first to another location in case something goes wrong. I also have a backup image of my /root partition. Then right click on the file and select "Open as Root". Open the file and count down to line 86
and create a space after it, after the line "</row>". Paste the code here. It should look like this below when done.


Save the file and go to System Settings > Brightness and lock. In the drop down window next to "Turn screen off when inactive for", select
"Never". I noticed that when I closed this screen and went back into it, that the window setting had changed to "1 minute" but the screen did not turn off after 1 minute. I waited another 5 minutes and the effect was still working. I then tried changing the setting several times from "1 minute" to "2 minutes" to "Never" and it seemed to be working. You will have to test this to see if the screen never turns off.

Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 6 guests