HDMI audio issue in Mint15

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
joerg_k
Level 1
Level 1
Posts: 4
Joined: Mon Jun 03, 2013 4:26 am

HDMI audio issue in Mint15

Post by joerg_k »

I just installed the new version Mint15, Cinnamon 64-bit. I am really surprised how well it works and looks. Unfortunately I encounter several issues. Most important to me, there is no sound over HDMI.

Before I installed Cinnamon I tried out Xubuntu and had this issue as well. Installing a different kernel solved it though, but also created other issues. Finally I abandoned the installation and gave Cinnamon a try. But also here, the audio problem persists.

Right after the installation the HDMI-audio did not even show up in the output devices.
So I updated the kernel, got it from 3.8.0-19-generic to 3.8.0-23-generic. Thereafter the HDMI showed up as an output-device, namely "Built-in Audio Digital Stereo (HDMI)". But the device still does not show up in the Sound Settings "Play sound through". It is therefore not selectable. I see a title "Settings for HDMI / DisplayPort" at the right side of the settings dialog. But, I am unable to direct the sound to HDMI.

I am unable to judge how far sound and video are interrelated for HDMI, whether it is a driver issue. I should have good drivers: In the Driver Manager I see the correct AMD device, Radeon HD 6310, the AMD/ATI display driver wrapper (recommended) selected. In my vew the problem it is unlikely there.

Anyway, how can I get HDMI audio? Does anyone have this issue as well? Does anyone know how to fix this? Would be great. Thanks!
danburgess67
Level 1
Level 1
Posts: 2
Joined: Mon Apr 15, 2013 11:40 am

Re: HDMI audio issue in Mint15

Post by danburgess67 »

I have experienced the same problem on two different machines. It's very frustrating. Anybody have an answer?
wub
Level 1
Level 1
Posts: 29
Joined: Mon Jan 02, 2012 4:19 pm

Re: HDMI audio issue in Mint15

Post by wub »

From the main menu, start Preferences -> Sound. On the Hardware tab, at the bottom is a drop down menu under "Settings for the selected device". On my laptop, when I enter this menu the default is "Analog Stereo Output" which feeds both the speakers and the headphone jack, apparently. The menu has 10 different choices, including "Digital Stereo (HDMI) Output", or my favorite "Digital Surround 5.1 (HDMI) Output"

Pick one of those, and then use the Test Speakers control to make sure it's working, and besides, its kinda fun to have isolated output that really shows your speakers are working. Only thing is, I never hear anything when I test my subwoofer, even though it obviously works with actual sound content.

Good Luck!
jaka1313
Level 1
Level 1
Posts: 2
Joined: Sat Aug 31, 2013 7:04 pm

Re: HDMI audio issue in Mint15 (SOLVED)

Post by jaka1313 »

HDMI Audio is disabled by default on kernel 3.0+ due to a black screen on some monitors.

To get audio working again go to:

etc/default/grub
Open grub as administrator with a text editor.

change the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

save

type in the terminal:

sudo update-grub

reboot and your HDMI sound will work again.
nitemagic
Level 1
Level 1
Posts: 1
Joined: Wed Oct 09, 2013 2:59 am

Re: HDMI audio issue in Mint15

Post by nitemagic »

i have super noob status as this is my 1st linux distro and i just finished the install at 10 am my time. I and my wife watch movies out on our flatscreen a lot so imagine my surprise when i no longer get audio out there (living room)..... hdmi audio has been dropped altogether!
well to make an even longer story short, i did as the advice above suggested but forgot to put the - between update and grub.... have i messed up entirely or can i just re-run the command correctly this time and be ok?? :D btw i'm running mint 15 w/ the Mate desktop or dosen't that make any diff. oh and hdmi is from ati raedon hd 6870 w/ 9.012-121219a ati proprietary drvs. gotten from mint driver manager
VectorRoll
Level 1
Level 1
Posts: 1
Joined: Fri Sep 06, 2013 5:35 pm

Re: HDMI audio issue in Mint15

Post by VectorRoll »

This may seem like a stupid question, but when you say go to
/etc/default/grub
How exactly do you do that? I tried typing that in the Terminal and using sudo before it. I have searched the internet for anything and everything pertaining to this fixed listed here and how to do it, but I am at a loss. I am new to Linux and am trying to learn all of this.
In my searching though I have come to a conclusion that I may not even have a version of Grub installed. In the Software Manager I can find them to install but in searching what I have installed already I do not see any.
Do I first need to install a version of Grub?
Also is their any other things I can try to get my HDMI sound to work and the videos to not play at high speeds?

I will say that I did fix this issue before but I had to change the SSD in this PC so I reinstalled Linux Mint 15, and since the reinstall the things I did last time to get my HDMI to work is no longer working.


Any help would be appreciated.


EDIT Update: I went ahead and installed Grub and then was able to try this fix. So that was my issue. I didn't have it installed. Sadly though the fix did not work for me. I still do not have any sound and my videos play in fast forawrd. :(

EDIT Update: I fixed it so no need to answer my questions. I had to remove the quiet splash from it completely so that it was just "radeon.audio=1".
Post Reply

Return to “Cinnamon”