{Solved} MDM Cinnamon won't load after updates LM13

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
User avatar
Therion87
Level 2
Level 2
Posts: 61
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

{Solved} MDM Cinnamon won't load after updates LM13

Postby Therion87 » Fri Jun 07, 2013 6:13 pm

AFter todays updates to Cinnamon MDM and Nemo I can no longer boot to MDM and login it I hang when it says

starting Network drives
stopping network drives

I have to push Alt-F4 drop to a console, login type startx and then I load XFCE.

Any ideas how I can get back to normal?

Let me know of any other information you need thanks!

http://pastebin.com/NFtdGTtj
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9

User avatar
Therion87
Level 2
Level 2
Posts: 61
Joined: Thu Apr 07, 2011 4:07 pm
Location: Youngstown, OH

Re: {Solved} MDM Cinnamon won't load after updates LM13

Postby Therion87 » Sat Jun 08, 2013 9:07 am

Fixed my own problem.

It had something to do witht he Infinality font rendering that I was recently trying out. After I removed it and purged the PPA it all started working fine again.
Processor: i7-2860QM
Memory: 16 GB DDR3 @ 1600MHz
Graphics: Nvidia 560M 1.5GB - 313.18
Operating System: Linux Mint 13 Maya
HDD: 120 GB SSD & 500 GB HDD
Kernel: 3.9

sha512
Level 1
Level 1
Posts: 1
Joined: Sun Jul 14, 2013 3:03 am

Re: {Solved} MDM Cinnamon won't load after updates LM13

Postby sha512 » Sun Jul 14, 2013 3:09 am

Greetings,

I found a workaround how to use infinality and MDM on Linux Mint.
If you want to use infinality and MDM follow this steps after infinality installation from PPA:

After setting the font rendering profile in infinality-settings.sh:
1) move the infinality script out of the system profile:

Code: Select all

sudo mv /etc/profile.d/infinality-settings.sh /etc/infinality-settings.sh

2) change permission to exectute by everyone:

Code: Select all

sudo chmod a+rx /etc/infinality-settings.sh

3) Using your favourite text editor add following lines at the end of your .bashrc file in home directory:

Code: Select all

# INFINALITY FONT RENDERING CONFIG
      . /etc/infinality-settings.sh


Tested on Linux Mint 15 Olivia.

SHA512

chronodm
Level 1
Level 1
Posts: 3
Joined: Wed Dec 19, 2012 12:33 pm

Re: {Solved} MDM Cinnamon won't load after updates LM13

Postby chronodm » Tue Jul 01, 2014 6:25 pm

I had the same problem with Infinality and MDM in Mint 17 MATE, and I was able to fix this by changing SET_XFT_SETTINGS from true to false in /etc/profile.d/infinality-settings.sh.

User avatar
clem
Level 12
Level 12
Posts: 4001
Joined: Wed Nov 15, 2006 8:34 am
Contact:

Re: {Solved} MDM Cinnamon won't load after updates LM13

Postby clem » Fri Apr 03, 2015 5:35 pm

Fixed by https://github.com/linuxmint/mdm/commit ... be25e31bb7

Here's an explanation of why it was failing:

- infinality provides a script in /etc/profile.d/ which uses xrdb.
- xrdb fails if there's no DISPLAY
- In the case where we're launching MDM via upstart, /etc/profile sources all /etc/profile.d/*.sh (I'm not sure whether we're using sh instead of bash, or whether we're setting "set -e" upstream from that, but in any case.. any failure is fatal here, so any script failing to load would make upstart fail to launch MDM).
- At that stage, MDM isn't launched yet and there's no DISPLAY... so xrdb fails, and it makes the script fails, which makes /etc/profile fail, which makes the MDM upstart job fail.

With the new commit, we no longer fail.

That said, this should be reviewed by the infinality devs. First they should probably ignore errors (like we did) or test $DISPLAY before calling xrdb... this is MDM, but failures in /etc/profile can be pretty bad, and MDM isn't the only piece in the puzzle, so their script should NEVER fail. Second, I really don't think /etc/profile is the right place to do this. It's too early in the login process imo. They should use other means and assure themselves they're already in the display.

I was going to post that on their github project but their last commit was in January 2013. If you're subscribed to their forums or in touch with them, please don't hesitate to let them know about this.

Regarding our own fix it will be part of MDM 2.0 (in Betsy and Mint 17.2). If you don't want to wait, simply edit your /etc/init/mdm.conf and add the two "set" lines as done in https://github.com/linuxmint/mdm/commit ... be25e31bb7
Image


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 2 guests