Cinnamon Compositor Screen Tearing in Games - Disable?

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
Yfrwlf
Level 3
Level 3
Posts: 129
Joined: Sat Jun 08, 2013 7:46 pm

Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Yfrwlf » Sat Jun 08, 2013 8:03 pm

I'm sad to say that I cannot switch to Linux Mint 15 over Ubuntu 13.04 if I want to have a nice desktop eperience in both cases, and here's why.

Unchecking all check boxes in System Settings > Appearance > Effects, including "Enable desktop effects", does not disable the compositor. Is there a way to disable compositing in Cinnamon?

Within Linux Mint 15, there is a huge difference for gaming due to screen tearing and most likely decreased framerates (haven't verified the latter yet) between when running Cinnamon and when running LXDE or Fluxbox, just to prove that it's not a game or driver settings difference.

Unity in Ubuntu 13.04 runs the games just like Mint 15 does in LXDE and Fluxbox, without screen tearing, and is using the same nVidia driver version. I don't know how they are doing it because it doesn't seem like desktop effects are being turned off upon launching a game. I haven't tried a windowed mode in a game yet but given how fullscreen games slide into place and there is no flickering I highly doublt the compositor is being turned off and they have even said you can't turn it off and that "2D mode is no longer supported" (and indeed is not selectable via the login screen like it was in Ubuntu 12.04).

Given all of this, it seems that Unity is doing something to allow fluid graphics processing even with a compositor, while Cinnamon is not doing this. Or, perhaps Cinnamon is simply not being hardware accellerated while Unity is.

Has anyone had similar experiences, and does anyone know why, and know of a way to disable compositing in Cinnamon or is it not an option?

Thanks!!!

strict
Level 1
Level 1
Posts: 7
Joined: Thu Feb 26, 2009 10:12 am

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by strict » Sat Jun 15, 2013 11:12 pm

I am having the same issue. I have upgraded my nvidia-equipped laptop from Mint 14 xfce edition to Mint 15 Cinnamon and noticed a slowness with Steam games. It would be nice to be able to switch off the compositor prior to running fullscreen 3d games.

Yfrwlf
Level 3
Level 3
Posts: 129
Joined: Sat Jun 08, 2013 7:46 pm

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Yfrwlf » Sat Jun 15, 2013 11:38 pm

strict wrote:I am having the same issue. I have upgraded my nvidia-equipped laptop from Mint 14 xfce edition to Mint 15 Cinnamon and noticed a slowness with Steam games. It would be nice to be able to switch off the compositor prior to running fullscreen 3d games.
Did you try Fluxbox, XFCE, LXDE, or something like that in Mint 15 to verify that without a compositing window manager it is faster? I'm sure it will be though. As I said I didn't try any real benchmarks for FPS but the tearing is very much real.

Some good benchmark programs if you want to try them: https://unigine.com/products/benchmarks/

You probably shouldn't do Valley on a laptop's GPU though but maybe Sanctuary or something.

User avatar
Ginsu543
Level 4
Level 4
Posts: 450
Joined: Thu Nov 24, 2011 3:15 am
Location: Los Angeles, CA, USA

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Ginsu543 » Sun Jun 16, 2013 2:25 am

To fix video tearing in Cinnamon, try this:

1) Open Terminal

2) Issue the following command:

Code: Select all

gksu gedit /etc/environment
3) Add to end of file:

Code: Select all

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True
4) Reboot and see if that fixes the problem
Main: Intel Core i7 920 D0 @ 4.0 GHz | Asus P6X58D Premium | 12 GB Mushkin Redline PC3-12800 7-8-7-24 | EVGA GeForce GTX 560 Ti | Mint 17.2 Cinnamon 64 / OS X 10.7.3
Portables: Toshiba Portege R200 | Mint 17.2 Cinnamon 32 / Dell Mini 9 | OS X 10.6.7

Oldbwl
Level 2
Level 2
Posts: 53
Joined: Thu May 09, 2013 2:38 am

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Oldbwl » Sun Jun 16, 2013 3:59 am

Ginsu543 wrote:To fix video tearing in Cinnamon, try this:

1) Open Terminal

2) Issue the following command:

Code: Select all

gksu gedit /etc/environment
3) Add to end of file:

Code: Select all

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True
4) Reboot and see if that fixes the problem
This should be reposted as a seperate topic to cure the tearing experienced in Smooth Scrolling in Firefox which it does admirably. - Thank you very much for posting this. You have made my Cinnamon experience much much better.

Yfrwlf
Level 3
Level 3
Posts: 129
Joined: Sat Jun 08, 2013 7:46 pm

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Yfrwlf » Sun Jun 16, 2013 9:56 am

Ginsu543 wrote:To fix video tearing in Cinnamon, try this:

1) Open Terminal

2) Issue the following command:

Code: Select all

gksu gedit /etc/environment
3) Add to end of file:

Code: Select all

CLUTTER_PAINT=disable-clipped-redraws:disable-culling
CLUTTER_VBLANK=True
4) Reboot and see if that fixes the problem
You are my hero. As Oldbwl said maybe this should be reposted as a sticky or something to fix screen tearing in Linux Mint 15? Who needs Wayland when we have this anyway, lol. Yeah yeah Xorg sucks in other ways apparently...

User avatar
Ginsu543
Level 4
Level 4
Posts: 450
Joined: Thu Nov 24, 2011 3:15 am
Location: Los Angeles, CA, USA

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Ginsu543 » Mon Jun 17, 2013 12:43 am

I'm glad that helped both you guys. I claim no credit as I saw that solution somewhere else in this forum. I just couldn't remember where so I just posted it rather than providing a linky.
Main: Intel Core i7 920 D0 @ 4.0 GHz | Asus P6X58D Premium | 12 GB Mushkin Redline PC3-12800 7-8-7-24 | EVGA GeForce GTX 560 Ti | Mint 17.2 Cinnamon 64 / OS X 10.7.3
Portables: Toshiba Portege R200 | Mint 17.2 Cinnamon 32 / Dell Mini 9 | OS X 10.6.7

Condorman
Level 4
Level 4
Posts: 263
Joined: Mon Nov 10, 2008 10:08 am

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by Condorman » Sat Jun 22, 2013 3:06 pm

Just wanted to post up a thanks for this. I had pretty bad tearing when playing snes9x-gtk and Kega Fusion fullscreen. I entered these commands and all is well. Hope this gets implemented by default for future releases, as many of us game on Mint now.

SundarTrichy
Level 1
Level 1
Posts: 1
Joined: Sun Apr 19, 2015 5:36 pm

Re: Cinnamon Compositor Screen Tearing in Games - Disable?

Post by SundarTrichy » Sun Apr 19, 2015 5:41 pm

Great!! It works...!
Thanks a lot..! I have been fiddling with NVIDIA drivers to fix the screen tearing issue in my mint. But your answer just worked like that :) I'm happy.

Post Reply

Return to “Cinnamon”