Help with theme colors

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

Not quite. I've done a little mix-n-match with my settings involving the use of both Dragon and Eclipse, and I'm not sure which one is responisible for my black box. Perhaps this will help. The first two are my theme and display/window manager settings (**EDIT** - image size restrictions forced me to convert from IMG[] to URL[]):

http://i114.removed/albums/n256/evilsup ... bb2995.png

http://i114.removed/albums/n256/evilsup ... 75f3a3.png

This one is the black screenshot box (couldn't do it on the PC, had to use my phone):

http://i114.removed/albums/n256/evilsup ... av35sr.jpg

Ironically, in Nemo, the selection box is semi-transparent (tinted red). Did my mix-n-match mess something up? If we need to get truly technical, I started initially with a clean install of Full on Ubuntu 14.04, then added the Mint repo's, installed Cinnamon and Nemo, nuked Unity and nautilus, and kept LightDM, making a kind of Cinnubuntu hybrid, which has worked fine until I changed my visuals a few days ago. I'm sure there's a complication in there somewhere, but my system reports as full on Mint 17, not Trusty, so I guess for all intents and purposes, it is, just slightly customised by a control freak geek who needs to get his hands dirty and scrape the metal from time to time when tweaking, until something breaks, and he wishes he'd just left well enough alone. :lol:

That being said, usually I can figure out what I did wrong and fix it myself, or at least work around it, but this theming business has me over a barrel this time. I like the way it is right now, except for that box, so the only two choices I had were to get help with the schema or change the look around to try and get something close. I opted to ask for help instead. :P
If I had a signature, this is where I'd stick it.

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

When using the Dragon gtk (Controls) theme I get the red transparent area when I drag the mouse on the desktop, and also when I press Shift+prtsc.

Try switching your Controls theme back to Mint-X, logout/in, and try both again. The area should be transparent green.

If you still have the black box when pressing Shift+prtsc and dragging the mouse while using Mint-X, that should rule out the theme as the problem.
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

Habitual
Level 13
Level 13
Posts: 4870
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: Help with theme colors

Post by Habitual »


EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

caribriz wrote:When using the Dragon gtk (Controls) theme I get the red transparent area when I drag the mouse on the desktop, and also when I press Shift+prtsc.

Try switching your Controls theme back to Mint-X, logout/in, and try both again. The area should be transparent green.

If you still have the black box when pressing Shift+prtsc and dragging the mouse while using Mint-X, that should rule out the theme as the problem.
Well, it worked just as you said. The shift+prtscr box is translucent green under Mint-X but when I change the controls back to Dragon, it reverts to a solid black box with a thin red border. So the problem is with my controls decoration schema...?
If I had a signature, this is where I'd stick it.

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

EvilSupahFly wrote:Well, it worked just as you said. The shift+prtscr box is translucent green under Mint-X but when I change the controls back to Dragon, it reverts to a solid black box with a thin red border. So the problem is with my controls decoration schema...?
:?

I just tried the Dragon theme again ... with exactly the same results (LM17 Cinnamon).
Both the mouse drag and shift+prtscr box are translucent red.

I think the theme section involved is called "rubberband" in Dragon > gtk-3.0 > gtk-widgets.css

Weirdly, I have two identical sections in the gtk-widgets.css file - starting at line 359 and also another section, starting at line 8782

The color is set on the background-color line - the 0.35 on the line - is the level of opacity.

Code: Select all

.content-view.view.rubberband,
.view.rubberband,
.rubberband {
    background-color: alpha (@theme_selected_bg_color, 0.35);
	background-image: none;
    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}
The only other thing I can think of is that we are using slightly different versions of the Dragon theme.
Did you download your version from Cinnamon-spices site or gnome-look.org? (or maybe somewhere else).

But, I have tried the theme from both sites with exactly the same results - both work perfectly.

All my "Controls" themes behave the same way.

Hopefully, someone else will try the Dragon theme and report their results.
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

caribriz wrote:
EvilSupahFly wrote:Well, it worked just as you said. The shift+prtscr box is translucent green under Mint-X but when I change the controls back to Dragon, it reverts to a solid black box with a thin red border. So the problem is with my controls decoration schema...?
:?

I just tried the Dragon theme again ... with exactly the same results (LM17 Cinnamon).
Both the mouse drag and shift+prtscr box are translucent red.

I think the theme section involved is called "rubberband" in Dragon > gtk-3.0 > gtk-widgets.css

Weirdly, I have two identical sections in the gtk-widgets.css file - starting at line 359 and also another section, starting at line 8782

The color is set on the background-color line - the 0.35 on the line - is the level of opacity.

Code: Select all

.content-view.view.rubberband,
.view.rubberband,
.rubberband {
    background-color: alpha (@theme_selected_bg_color, 0.35);
	background-image: none;
    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}
The only other thing I can think of is that we are using slightly different versions of the Dragon theme.
Did you download your version from Cinnamon-spices site or gnome-look.org? (or maybe somewhere else).

But, I have tried the theme from both sites with exactly the same results - both work perfectly.

All my "Controls" themes behave the same way.

Hopefully, someone else will try the Dragon theme and report their results.
I installed it from the Spice list built into Cinnamon's user pref menu, accessed from "Themes". Now that I know what I'm looking for, l'll see what turns up. On my phone currently, and at work, but I can SSH in over lunch. Thanks for your help!
If I had a signature, this is where I'd stick it.

EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

OK, I took a look, and it's the same as what you've got. I'm wondering if it's picking up some leftover junk from Unity, since I did start with Trusty initially, and installed Cinnamon over top, although with Unity gone, I would think that shouldn't happen... Unless I'm underestimating the purvasiveness of Unity... :?

I guess I'll leave it for now, or try removing and reinstalling Dragon when I get home. Not sure which yet.
If I had a signature, this is where I'd stick it.

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

EvilSupahFly wrote:OK, I took a look, and it's the same as what you've got. I'm wondering if it's picking up some leftover junk from Unity, since I did start with Trusty initially, and installed Cinnamon over top, although with Unity gone, I would think that shouldn't happen... Unless I'm underestimating the purvasiveness of Unity... :? ...
I'm no expert :) , but that's what I'd suspect - something left over from Ubuntu is picking up the Unity parts of the Dragon theme.
Whereas, when I use the Dragon theme (only having a straight LM17 Cinnamon base), the Unity (and Nautilus?) bits of the theme are just ignored.

Also, if you look at the folders of the Mint-X theme (in /usr/share/themes), there are no Unity files .... so when you tried the Mint-X theme and pressed Shift+prtscreen
it worked. Maybe that's it :?:

Could try an experiment - if you haven't tried this already:
Make a copy of the Dragon theme folder in ~/.themes, rename it

In the copied theme folder, open gtk-3.0 > gtk.widgets.css

Try playing around with the two .content-view.view.rubberband .... sections in the file

"comment out" the .content-view.view.rubberband .... section at the bottom of the file

Code: Select all

/*.content-view.view.rubberband,
.view.rubberband,
.rubberband {
    background-color:  alpha (@theme_selected_bg_color, 0.35);
	background-image: none;
    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}*/
Choose the new theme in Themes > Controls
logout/in
See if it makes any difference

If nothing - uncomment the bottom section and try commenting out the top section.

Could also try changing the colors just to see what happens - one section at a time - logout/in after each change
(the change to the background-color line below should get a solid yellow/red border area when you drag the mouse):

Code: Select all

.content-view.view.rubberband,
.view.rubberband,
.rubberband {
    background-color: #FFFF00; /*alpha (@theme_selected_bg_color, 0.35);*/
	background-image: none;
    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}
:?:
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

Excellent ideas. Thanks! I will let you know once I have some results! Yes, I hated Unity and I dislike Nautilus greatly, so I got rid of them, replaceing them with Cinnamon and Nemo thinking that would be the end of things, but it seems there's a conflict in there somewhere still. Unity seems like it's hanging on by it's fingernails, refusing to go away quietly.

Ironically, I had started with Mint 17 in the first place but had trouble getting my nVidia card to work properly with the nVidia binaries, so I switched to Ubuntu Trusty (which Qiana was based from), and had no trouble at all with nVidia, then I nuked Unity, Nautilus, etc, and the rest you know. :lol:

*** Edit ***
It's funny. It does the same thing with DeloreanDark, which seems to be what Dragon was based off going by the comments sections.

*** Edit 2 ***
Commenting out those sections didn't change anything, so now I'm experimenting with commenting out anything Unity-related in my "Dragon 2 - The Modified Version" theme to see if that yeilds results.
If I had a signature, this is where I'd stick it.

EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

I see there are minor differences between MintX and Dragon. For example, in Dragon, we have this:

Code: Select all

.content-view.view.rubberband,
.view.rubberband,
.rubberband {
    background-color: alpha (@theme_selected_bg_color, 0.35);
	background-image: none;
    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}
And in MintX, we have this instead:

Code: Select all


.view.rubberband,
.rubberband {
    border: 1px solid @theme_selected_bg_color;
    border-radius: 0;
    background-color: alpha(@theme_selected_bg_color, 0.3);
}
Also, the selection/hilight governance (the "rubberband") is listed twice in Dragon, but only once in MintX, and that has me curious. I'm going to continue to play with my "Dragon 2" theme and see what I can come up with.

*** Edit ***

Well, I have finally just completely commented out both rubberband sections after changing the colours, the opacity, removing all references to unity, etc, and it still does it. So now I'm completely lost, though I think that at least I have a better handle on CSS now! :lol:
If I had a signature, this is where I'd stick it.

EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

Perhaps there's something else you can help me with...

Some of the themes I installed take full-screen windows (like the webbrowser) below the menu bar at the bottom, and that's a little annoying because the bottom button on the scroll bar is usually cut off. Which setting controls that?
If I had a signature, this is where I'd stick it.

KirbySmith
Level 4
Level 4
Posts: 284
Joined: Sun Feb 03, 2013 10:25 pm

Re: Help with theme colors

Post by KirbySmith »

For a related historical thread, there is:

http://forums.linuxmint.com/viewtopic.p ... 64#p694464

What is less historical is that the theme described in the link above that I had built for Mint 14 Cinnamon and saved in home before upgrading works great in Mint 17 MATE.

kirby
Attachments
Screenshot-1.png
Desktop 1: DFI Lanparty UT nF4 SLI-D/AMD Athlon 64 San Diego/BFG GeForce 7800 GT/Mint 18.3 MATE
Desktop 2: Gigabyte 770T-USB3/AMD Phenom II X4 965/EVGA GeForce 9800 GT/Mint 18.3 MATE
HTPC: Asus C6H/AMD Ryzen 7 1800X, Asus Geforce 1080 Ti/Mint 18.3 MATE

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

EvilSupahFly wrote:*** Edit ***
It's funny. It does the same thing with DeloreanDark, which seems to be what Dragon was based off going by the comments sections.

*** Edit 2 ***
Commenting out those sections didn't change anything, so now I'm experimenting with commenting out anything Unity-related in my "Dragon 2 - The Modified Version" theme to see if that yeilds results.
I've tried a few things -

Downloaded Ubuntu 14.04.1 - made a live usb - installed Dragon theme
"mouse drag" and shift+prtsc worked perfectly there for me too - red translucent area in both.

Back to LM17 Cinnamon - installed delorean-dark theme -
"mouse drag" had the blue translucent area

but - shift+prtsc did this .........

Image

So now I know what you're experiencing.
Strange that delorean-dark does this, and Dragon theme does not (for me).

So, I might have been barking up the wrong tree changing .rubberband section of these themes.
Edit: No - for me - this was the right section to edit.
See blue section below


In delorean-dark (hopefully, we have the same version of the theme) - I did this:
delorean-dark > gtk-3.0 > gtk-widgets-assets.css
In * background * section at the top of the file -
in the .background section beginning line 23 - try commenting out the background-image line as indicated below

Code: Select all

.background {
	background-color: transparent;
	/*background-image: url("assets/WindowBg-dark.png");*/
}
or can also try this instead - just comment out the image and still keep the background-image part.

Code: Select all

.background {
	background-color: transparent;
  background-image: none;   /*url("assets/WindowBg-dark.png");*/
Save the file, logout/in

Try mouse drag and shift+prtsc again.
shift+prtsc changed to translucent blue for me after doing this.

See if it works for you with delorean-dark.[/color]

Edit: I (much) later discovered that the above edit to the .background sections in delorean-dark was unnecessary (for me anyway) - and editing the .rubberband section did work just the same as the .background edit, and possibly with less risk of inadvertently changing something else in the theme.

section beginning line 225 of gtk-3.0 > gtk-widgets.css
I added the line background-image: none;
so the section looked like this.

Code: Select all

.view.rubberband,
.rubberband {
    background-color: alpha (@theme_selected_bg_color, 0.35);
    background-image: none; 
    border-color: @theme_selected_bg_color;
    border-style: solid;
    border-width: 1px;
    border-radius: 2px;
}
[/color]

Doing the above edit to .rubberband section in delorean-dark gave the same result - the mouse-drag and shift+prtsc both had a blue translucent area.

The Dragon theme's gtk-widgets-assets.css file is different - that section is not there.

But, in Dragon > gtk-3.0 > gtk-widgets.css
beginning line 66 has similar references to .background with a different image:

Code: Select all

/***************
 * Base States *
 ***************/
.background,
GtkPaned {
    color: @theme_fg_color;
    background-color: transparent;
	background-image: url("assets/delorean-dark-bg.png");
    background-repeat: repeat;
    background-position: top left;
}

.background:backdrop,
GtkPaned:backdrop {
    color: shade(@theme_fg_color, 0.76);
    background-color: transparent;
	background-image: url("assets/delorean-backdrop-bg.png"); /*24x*/
    background-repeat: repeat;
    background-position: top left;
}
and in

Dragon > gtk-3.0 > gtk-widgets-dark-overrides.css at the very top of the file:

Code: Select all

.background, 
.background:backdrop,
GtkPaned,
GtkPaned:backdrop {
    color: @theme_fg_color;
    background-color: transparent;
	background-image: url("assets/delorean-darker-bg.png");
    background-repeat: repeat;
    background-position: top left;
}
Don't know if commenting out the background image line in those sections will have the same effect in Dragon.
Try them one at a time to see if it makes a difference.

PS. Sorry, don't know about the other problem ....
Last edited by caribriz on Wed Aug 27, 2014 4:57 am, edited 2 times in total.
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

KirbySmith wrote:For a related historical thread, there is:

http://forums.linuxmint.com/viewtopic.p ... 64#p694464

What is less historical is that the theme described in the link above that I had built for Mint 14 Cinnamon and saved in home before upgrading works great in Mint 17 MATE.

kirby
I found that my own Mint-blue theme (modified Mint-X) I made for LM14 also works ok in LM17 MATE.

In LM17 Cinnamon - the LM14 theme works but there are a few niggles.
Like the desktop icon text color is black instead of white, same with the menubar text color (in some apps), menu item spacing is a bit close compared to the latest Mint-X theme for LM17. But it is usable.

I've done Mint-X tweaks from 14 onwards using the new versions.
I found that the old versions of Mint-blue haven't all worked completely in the next release of Mint.
I think the Mint-blue theme I made for LM15 didn't look good in LM16 (Cinnamon) for example - the drop down/right-click menus had horizontal lines
- boxes outlining the menu items in them for one thing.

I like to take the current version of Mint-X for the new release and modify that. Then I know it works for sure.
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

aengusafton
Level 1
Level 1
Posts: 4
Joined: Sun Aug 24, 2014 1:33 am
Location: United States

Re: Help with theme colors

Post by aengusafton »

What you have do is copy radiance as backup and change setting.ini file in themes by using.

gksu gedit /usr/share/themes/Radiance/gtk-3/settings.ini
Edit:

nselected_bg_color:#f07746
So it says:

nselected_bg_color:#7FADFD
And do the same with gtk-2, using:

gksu gedit /usr/share/themes/Radiance/gtk-2/gtkrc
Otherwise gtk-2 applications like chrome etc will have old orange color and you are done. Reload the theme using gnome-tweak-tool.

Every GNOME-3 theme works with unity-3d perfectly but with 2D it has fallback window control problem when maximized (means in global panel it has fallback window controls which are ugly as hell, even the themes have unity folder in them and they work fine with 3D)

The colour used above [#7FADFD] is just one example of any number of hex colours that can be employed.

KirbySmith
Level 4
Level 4
Posts: 284
Joined: Sun Feb 03, 2013 10:25 pm

Re: Help with theme colors

Post by KirbySmith »

Strange, my desktop icon text color is white, but maybe I fixed that in Mint-X-neublue and forgot about it, or maybe the Mint-X-blue I started with used white. Note that my desktop background is the same color blue as I have used for accent colors in the menus and such: 3a6ea5. (This is the counterpart to the color I changed my work NT4 screen background to back in the '90s to escape Microsoft teal, and a blue color that is most harmonious with the central wallpaper photo of Todaiji at Nara.)

I also noticed with Mint 17 MATE that my complaint in my last message at the reference I gave above, "There is one anomaly, however, in the larger structure. While most places where the new blue is expected are presented as that color, tagging files or folders in Nemo yields a much darker blue color, almost black. This is also true of tagging text in gedit." no longer applies. Caja and pluma both conform to the defined color.

kirby
Desktop 1: DFI Lanparty UT nF4 SLI-D/AMD Athlon 64 San Diego/BFG GeForce 7800 GT/Mint 18.3 MATE
Desktop 2: Gigabyte 770T-USB3/AMD Phenom II X4 965/EVGA GeForce 9800 GT/Mint 18.3 MATE
HTPC: Asus C6H/AMD Ryzen 7 1800X, Asus Geforce 1080 Ti/Mint 18.3 MATE

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

Hi kirby,

Yes in LM17 mate, using my LM14 Mint-blue, the desktop icon text is white - but using (the old Mint-blue) in later versions of Cinnamon
displays differently for me (Nemo).

I'm surprised it still displays ok in the latest version of Mint, given the many changes that would have been made between 14 and 17.

You can see how much Mint-X has been revamped for LM17 compared with LM14, and this time I found it a bit more of an effort to do a similar blue "tweak" in LM17
than I did back in LM14. I mainly use Cinnamon, so I made my new LM17 version of Mint-blue in LM17 Cinnamon.

I guess time will tell if the old themes will still work as well in future versions.
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

KirbySmith
Level 4
Level 4
Posts: 284
Joined: Sun Feb 03, 2013 10:25 pm

Re: Help with theme colors

Post by KirbySmith »

Thanks for the clarification, caribriz. If I ever return to Cinnamon from MATE I'll have to look into your adaptation. Of course, there is always KDE Mint, which I believe is blue from the start.

k
Desktop 1: DFI Lanparty UT nF4 SLI-D/AMD Athlon 64 San Diego/BFG GeForce 7800 GT/Mint 18.3 MATE
Desktop 2: Gigabyte 770T-USB3/AMD Phenom II X4 965/EVGA GeForce 9800 GT/Mint 18.3 MATE
HTPC: Asus C6H/AMD Ryzen 7 1800X, Asus Geforce 1080 Ti/Mint 18.3 MATE

EvilSupahFly
Level 1
Level 1
Posts: 40
Joined: Sat May 24, 2014 11:10 am
Location: Mordor

Re: Help with theme colors

Post by EvilSupahFly »

caribriz wrote:
EvilSupahFly wrote:*** Edit ***
It's funny. It does the same thing with DeloreanDark, which seems to be what Dragon was based off going by the comments sections.

*** Edit 2 ***
Commenting out those sections didn't change anything, so now I'm experimenting with commenting out anything Unity-related in my "Dragon 2 - The Modified Version" theme to see if that yeilds results.
I've tried a few things -

Downloaded Ubuntu 14.04.1 - made a live usb - installed Dragon theme
"mouse drag" and shift+prtsc worked perfectly there for me too - red translucent area in both.

Back to LM17 Cinnamon - installed delorean-dark theme -
"mouse drag" had the blue translucent area

but - shift+prtsc did this .........

Image

So now I know what you're experiencing.
Strange that delorean-dark does this, and Dragon theme does not (for me).

So, I might have been barking up the wrong tree changing .rubberband section of these themes.

In delorean-dark (hopefully, we have the same version of the theme) - I did this:
delorean-dark > gtk-3.0 > gtk-widgets-assets.css
In * background * section at the top of the file -
in the .background section beginning line 23 - try commenting out the background-image line as indicated below

Code: Select all

.background {
	background-color: transparent;
	/*background-image: url("assets/WindowBg-dark.png");*/
}
or can also try this instead - just comment out the image and still keep the background-image part.

Code: Select all

.background {
	background-color: transparent;
  background-image: none;   /*url("assets/WindowBg-dark.png");*/
Save the file, logout/in

Try mouse drag and shift+prtsc again.
shift+prtsc changed to translucent blue for me after doing this.

See if it works for you with delorean-dark.

The Dragon theme's gtk-widgets-assets.css file is different - that section is not there.

But, in Dragon > gtk-3.0 > gtk-widgets.css
beginning line 66 has similar references to .background with a different image:

Code: Select all

/***************
 * Base States *
 ***************/
.background,
GtkPaned {
    color: @theme_fg_color;
    background-color: transparent;
	background-image: url("assets/delorean-dark-bg.png");
    background-repeat: repeat;
    background-position: top left;
}

.background:backdrop,
GtkPaned:backdrop {
    color: shade(@theme_fg_color, 0.76);
    background-color: transparent;
	background-image: url("assets/delorean-backdrop-bg.png"); /*24x*/
    background-repeat: repeat;
    background-position: top left;
}
and in

Dragon > gtk-3.0 > gtk-widgets-dark-overrides.css at the very top of the file:

Code: Select all

.background, 
.background:backdrop,
GtkPaned,
GtkPaned:backdrop {
    color: @theme_fg_color;
    background-color: transparent;
	background-image: url("assets/delorean-darker-bg.png");
    background-repeat: repeat;
    background-position: top left;
}
Don't know if commenting out the background image line in those sections will have the same effect in Dragon.
Try them one at a time to see if it makes a difference.

PS. Sorry, don't know about the other problem ....
My friend, you are a genius, and a rival of the gods themselves!

With regard to the Dragon theme:
Well, I commented out the url() portion, making background-image: none; and it's left me with the red outline, but no shading in the box with shift+prtscr, which is much better, because at least now I can see what I'm selecting!

With regard to DeLorean Dark:
I renamed the files listed as the background images and replaced them with alpha-channel-only versions of their former selves, and it's all good there too. Same effect as with Dragon: outline only, with no more solid box!

As for the other problem, well, it's very minor at best, and I'm sure I'll figure it out eventually, or just start a new thread elsewhere for it. You have been loads of help! Thanks muchly! :D :D :D
If I had a signature, this is where I'd stick it.

caribriz
Level 5
Level 5
Posts: 938
Joined: Mon Nov 28, 2011 7:43 am

Re: Help with theme colors

Post by caribriz »

EvilSupahFly wrote:....With regard to the Dragon theme:
Well, I commented out the url() portion, making background-image: none; and it's left me with the red outline, but no shading in the box with shift+prtscr, which is much better, because at least now I can see what I'm selecting!

With regard to DeLorean Dark:
I renamed the files listed as the background images and replaced them with alpha-channel-only versions of their former selves, and it's all good there too. Same effect as with Dragon: outline only, with no more solid box!
Well, it was a bit unexpected that you'd have to do all that to get rid of that pesky box - but it looks like you have created a workable solution :)
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 18.3 Cinnamon)

Post Reply

Return to “Cinnamon”