mdm won't start after nvidia installation

Please post suggestions for improvement of Cinnamon here
Level 1
Level 1
Posts: 1
Joined: Fri Aug 30, 2013 4:45 pm

mdm won't start after nvidia installation

Postby Oros » Fri Aug 30, 2013 4:52 pm

In desperate help. I tried to install the drivers for my graphic card by stopping mdm, running "sudo bash ./" and then restarted the computer.
When I started the computer again, I could only see the "linux mint" loading screen, and then it said something about xorg could not load. Tried to copy the log-files to a usb, but when I started the other partition (windows 7) I could no longer see the files. the usb is a ext32 filesystem....
Any thought? Could really use some help :)
Edit: It says the fatal error is that x could find any screen.
Edit2: Noticed the logfiles I tried to copy was still in a folder under /media, even though the usb was not plugged in. Tried to plug it in and re-ran ls... nothing. Did "df -h" but there were no other filesystem except for the once running atm.

Level 5
Level 5
Posts: 777
Joined: Wed Jul 11, 2012 4:10 pm

Re: mdm won't start after nvidia installation

Postby trapperjohn » Fri Aug 30, 2013 7:05 pm

I assume the driver install completed with any errors and you have, by some means, disabled nouveau at boot. Can you get to a command prompt? [cntl][alt][f1]

Have you run:
sudo nvidia-xconfig

Specifically, what graphics card are you using?
lspci | grep NVIDIA

User avatar
Level 17
Level 17
Posts: 7948
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: mdm won't start after nvidia installation

Postby karlchen » Fri Aug 30, 2013 7:16 pm

Hello, Oros.

About the USB pendrive problems:
As you wish to use the pendrive on Mint and Windows format it to FAT32, because this filesystem can be read and written by Mint and Windows. You may also format it to NTFS, because this filesystem can be read and written by Mint and Windows, too. But to not use any filesystem type on it like ext2, ext3 or ext4, which is only known by Linux operating systems.

When the pendrive has been mounted on Mint, /media is just the parent folder of the mount point.
The pendrive will be mounted as /media/name_of_pendrive or /media/volume_number_of_pendrive. This i true up to Mint 13.
Starting with Mint 14, the mount points will be /media/Oros/name_of_pendrive or /media/Oros/volume_number_of_pendrive.
I.e. the will be a subfolder under /media having your Mint account name.
Below this subfolder will be the subfolder which corresponds to the root folder of the pendrive.
So do not write anything to /media. /media is located on the local harddrive of your machine.

About the problems affecting your graphical subsystem:
Have you used Synaptic package manager to verify that the NVidia driver which you wanted to install is not available through the official Ubuntu repositories? Installing from there causes less hassle as a rule.
Which Nvidia driver exactly did you install?
Which Nvidia card have you got exactly?
Have you verified that your card is supported by this driver?
Which graphics driver was in use before you tried to install the NVidia driver?

Please, login to the machine and execute

Code: Select all

inxi -Gx
Write down the name of the graphics card and post it here, please. Write down the name of the used driver and post it here, please.
Collect the logfile /var/log/dmesg, /var/log/syslog and ~/.xessions-errors and copy them to the USB pendrive so that you will be able to inspect them for error messages which give a hint what is wrong. In particular lines talking about NVRM and nvidia will be of interest.

Kind regards,

Kind regards,
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

Return to “Cinnamon”

Who is online

Users browsing this forum: CalvinHobbes, hpc and 4 guests