Cinnamon 2 - brightness

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
amey01
Level 1
Level 1
Posts: 11
Joined: Sat May 04, 2013 6:37 pm

Cinnamon 2 - brightness

Postby amey01 » Sat Nov 30, 2013 3:59 pm

I've always had a problem where Mint will remain on 100% brightness after every boot. I've solved this problem in the past by using a command gdbus call --session --dest org.gnome.SettingsDaemon --object-path /org/gnome/SettingsDaemon/Power --method org.gnome.SettingsDaemon.Power.Screen.SetPercentage 70.

Alas - org.gnome.settingsDaemon.power.screen does not exist in Cinnamon2.

So what are the alternatives?

User avatar
hexdef101
Level 4
Level 4
Posts: 357
Joined: Sat Oct 09, 2010 5:43 pm

Re: Cinnamon 2 - brightness

Postby hexdef101 » Sat Nov 30, 2013 5:30 pm

I posted about this a while ago anyway...... go here this will work wonders http://forums.linuxmint.com/viewtopic.php?f=148&t=146824
Image

amey01
Level 1
Level 1
Posts: 11
Joined: Sat May 04, 2013 6:37 pm

Re: Cinnamon 2 - brightness

Postby amey01 » Sun Dec 01, 2013 1:30 am

hexdef101 wrote:I posted about this a while ago anyway...... go here this will work wonders http://forums.linuxmint.com/viewtopic.php?f=148&t=146824


It doesn't work sorry - xbacklight does nothing whether run in startup or directly on the command line.

User avatar
hexdef101
Level 4
Level 4
Posts: 357
Joined: Sat Oct 09, 2010 5:43 pm

Re: Cinnamon 2 - brightness

Postby hexdef101 » Mon Dec 09, 2013 5:52 pm

hmmm must be a different issue then. Thats the exact solution I use on my system. :? Sorry it didn't help.


Are you using an Intel chipset or Nvidia ? I suppose it could be a wonky driver.
Image

wub
Level 1
Level 1
Posts: 29
Joined: Mon Jan 02, 2012 4:19 pm

Re: Cinnamon 2 - brightness

Postby wub » Tue Dec 17, 2013 2:10 am

The brightness controls may be working on the wrong backlight device. I have Mint 13 installed, and under /sys/class/backlight, I find one subdirectory, intel_brightness. Stuff works. But when I boot from a Mint 15 or Mint 16 live CD, my system is stuck at full brightness. Now when I look under /sys/class/backlight, I find both intel_backlight and acpi_backlight.

Long story short, all the various brightness controls I can find operate on settings in acpi_backlight. The settings really change, but the screen does not. However, if I use "echo > " to change the settings under intel_backlight, I regain control of the screen brightness. I have not been able to figure out what the right way to get rid of the acpi_backlight subdirectory is.

User avatar
hexdef101
Level 4
Level 4
Posts: 357
Joined: Sat Oct 09, 2010 5:43 pm

Re: Cinnamon 2 - brightness

Postby hexdef101 » Thu Dec 19, 2013 1:25 am

That might be it. I seem to have three though, the other is for manufacturer.


Edit: this is a Kernel issue, Its not a LM issue. seems to be common irregardless of distro. I have seen reports that its been fixed in ver 3.9.x
Image

wub
Level 1
Level 1
Posts: 29
Joined: Mon Jan 02, 2012 4:19 pm

Re: Cinnamon 2 - brightness

Postby wub » Thu Dec 19, 2013 7:43 pm

Yeah, I've been wondering where the most effective place to file a bug would be... I'm not sure it's not a kernel thing, but after reading the archwiki page on backlights (https://wiki.archlinux.org/index.php/backlight), I think that proper configuration of X11 might be a way to address this.

There are several screen-related utilities mentioned at the bottom of that wiki page, among them xbacklight, which works nicely for me - it's a lot easier than echoing a number as root, although it is still a command-line call. What I found odd is that xbacklight is related to xrandr, but while xbacklight works fine, xrandr always tells me the screen is at 100% brightness, no matter what is really going on.

I did find that my xorg.conf file contains this:

Section "Device"
Identifier "Configured Video Device"
Driver "intel"
EndSection

which I do not recall adding (although I may have).

Naturally, I also found " acpi_osi=Linux acpi_backlight=vendor " among the parameters that grub passes to my kernel when I boot. Very confusing.

I am tempted to follow through and add the "Option "backlight" line to that Device section I found, just to see if that helps at all.
I guess I am going to have to learn more about ACPI, which I have actively avoided doing up to now. This is all very confusing.

I have to remember to give credit the the Arch folks - I've always used the Ubuntu forums as another place to find out how to fix problems, but there sure is a lot of useful information on the Arck wiki.

User avatar
wanderer7
Level 4
Level 4
Posts: 258
Joined: Mon Oct 28, 2013 3:13 pm

Re: Cinnamon 2 - brightness

Postby wanderer7 » Mon Dec 23, 2013 2:53 am

I have the same problem. In Mint 15, I could solve the problem. In terminal I would type:

Code: Select all

gedit ~/.lowerbrightness.sh

Then in gedit:

Code: Select all

#!/bin/sh
#change brightness setting on startup or resume
pkexec /usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness 5

Instead of 5 in the end, I could choose any number from 1 to 10. Save it, go to my home folder, make .lowerbrightness executable from properties and then type this command in terminal:

Code: Select all

gsettings set org.gnome.settings-daemon.peripherals.input-devices hotplug-command "/home/USERNAME/.lowerbrightness.sh"

With USERNAME replaced with my own username.

However, this trick doesn't work in Mint 16. And changing brightness manually, every time I boot the PC is getting very annoying. I guess, it's not Mint developers' fault, but someone should fix it, right? Is it that difficult to take input from the user, save it somewhere on the hard disk, and then read the saved value during the boot up?! This bug has been around for too long. The system simply doesn't remember brightness settings.
Time goes on and people write some fancy, eye-pleasing programs, which the users might need only once in a month or even a year. On the other hand, I need correct brightness, every time I start my computer. Is this difficult to understand?
I don't know, who is responsible for this bug, but someone has to fix it.
Temporarily, a little script would be enough too. If any of you, reading this post, know something about programming/coding please help us: help hundreds of thousands GNU/Linux users, who experience this persistent brightness problem, but love thier OS no matter what. :wink:

User avatar
roblm
Level 8
Level 8
Posts: 2353
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cinnamon 2 - brightness

Postby roblm » Tue Dec 24, 2013 3:34 pm

wanderer7,

Check this topic:
viewtopic.php?f=49&t=153672

User avatar
wanderer7
Level 4
Level 4
Posts: 258
Joined: Mon Oct 28, 2013 3:13 pm

Re: Cinnamon 2 - brightness

Postby wanderer7 » Tue Dec 24, 2013 3:59 pm

roblm wrote:wanderer7,

Check this topic:
viewtopic.php?f=49&t=153672

Thanks, roblm. I'll try everything you've written in another thread and tell you if it works for me. The user you responded to, has another problem though. He has to reboot in order to change brightness. Me, I can change it, but it doesn't stay the same, so I have to adjust it every time I start the computer.

User avatar
roblm
Level 8
Level 8
Posts: 2353
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cinnamon 2 - brightness

Postby roblm » Tue Dec 24, 2013 5:12 pm

wanderer7,

Did you also try using xbacklight? amey01 said it didn't work for him.

User avatar
wanderer7
Level 4
Level 4
Posts: 258
Joined: Mon Oct 28, 2013 3:13 pm

Re: Cinnamon 2 - brightness

Postby wanderer7 » Wed Dec 25, 2013 11:46 am

roblm wrote:wanderer7,

Did you also try using xbacklight? amey01 said it didn't work for him.

xbacklight works, but I can change brightness without it too: with Fn+arrow keys. The problem is that I have to change it manually every time I start the computer. I tried the 'grub' method too, but it's not for me I guess. :?

It seems I have to live with it for now and wait until one day this bug is fixed. I just hoped in Mint 16, I wouldn't have to deal with it again. Here people were saying that it is a kernel related bug, but I don't think so. During my distro-wandering I tried Netrunner too. It's a kubuntu based distro. And Netrunner used to remeber my brightness settings.

Oh, I almost forgot, Merry Christmas! :D

User avatar
roblm
Level 8
Level 8
Posts: 2353
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cinnamon 2 - brightness

Postby roblm » Wed Dec 25, 2013 12:47 pm

wanderer7,

You can add a startup program to keep the brightness setting persistent after restarting. First find the right setting by
opening the Terminal and typing: xbacklight -set 80
The value can be from 5 to 100. If the setting is not right then increase or decrease the value by 5 or 10 at a time.

Then go to Menu → Preferences → Startup Applications. Click on "Add". In the new window, under "Name" you can put
"Brightness". In the "Command" window put: xbacklight -set X
where X is the value you got from testing.

Click save. Reboot and test the setting. If the setting needs to be changed then go back into "Startup Applications" and edit
the startup command.

Another method is if you have an Nvidia proprietary driver installed then you can set the brightness using the Nvidia Settings
Utility (Mint 16) or manually editing it's configuration file “.nvidia-settings.rc” (Mint 14 and 15). For radeon proprietary drivers,
the Catalyst Control Center may work.

Another method is creating a script like you previously used that runs at startup but using a different command. You would
first need to post the output of this command: cat /sys/class/backlight/acpi_video0/max_brightness
or if that gives no result then: ls /sys/class/backlight/*/*

The last method is using the udev kernel event manager. You would need to get scancodes as described in the link I gave in a
previous post.

User avatar
wanderer7
Level 4
Level 4
Posts: 258
Joined: Mon Oct 28, 2013 3:13 pm

Re: Cinnamon 2 - brightness

Postby wanderer7 » Thu Dec 26, 2013 1:57 pm

roblm wrote:wanderer7,

You can add a startup program to keep the brightness setting persistent after restarting. First find the right setting by
opening the Terminal and typing: xbacklight -set 80
The value can be from 5 to 100. If the setting is not right then increase or decrease the value by 5 or 10 at a time.

Then go to Menu → Preferences → Startup Applications. Click on "Add". In the new window, under "Name" you can put
"Brightness". In the "Command" window put: xbacklight -set X
where X is the value you got from testing.

Click save. Reboot and test the setting. If the setting needs to be changed then go back into "Startup Applications" and edit
the startup command.


You're a genius, this worked!! :D roblm, I can't thank you enough. This method is so simple and effective at the same time. So, it seems, there was no need to write scripts, I could have done this earlier. Thank you very much! :D :D

User avatar
roblm
Level 8
Level 8
Posts: 2353
Joined: Sun Feb 24, 2013 2:41 pm

Re: Cinnamon 2 - brightness

Postby roblm » Thu Dec 26, 2013 9:35 pm

wanderer7,

The method you used in Mint 15 to set the brightness worked for Wayne1953 when he added it to Startup Applications.
Check this link:
viewtopic.php?f=90&t=154180

User avatar
wanderer7
Level 4
Level 4
Posts: 258
Joined: Mon Oct 28, 2013 3:13 pm

Re: Cinnamon 2 - brightness

Postby wanderer7 » Fri Dec 27, 2013 2:33 am

roblm wrote:wanderer7,

The method you used in Mint 15 to set the brightness worked for Wayne1953 when he added it to Startup Applications.
Check this link:
viewtopic.php?f=90&t=154180

:D


Return to “Cinnamon”

Who is online

Users browsing this forum: No registered users and 2 guests