XRDP / vino connect creates screwed up desktops

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
reapur
Level 1
Level 1
Posts: 3
Joined: Tue Mar 23, 2010 10:28 am

XRDP / vino connect creates screwed up desktops

Post by reapur »

Hi Guys,
apologies if this has been covered. I can't search on xrdp, the search requires each word has 5 characters in it and won't let me search.
"The following words in your search query were ignored because they are too common words: xrdp.
You must specify at least one word to search for. Each word must consist of at least 5 characters and must not contain more than 14 characters excluding wildcards."
weird.

Anyway I'm hoping someone can help with this problem.
I've tried this ONLY on VMs in vmware player. I've used cinnamon, and mate
I do have this working on centos and fedora, so I have gathered a little experience in this...

I install from scratch.
sudo apt-get update
sudo apt-get install xrdp
vino-preferences
sudo vino-preferences
reboot
now I can use windows RDP or mobaxterm
When I connect to vnc, it looks OK.
when I connect to xrdp (console) I get a fuzzy wavy desktop
Image

Very consistent. I can't figure out how to fix this.
Any ideas?
Many thanks

Tim-int
Level 1
Level 1
Posts: 46
Joined: Tue Nov 29, 2011 2:30 pm

Re: XRDP / vino connect creates screwed up desktops

Post by Tim-int »

Please read http://forum.linuxmint.com/viewtopic.php?f=208&t=173739
Try to add packages vnc4server and tightvncserver because xrdp only recommends them but doesn't depend on them. Even with that, I get "Do you want to restart Cinnamon? Cinnamon just crashed. You are currently running in Fallback mode". Other environments work better, so you can use XFCE.

Post Reply

Return to “Cinnamon”