Hibernate gone AWOL

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
Sgt Peppermint
Level 1
Level 1
Posts: 37
Joined: Wed Apr 16, 2014 5:58 am

Hibernate gone AWOL

Post by Sgt Peppermint »

I've just installed 17 over 16 and have noticed that the Hibernate option has disappeared. It's also greyed out in the Power Management options if I was to try to, say, set what happens when I close the lid of the laptop.

How do I get it back?
User avatar
Kalyk
Level 5
Level 5
Posts: 770
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Hibernate gone AWOL

Post by Kalyk »

Problem might be the swapfile isn't as big as or bigger then the internal memory.
Or more likely: the swapfile isn't active.
See if the swapfile is mounted while booting, it should be in /etc/fstab.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
Sgt Peppermint
Level 1
Level 1
Posts: 37
Joined: Wed Apr 16, 2014 5:58 am

Re: Hibernate gone AWOL

Post by Sgt Peppermint »

Thanks. However, I did a clean install (including a partition format) and that seems to have cured the problem.
ratcat
Level 1
Level 1
Posts: 45
Joined: Fri Aug 21, 2009 10:51 pm

Re: Hibernate gone AWOL

Post by ratcat »

Mine is gone too. Swapfile partition active and of adequate size and fstab appears to have the correct info per directions I found online UUID number seems correct. I've done a few installs mostly because I tend to screw things up but have not had the hibernate button at any time. I can see the button when booted from DVD.
ratcat
Level 1
Level 1
Posts: 45
Joined: Fri Aug 21, 2009 10:51 pm

Re: Hibernate gone AWOL

Post by ratcat »

Any other ideas?
User avatar
Kalyk
Level 5
Level 5
Posts: 770
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Hibernate gone AWOL

Post by Kalyk »

Hi,

Did some searching and found this post.
http://forums.linuxmint.com/viewtopic.php?f=42&t=154442
Where they use kate you should use gedit .
So in short:
Try if hibernation can work by typing: sudo pm-hibernate
Then do: sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
Replace the contents with:
[Enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Please post if this solves your problem.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
User avatar
martywd
Level 3
Level 3
Posts: 147
Joined: Sun May 08, 2011 10:35 am
Location: TX

Re: Hibernate gone AWOL

Post by martywd »

ratcat wrote:Mine is gone too. Swapfile partition active and of adequate size and fstab appears to have the correct info per directions I found online UUID number seems correct. I've done a few installs mostly because I tend to screw things up but have not had the hibernate button at any time. I can see the button when booted from DVD.
ratcat wrote: ... on 03 Jun 2014, 10:12
Any other ideas?
I asked this question recently on the blog annoucement for LM17 MATE ... http://blog.linuxmint.com/?p=2627#comment-109515 . I'm still waiting for a response ....

Ok, now that I've editorialized a bit.

Here's what I did on the LM17 MATE RC 64-bit machines where 'Hibernate' was 'missing'... Maybe this works for Cinnamon as well? I don't know?

Look at the contents of the following file:

Code: Select all

/etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
_Without_ the 'Hibernate' button, the contents should look like the following:

Code: Select all

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
**Make backup of file first!** To get the 'Hibernate' button (and functionality) to show ... edit and add text so 'com.ubuntu.enable-hibernate.pkla' looks like this:

Code: Select all

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes
Save and close file.

By doing this I was able to get 'Hibernate' which was missing in my LM17 MATE RC 64-bit installs.



Conversely. By eliminating the following lines from the 'com.ubuntu.enable-hibernate.pkla' on a fresh install of final release of LM17 MATE:

Code: Select all

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes
I was able to remove the 'Hibernate' option on a Desktop where hibernate was unwanted and not needed.


.
User avatar
martywd
Level 3
Level 3
Posts: 147
Joined: Sun May 08, 2011 10:35 am
Location: TX

Re: Hibernate gone AWOL

Post by martywd »

Kalyk wrote:Hi,
Did some searching and found this post.
Hey Kalyk,

Apologies. Didn't mean to step all over your post. Unfortunately your post wasn't showing up when I posted my suggestion.
.
ratcat
Level 1
Level 1
Posts: 45
Joined: Fri Aug 21, 2009 10:51 pm

Re: Hibernate gone AWOL

Post by ratcat »

Well first off let me say thanks a bunch! The problem is solved and I will mark it as such. I found my file "/etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla" to look like this:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

So I added:

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

I apparently didn't have gkedit installed so I substituted "gksudo pluma" for the "sudo gkedit" I used the gk as I had read that launching pluma with sudo could cause permission problems. I get a big kick out of fixing this stuff even though I only somewhat understand it. So there were some pluma warnings in the terminal window when I was done about permissions and files or folders that did not exist, but hopefully I did not introduce any new issues! So my hibernate button is back and appears to be working. Thanks!
User avatar
Kalyk
Level 5
Level 5
Posts: 770
Joined: Wed Mar 12, 2014 5:29 pm
Location: The Netherlands

Re: Hibernate gone AWOL

Post by Kalyk »

Good for you redcat.

And about stepping over my post, martywd, your post had the answer where mine only had a hint in that direction, so good for you :)
I don't fully understand because I have the configuration mentioned in my post that works, so there are probably a few other factors that have some relevancy in this problem.
Add (Solved) to the topic-title of the first post when appropriate so others know they might find a solution here.
ratcat
Level 1
Level 1
Posts: 45
Joined: Fri Aug 21, 2009 10:51 pm

Re: Hibernate gone AWOL

Post by ratcat »

So a little update and FYI for those who may have experienced this problem. I was able to get hibernate working thanks to the advice on this thread, but when resuming wifi was disabled. I tried a few solutions I found online and was unable to solve the problem. I decided to just reinstall LM17 Mate since the final release was released and lo and behold everything works perfectly! Hibernate works and resumes with wifi functional. So for me maybe the lesson learned was forgo release candidates and wait for full releases. I did learn quite a bit about how linux works in the process, so that was good, and I'm considering trying the XFCE version once its released as my computer seems a bit slow with Mate. It was unbearable with Cinnamon. So the adventure continues. I just wanted to say thanks for all the help and give a little update on my progress.
Cheers
Jeff
Post Reply

Return to “Cinnamon”