Boot & theme issues with Cinnamon.

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
User avatar
gtsfer
Level 7
Level 7
Posts: 1912
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Boot & theme issues with Cinnamon. Think I drove it nuts

Post by gtsfer »

expat_tony wrote:Maybe we could even identify the update we received that caused the trouble. It'll be a September one. Is there such an archive?
In Update Manager, View -> History of Updates. Sometimes this doesn't include everything from day one, but it should be enough for your purposes. If not, then /var/log/apt has a history file too. (plus some compressed history.log files as these get rotated and archived over time by the system).
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240
expat_tony
Level 4
Level 4
Posts: 283
Joined: Thu Mar 27, 2014 6:52 pm

Re: Boot & theme issues with Cinnamon.

Post by expat_tony »

Of course, to get at the Update Manager or the /var/... , I have to be able to see them. But all I can get to see at the moment are the live boot versions. The /var/log/apt/history.log starts and ends on 29th May - LM17 release day. Hmmmm.
User avatar
gtsfer
Level 7
Level 7
Posts: 1912
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Boot & theme issues with Cinnamon.

Post by gtsfer »

So you can't boot into Cinnamon at all now? You can still see Cinnamon's /var/log/apt from a live session, but you might have to mount the partition by clicking on it in file manager. It should be there though no matter what. If Cinnamon is that unusable, then you know what time it is, right?
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240
expat_tony
Level 4
Level 4
Posts: 283
Joined: Thu Mar 27, 2014 6:52 pm

Re: Boot & theme issues with Cinnamon.

Post by expat_tony »

I tried once before with sda1 mounted, but didn't get the hidden directories. Now I have, and got to the history.log...but it only goes up to 8th September, and that's before the date the trouble started. But let me check that.
EDIT: Yes, it started on Sept 11th. No jokes about that please. The archive files are monthly, to 31st July & 31st August.
Have you read my opening post of http://forums.linuxmint.com/viewtopic.p ... 6&p=922667 ? Especially my questions.
User avatar
gtsfer
Level 7
Level 7
Posts: 1912
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Boot & theme issues with Cinnamon.

Post by gtsfer »

I just saw it. You have multiple problems, between all these threads
- Partitions still look funky (what are sdb10 and sdb11? they look identical). SOLVED: Gparted Unallocated Space
- Cinnamon Desktop http://forums.linuxmint.com/viewtopic.p ... 8&t=177987
- Lost Grub, but easily fixable. http://forums.linuxmint.com/viewtopic.p ... 6&p=922667

If it were me, I'd forget about how I got there and get ready to re-install.

1) Do you have an external hard disk or something that will hold /home?
2) Did you back up /home already or didn't get around to it yet?

You can back up /home a couple of ways, then boot live mode. Clean up that hard completely (except for Windows) and start over. Make new partitions for root, swap and home. Restore home from backup first. Then reinstall, but do not format home.

You can use Gparted to back up home if you haven't already. Or just use "copy" or a backup tool. Some of might be a good reference...
http://forums.linuxmint.com/viewtopic.p ... 97#p915905

EDIT: I did it more than once, in fact over a dozen times when I first started with Linux. :D It's part of the learning curve.
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240
Falconus
Level 1
Level 1
Posts: 26
Joined: Thu Sep 02, 2010 8:11 pm

Re: Boot & theme issues with Cinnamon.

Post by Falconus »

For what it's worth (and I don't know if it is related), on September 11, my desktop background defaulted to the LinuxMint wallpaper, although I haven't noticed any other problems with Cinnamon or with my terminal. I definitely was not messing around with any settings. I have been keeping up with the level 1-3 updates, and I know that there have been a bunch this week.

I also don't know if this could be related, but I have noticed that when a program freezes (like Skype), and I go to shut down the computer, the appearance of my computer changes as described in this post (older icons, windows have that older feel), and then I usually end up hitting F1, logging in as root and doing 'shutdown -P now'. I haven't bothered filing any kind of bug report because it wasn't a big deal to me, but I just mention it here in case it could be a result of the same issue.

I also have nvidia.

Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
Card-2: NVIDIA GF108M [GeForce GT 540M] bus-ID: 01:00.0
X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1920x1080@60.0hz, 1280x1024@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
User avatar
gtsfer
Level 7
Level 7
Posts: 1912
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Boot & theme issues with Cinnamon.

Post by gtsfer »

Falconus wrote:Card-2: NVIDIA GF108M [GeForce GT 540M] bus-ID: 01:00.0
X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1920x1080@60.0hz, 1280x1024@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
You don't have any nVidia driver loaded yet though. Fwiw...
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240
Falconus
Level 1
Level 1
Posts: 26
Joined: Thu Sep 02, 2010 8:11 pm

Re: Boot & theme issues with Cinnamon.

Post by Falconus »

gtsfer wrote:
Falconus wrote:Card-2: NVIDIA GF108M [GeForce GT 540M] bus-ID: 01:00.0
X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1920x1080@60.0hz, 1280x1024@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
You don't have any nVidia driver loaded yet though. Fwiw...
Oh, yeah... Thanks for pointing that out.
expat_tony
Level 4
Level 4
Posts: 283
Joined: Thu Mar 27, 2014 6:52 pm

Re: Boot & theme issues with Cinnamon.

Post by expat_tony »

How can we find out if this probable bug has been reported? If it hasn't been, whose responsibility is it to report? I wouldn't have the first clue about how and what info would be needed. I think it's a technical form to fill in - beyond me, probably.
buckethead
Level 1
Level 1
Posts: 9
Joined: Sat Jan 26, 2008 2:47 pm

Re: Boot & theme issues with Cinnamon.

Post by buckethead »

looks like your theme issues are related to mine and others here:
http://forum.linuxmint.com/viewtopic.php?f=208&t=175517
though I don't think it's nvidia related as I'm running ati graphics
User avatar
gtsfer
Level 7
Level 7
Posts: 1912
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Boot & theme issues with Cinnamon.

Post by gtsfer »

expat_tony wrote:How can we find out if this probable bug has been reported? If it hasn't been, whose responsibility is it to report? I wouldn't have the first clue about how and what info would be needed. I think it's a technical form to fill in - beyond me, probably.
Where's that link to the article about the Ubuntu update possibly causing this with nvidia drivers? Post that link back here if you can find it. Bugs for Ubuntu would go somewhere on Launchpad I guess. I haven't searched to see if it exists yet, I want to see that article again. There might be more info in there. https://launchpad.net/ubuntu/+bugs
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240
expat_tony
Level 4
Level 4
Posts: 283
Joined: Thu Mar 27, 2014 6:52 pm

Re: Boot & theme issues with Cinnamon.

Post by expat_tony »

gtsfer wrote:Where's that link to the article about the Ubuntu update possibly causing this with nvidia drivers?
It's the very last post on page 1 of this thread, for your convenience click on http://www.webupd8.org/2014/09/recent-u ... op-on.html.

And there's link to here: https://bugs.launchpad.net/ubuntu/+sour ... ug/1365695, which is the full Ubuntu bug report. Several nVidia versions are affected incl. 331 that I have. The report contains a full listing of the package update that appears to have created the bug on 3rd Sept 2014. Somewhere in Mint updates since then, says the theory, we will find an equivalent file that did the same to us.
User avatar
gtsfer
Level 7
Level 7
Posts: 1912
Joined: Mon May 27, 2013 9:15 am
Location: Bucks County PA, USA

Re: Boot & theme issues with Cinnamon.

Post by gtsfer »

Thanks for both of those links Tony. I was getting a little lazy and annoyed at something unrelated, so I let you do the work. :wink: It appears that this is definitely tied to nVidia now and the bug report sure does exist. Something else must be involved with those updates that sets it off.

Also, I have not seen it on my Cinnamon install running the 304.117 driver. I guess it affects some systems and not others and they're still trying to figure some of it out.
"There is no gravity, the earth sucks." - Issac Newton @ 75
KDE & Cinnamon 18.1 & Win 10 - ASUS M5A99FX PRO MB, AMD FX-8370 Octo-Core CPU, 16GB RAM, AMD Radeon R7 240
Scott65
Level 2
Level 2
Posts: 51
Joined: Tue Apr 03, 2012 5:05 pm

Re: Boot & theme issues with Cinnamon.

Post by Scott65 »

I have these same issues using the recommended 304.117 driver -- I went back to the video nouveau driver until this is resolved...
Post Reply

Return to “Cinnamon”