Random missing characters everywhere

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
kev51773
Level 1
Level 1
Posts: 9
Joined: Mon Feb 23, 2015 4:48 pm

Random missing characters everywhere

Post by kev51773 »

I've been using Linux Mint Cinnamon 17.1 happily for a month or so now. As of today I've started seeing random missing characters everywhere. It happens in most (but not all) programs and menus. ie It never happens in Chrome but it always happens in Firefox, GIMP. It doesn't happen in the main Mint start menu but it does happen all throughout the system settings menu and in Nemo.
Sometimes moving my mouse over them makes the letters reappear, sometimes clicking on the window makes them reappear. Sometimes nothing works at all.

I've attached a screenshot where I've underlined several instances to give you an idea.


Any thoughts anyone?
Attachments
MissingLetters.jpg
kev51773
Level 1
Level 1
Posts: 9
Joined: Mon Feb 23, 2015 4:48 pm

Re: Random missing characters everywhere

Post by kev51773 »

Actually, I've fixed this now.

All I had to do was change Fonts from 'Noto Sans' to 'Sans'. The problem then went away. I then changed back to 'Noto Sans' and the problem was still gone.

For future reference I'd still be interested in knowing the cause of this problem if anyone has any idea.

Thanks anyway.
Cosmo.
Level 23
Level 23
Posts: 17817
Joined: Sat Dec 06, 2014 7:34 am

Re: Random missing characters everywhere

Post by Cosmo. »

Fine that you fixed it.

Was this a fresh new installation of 17.1 or an upgrade from 17 ?
iraklisg
Level 1
Level 1
Posts: 2
Joined: Mon Mar 03, 2014 7:33 am

Re: Random missing characters everywhere

Post by iraklisg »

Same problem here. I followed kev51773's solution and the problem seems to have been solved, at the moment.
If the problem came up again there a shall inform you
OS: Linux Mint Cinnamon 17.1 64bit
GryphonX77
Level 1
Level 1
Posts: 23
Joined: Tue Dec 13, 2016 3:58 am

Re: Random missing characters everywhere

Post by GryphonX77 »

Confirmed here. I had the same issue; I followed these instructions, and so far, so good. Also running i915 graphics.
.:gryphon
GryphonX77
Level 1
Level 1
Posts: 23
Joined: Tue Dec 13, 2016 3:58 am

Re: Random missing characters everywhere

Post by GryphonX77 »

So, this solution didn't totally fix the problem, but it got better.

Unfortunately, after upgrading to Serena, it got worse. When I resumed, the login screen had no text whatsoever. After logging in, there was no text on the screen at all. I tried suspending and resuming again...no love. I had to do the "three finger salute" and restart X. Very frustrating. I'm glad I didn't have any work going on.
.:gryphon
GryphonX77
Level 1
Level 1
Posts: 23
Joined: Tue Dec 13, 2016 3:58 am

Re: Random missing characters everywhere

Post by GryphonX77 »

As a follow-up, I installed Mate. Problem solved. :) And there seems to be no issues switching between DEs. I recommend installing Compiz if you want the eye candy (and compiz settings manager as well).
.:gryphon
reggieb
Level 1
Level 1
Posts: 5
Joined: Thu Feb 27, 2014 8:45 am

Re: Random missing characters everywhere

Post by reggieb »

I've had a similar problem - with `M` characters disappearing. Switching from 'Noto Sans' to 'San' fixed the problem. However, returning to 'Noto Sans' and the problem returns.
lite1979
Level 1
Level 1
Posts: 1
Joined: Wed Aug 02, 2017 12:52 am

Re: Random missing characters everywhere

Post by lite1979 »

For what it's worth, I just had this happen to me on 18. Changing the fonts didn't help me, but chaning my anti-aliasing to either 'grayscale' or 'none' brought the letters back in my taskbar and mint menu... :)
Post Reply

Return to “Cinnamon”