Workspace switching + fullscreen windows minimizing

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
cmoud94
Level 1
Level 1
Posts: 6
Joined: Fri Mar 29, 2013 4:16 am

Workspace switching + fullscreen windows minimizing

Post by cmoud94 » Tue May 12, 2015 10:20 am

Hi,

Is there a way how to prevent fullscreen windows from minimizing when I switch workspace? For example Firefox doesn't minimize on workspace switch, but if I have a game running in Wine in fullscreen on second workspace, then when I switch to first workspace and back, the game is minimized.

I'm using Linux Mint 17.1 Cinnamon edition and I'm not able to find out how to solve my problem, there isn't such a option in System settings.

Thanks

kodos
Level 1
Level 1
Posts: 5
Joined: Thu Sep 24, 2015 1:36 pm

Re: Workspace switching + fullscreen windows minimizing

Post by kodos » Tue Sep 29, 2015 12:35 pm

I know this is an old post but I have the same problem and my solution is to use a virtual desktop in wine with fullscreen resolution.

Arikania
Level 1
Level 1
Posts: 19
Joined: Tue Jan 10, 2017 9:32 pm
Location: The Netherlands
Contact:

Re: Workspace switching + fullscreen windows minimizing

Post by Arikania » Sat Mar 11, 2017 3:24 pm

At my Cinnamon 17.1, running World of Warcraft 5.4.8 (MoP) under Wine 2.3. Later it minimized my full screen game. Ever since, when I switch workspace and switch back, my game is minimized. I am clueless how to undo it. I restarted my computer with no luck.

Even on my other accounts it minimizes now :(


I now installed scanmem (from the repository) to give it a try. It may be a command line program, but being a genuine Linux program I trust it not to mess up my Gnome settings.


With love,
Last edited by Arikania on Sun Mar 12, 2017 5:38 am, edited 2 times in total.
Image

Arikania
Level 1
Level 1
Posts: 19
Joined: Tue Jan 10, 2017 9:32 pm
Location: The Netherlands
Contact:

Re: [SOLVED] Workspace switching + fullscreen windows minimizing

Post by Arikania » Sun Mar 12, 2017 5:22 am

Hi all,
I did some checking around, and in my World of Warcraft 5.4.8 (MoP), I solved it like this:

Game menu --> System --> Graphics --> "Windowed (Full Screen)"


That did the trick for me! :D

It still looks full screen without window decorations and such, but the full screen mode now survives my workspace switchings.


Good luck! Keep us posted on your successes!
Image

Post Reply

Return to “Cinnamon”