Dropbox on Cinnamon 2.6/Mint 17.2

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
DrOKtopus
Level 1
Level 1
Posts: 17
Joined: Thu Jun 05, 2014 7:26 am

Dropbox on Cinnamon 2.6/Mint 17.2

Post by DrOKtopus » Fri Jul 03, 2015 2:17 pm

Hi all,

I've just updated to Mint 17.2 (Cinnamon) and noticed an issue with the Dropbox integration - namely that the Dropbox applet icon doesn't appear when you log in. Someone else mentioned that this might be due to it starting up too quickly to appear and this does indeed appear to be the case.

I tried setting a delay in the startup applications but this seems to get reset between logins. Interestingly, both disabling and deleting the Dropbox item is also reverted on the next login!

So I wrote my own shell script to start it with a sleep in it that looks like this:

Code: Select all

#!/bin/bash
# Restart dropbox to make icon work.

sleep 10

dropbox stop

dropbox start -i
And added a startup item to start this script and this is working as a temporary workaround, but obviously fixing the Dropbox/Cinnamon integration would be better!

Jlynton
Level 1
Level 1
Posts: 11
Joined: Sat Feb 04, 2012 6:51 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by Jlynton » Sat Jul 04, 2015 2:28 pm

I also updated to Mint 17.2 (Cinnamon), and had the same dropbox isssue. also I find that I can not open 'Startup Applications'!

SallyK
Level 4
Level 4
Posts: 207
Joined: Fri Oct 02, 2009 5:22 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by SallyK » Sun Jul 05, 2015 11:22 am

Sorry, no solutions, but someone else with the same problem.

a34fm
Level 1
Level 1
Posts: 3
Joined: Mon Jan 30, 2012 7:55 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by a34fm » Mon Jul 06, 2015 1:12 pm

Hi there!
I also have the same problem and additionally with GoogleCrome.
I've added the delay values in ~/.config/autostart/*.desktop files thinking i'll trick the cinnamon (e.g. X-GNOME-Autostart-Delay=50)
but they have been reset after a new start of the system.
I don't know if there is a similar command for cinnamon :D

sawdoctor
Level 1
Level 1
Posts: 4
Joined: Thu May 14, 2015 6:55 am

Post by sawdoctor » Mon Jul 06, 2015 1:19 pm

I'm glad its not just me having the issue. When I launch dropbox through terminal and select status i get the error "missing job name" I don't know if that will help with fixing it

Sent from my SM-G925F using Tapatalk

gordonthegopher
Level 1
Level 1
Posts: 17
Joined: Wed Dec 10, 2014 7:10 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by gordonthegopher » Mon Jul 06, 2015 1:24 pm

I'm getting this also, and I can't change the delay. Interestingly, my girlfriend is also running 17.2 on the same kernel and doesn't have the problem. She is on a HDD and I am on an SSD so boot times are slightly different. "dropbox status" in terminal brings up "Up to date" and if I issue the "dropbox stop" and then "dropbox start -i" commands the icon appears, but only until a reboot. Bit of an annoyance. Does it need fixing by Cinnamon or Dropbox?

EDIT - Applied latest updates from Update Manager, rebooted, and it seems to be resolved. Anyone else confirm?

sawdoctor
Level 1
Level 1
Posts: 4
Joined: Thu May 14, 2015 6:55 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by sawdoctor » Mon Jul 06, 2015 3:17 pm

gordonthegopher wrote:I'm getting this also, and I can't change the delay. Interestingly, my girlfriend is also running 17.2 on the same kernel and doesn't have the problem. She is on a HDD and I am on an SSD so boot times are slightly different. "dropbox status" in terminal brings up "Up to date" and if I issue the "dropbox stop" and then "dropbox start -i" commands the icon appears, but only until a reboot. Bit of an annoyance. Does it need fixing by Cinnamon or Dropbox?

EDIT - Applied latest updates from Update Manager, rebooted, and it seems to be resolved. Anyone else confirm?
Still the same for me. Dropbox refuses to launch and still the same message in terminal "missing job name ". Really hope someone can help as I use dropbox for all my invoices

Sent from my SM-G925F using Tapatalk

DrOKtopus
Level 1
Level 1
Posts: 17
Joined: Thu Jun 05, 2014 7:26 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by DrOKtopus » Mon Jul 06, 2015 3:48 pm

Hi all, an update.

I came up with a better solution than my shell script.

I guessed (and testing bore it out) that the Dropbox entry in Startup applications is being created by the Dropbox tool itself when run, and that's why the timer is being reset (so you can't set a delay).

So the solution is to take control of this away from the Dropbox tool. First unset "Start Dropbox on system startup" in the Dropbox prefs. The Dropbox entry will now disappear from Startup items. You can then create a new startup item yourself (that runs "dropbox start -i"), set the delay to 5 seconds (seems to be enough for me) and then it will stick because it's not being updated by the Dropbox client every time you run it.

Cheers,
DrOKtopus

SallyK
Level 4
Level 4
Posts: 207
Joined: Fri Oct 02, 2009 5:22 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by SallyK » Tue Jul 07, 2015 2:50 pm

DrOKtopus wrote:Hi all, an update.

I came up with a better solution than my shell script.

I guessed (and testing bore it out) that the Dropbox entry in Startup applications is being created by the Dropbox tool itself when run, and that's why the timer is being reset (so you can't set a delay).

So the solution is to take control of this away from the Dropbox tool. First unset "Start Dropbox on system startup" in the Dropbox prefs. The Dropbox entry will now disappear from Startup items. You can then create a new startup item yourself (that runs "dropbox start -i"), set the delay to 5 seconds (seems to be enough for me) and then it will stick because it's not being updated by the Dropbox client every time you run it.

Cheers,
DrOKtopus
Thank you very much, that seems to solve the problem. :-)

twomby
Level 1
Level 1
Posts: 7
Joined: Sun Mar 16, 2014 4:01 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by twomby » Wed Jul 29, 2015 12:12 pm

Thanks DrOKtopus! This fixed my issue as well! Much appreciated!

hughparker1
Level 2
Level 2
Posts: 76
Joined: Wed Oct 01, 2014 4:18 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by hughparker1 » Sun Aug 23, 2015 6:47 pm

Thanks "DrOKtopus" for a really good solution. I had same problem but your solution fixed it. Dropbox should be using this solution to resolve this issue.

Best Regards,

Hugh

Logan_Wolverine
Level 1
Level 1
Posts: 12
Joined: Wed Aug 26, 2015 3:04 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by Logan_Wolverine » Wed Aug 26, 2015 3:06 pm

Thanks Man It helps. :D

hughparker1
Level 2
Level 2
Posts: 76
Joined: Wed Oct 01, 2014 4:18 pm

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by hughparker1 » Wed Aug 26, 2015 3:53 pm

Thanks DrOKtopus! your solution is simple but very effective, I had to set my delay to 8 seconds but works perfectly.

Cheers,

Hugh

Luismanu
Level 1
Level 1
Posts: 1
Joined: Thu Aug 27, 2015 5:58 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by Luismanu » Thu Aug 27, 2015 6:12 am

Thanks you DrOKtopus.
I was trying to solve that error by myself but I did not think that Dropbox tool creates an entry in Startup applications. :)

Lghtning4u
Level 1
Level 1
Posts: 2
Joined: Sun Aug 16, 2015 9:49 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by Lghtning4u » Sun Aug 30, 2015 8:09 pm

Your the man!

Thanks DrOKtopus

Grundkurs
Level 1
Level 1
Posts: 10
Joined: Tue Nov 10, 2015 6:18 am

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by Grundkurs » Tue Nov 10, 2015 6:20 am

@DrOKtopus
Thanks, your solution solved the problem for me.

User avatar
zquestz
Level 1
Level 1
Posts: 1
Joined: Fri Nov 11, 2016 6:43 pm
Contact:

Re: Dropbox on Cinnamon 2.6/Mint 17.2

Post by zquestz » Fri Nov 11, 2016 6:49 pm

Simplest solution that works.

* Disable the systemd dropbox service.
* Setup dropbox to auto start
* Open Startup Applications and enable Dropbox with a 3 second delay.
* Open your terminal and run `sudo chattr +i ~/.config/autostart/dropbox.desktop`

This will make the autostart file read only and dropbox can't overwrite it to remove the delay. To disable auto start you will need to `chattr -i` the file, and then you can delete it or uncheck the startup checkbox in Dropbox.

Post Reply

Return to “Cinnamon”