Page 1 of 1

Changing tabs in preference screens using only the keyboard

Posted: Wed Sep 09, 2015 10:06 pm
by jg0x42
Is there a way to change the tabs in the preference screens using only the keyboard? (i.e. no mouse and touchpad is disabled)

For example, let's say you've disabled your laptop touchpad because it constantly interferes with smooth keyboard input. Instead you plug in a mouse.

But then you're away from home and forget the mouse and would like to enable the touchpad. But when you navigate to Menu/Preferences/Mouse and Touchpad, the Mouse tab is active. How can you switch to the Touchpad tab with only the keyboard and then check the "Enable Touchpad" checkbox?


Re: Changing tabs in preference screens using only the keybo

Posted: Thu Sep 10, 2015 6:35 pm
by jg0x42
To partially answer my own post based on some additional investigation:

It appears that the default control theme installed with Linux Mint 17.2 Rafaela doesn't show which control has focus (e.g. using a thin dashed border). This makes keyboard-only navigation extremely difficult.

Why such a usability nightmare is the default?

WORKAROUND: change the control theme

  • choose Menu / Preferences / Themes
  • Under the Themes container, in the row called "Controls", click the image on the right and choose the desired control theme
  • "Adwaita" displays the traditional dashed border around the control with focus (unlike "Mint-X")
  • keyboard navigation is now much more intelligible
  • tab, the arrow keys, the return key and space bar work to navigate and activate the various controls on the screen
See: Github Issue: Keyboard navigation in Cinnamon settings unusable #4447

Re: Changing tabs in preference screens using only the keyboard

Posted: Sun Oct 29, 2017 3:57 am
by gsmagesh
I just created a login here to create a post regarding this. And before that simply searched for 'keyboard navigation' so that if any solutions available. To my surprise you did it. Thanks a lot! Such a basic thing missing by default in Cinnamon. Also thanks for making me understand that it's an issue with the theme and not with Cinnamon itself :-)