Automatic (unwanted) Screen Dimming

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
jjmcousineau
Level 1
Level 1
Posts: 2
Joined: Thu Dec 31, 2015 10:59 am

Automatic (unwanted) Screen Dimming

Post by jjmcousineau »

Hello,

I am attempting to improve on a kiosk install I have that uses mint 17 (cinnamon) as a base. I have everything working except that the screen dims with inactivity and I cannot find where to turn this off or modify it. I don't mind if it dims just not so much that it appears off/disabled from far.

I have all the obvious switches in the off position, under screen-saver, power management etc.. but neither mentions dimming. Also when in the settings app if you type "brightness" the power management tool is filtered but no where in that menu does it mention any brightness settings.

After much unsuccessful googling I installed dconf-tools this is a great tool but it seems to have no effect and many settings seem to be in two places and I can't figure out which one should work though it appears that neither works. For example:

org>gnome>desktop>session: idle-delay 0 also 999999
org>cinnamon>desktop>session: idle-delay 0 also 999999

I tried both of those to no avail trying to bypass the dim setting by just having the PC never idle. I tried many options that seemed correct and nothing works, I even tried launching dconf using sudo and again as su, and both did not work.

Please help if you can, thanks.

Cosmo.
Level 23
Level 23
Posts: 17825
Joined: Sat Dec 06, 2014 7:34 am

Re: Automatic (unwanted) Screen Dimming

Post by Cosmo. »

Ad the brightness applet to the panel, left click and open the sub-menu for dimming; disable dimming.

jjmcousineau
Level 1
Level 1
Posts: 2
Joined: Thu Dec 31, 2015 10:59 am

Re: Automatic (unwanted) Screen Dimming

Post by jjmcousineau »

Cosmo. wrote:Ad the brightness applet to the panel, left click and open the sub-menu for dimming; disable dimming.
I looked into this and in 17.3 the power management applet controls the brightness and is pre-installed. The dimming I am referring to is after a period of inactivity when you have the screen saver/screen locking disabled.

*edit*

I looked and downloaded a 3rd party applet called "Brightness" but it added no functionality

olle
Level 3
Level 3
Posts: 131
Joined: Thu Oct 08, 2009 12:03 pm
Location: Helsinki, Finland

Re: Automatic (unwanted) Screen Dimming

Post by olle »

You could try to run in the terminal

Code: Select all

xset -dpms s off
You can undo it:

Code: Select all

xset +dpms s on
For information run

Code: Select all

xset -h

tgm1024
Level 1
Level 1
Posts: 13
Joined: Thu Jun 14, 2018 11:32 am

Re: Automatic (unwanted) Screen Dimming

Post by tgm1024 »

Ugh, this is embarrassing.

I came here with the exact same weirdness.

Welllllllllllllllllllllllllllllll.........if you're using a laptop that is always plugged in, check your power source (and you're likely not used to doing this).

My newly adopted kittens turned off my power strip while horsing around and it was in "battery mode".
Believe it or not, the sentence "What we've got here is a failure to communicate." never appears in the movie Cool Hand Luke. If you don't believe me, check here. :)

Post Reply

Return to “Cinnamon”