[SOLVED] Icon corruption/missing icons

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
xox101
Level 2
Level 2
Posts: 93
Joined: Sat Jan 29, 2011 7:34 pm

[SOLVED] Icon corruption/missing icons

Post by xox101 » Mon Feb 08, 2016 8:06 pm

I have just finished installing 17.3 Cinnamon on my friends old Dell E520. It is as expected working perfectly except for some sort of corruption in the graphics.
Example.png
As you can see the top half of the Update Manager icon is missing. This also happens in Firefox where either the "F" in the top left of the browser is missing or the Last Pass icon is showing only the bottom half. In Nemo I can open several windows and in some of them the top left corner has a rectangle missing just above "File". There doesn’t seem to be any pattern to this. Additionally when opening Shutter for instance, the Panel icon for Shutter seems to end up superimposed over another icon. At other times an icon will disappear completely although the underlying button can still be depressed. ie the "All Windows" icon will disappear from the Panel but hovering the cursor over where the icon was will still show the pop up saying "All Windows" and clicking on the empty space will have the desired effect. The button is still there but the icon has gone.

This happens no matter which theme is used, should it be the default theme or one installed through System Settings/Theme.

I have upgraded this PC over the years with a Core2Duo processor, 5 gig of ram, Intel SSD and an ATI X1300 graphics card driving twin Dell 17in monitors. Hardinfo reports the ATI card as ATI RV515 and this is as far as I can find out supported in Mint 17.3. Running the Driver Manager results in no drivers being found.

Unfortunately I am flying back home tomorrow so will only be able to connect to the PC through Teamviewer. I would really like to get this sorted before I leave as my friend really loves her PC again!
Last edited by xox101 on Sat Feb 27, 2016 2:22 pm, edited 2 times in total.

User avatar
richyrich
Level 19
Level 19
Posts: 9075
Joined: Mon May 04, 2009 8:31 pm

Re: Icon corruption/missing icons

Post by richyrich » Mon Feb 08, 2016 9:35 pm

ATI/AMD have dropped support for your card, so you are left with the open-source drivers. Thus said, I recommend you install either the Mate or Xfce version of Mint. They are easier to run on open-source drivers, than the more graphics intensive Cinnamon edition.

xox101
Level 2
Level 2
Posts: 93
Joined: Sat Jan 29, 2011 7:34 pm

Re: Icon corruption/missing icons

Post by xox101 » Tue Feb 09, 2016 10:02 am

I thought that would be the answer unfortunately. Still, installed MATE as a backup and showed her how to get into it if Cinnamon gets really bad.She much prefers Cinnamon, more familiar to her. Thanks for the reply.

xox101
Level 2
Level 2
Posts: 93
Joined: Sat Jan 29, 2011 7:34 pm

Re: Icon corruption/missing icons

Post by xox101 » Sat Feb 27, 2016 2:16 pm

For anyone reading this and having the same problems I solved the graphics corruption by installing a GeForce N210 video card and installing the recommended driver. It was around £25 and works perfectly.

Post Reply

Return to “Cinnamon”