[SOLVED] Mint 18 - 64bit - Cinnamon - Black Screen on login

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

[SOLVED] Mint 18 - 64bit - Cinnamon - Black Screen on login

Post by Aptus » Thu Jul 07, 2016 9:12 am

Updated to 18 from 17.3 by performing a clean install and I am running into some weird issues on my laptop. First, sometimes when I log in, about say every third or fourth time, the screen is black with only the cursor visible. Upon rebooting however it is usually possible to log in normally, however, now the real interesting things happen. Several settings in the system settings tab are reverted back to the defaults. Things like sound settings, wallpapers, scrolling direction, power management settings etc. Not all of them every time, it seems almost random which ones are reverted and which ones are not.

I guess the first issue with the black screen may be some issue with running the nVidia drivers instead of noveau, but I had absolutely no issue with these on 17.3. The second issue with reverting settings though is a major annoyance.

Any ideas?

EDIT: Second issue with reverting settings has been solved further down in the thread. The black screen issue is still ongoing.
Last edited by Aptus on Fri Jul 15, 2016 3:20 am, edited 4 times in total.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Thu Jul 07, 2016 11:02 am

Regarding the second issue:
Create a new user account. Don't do any changes there. Does it give the same result?

eric71
Level 1
Level 1
Posts: 9
Joined: Tue May 18, 2010 3:07 pm

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by eric71 » Sun Jul 10, 2016 4:39 am

I was just searching to see if anyone else had this problem. I see exactly the same on 64 bit Cinnamon Mint 18. It was a clean install of the Beta, now fully updated. About every third time I log in, it stalls at a blank screen with the hard drive very active. I need to shut down via the power button. Upon restarting, it logs in normally, but wallpaper is reset to the default. My desklets are still there, though. I did see the same thing in the beta.

rene
Level 12
Level 12
Posts: 4149
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by rene » Sun Jul 10, 2016 5:11 am

Had the same thing happen yesterday on an into VirtualBox 5 newly installed Mint 18 Cinnamon 64-bit (release). This after also experiencing random behaviour with respect to automatic login (and a boot failure when trying to install in UEFI mode, but that might be VirtualBox being incompatible with actual UEFI firmware; no idea).

Mint 17 was the first version of Mint I ever ran and Mint 17.3 the first I ever ran while considering it my main system. Long-time Linux user, and was impressed by it. Which is to say that I feel the state of 18 is a bit of a shame; it's not anything to currently also be impressed with.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Sun Jul 10, 2016 5:44 am

rene wrote:a boot failure when trying to install in UEFI mode
rene, did you activate EFI in the VM settings of VB? At least with VB 4.3.38 is not the case by default. If you did yourself I would like to hear, why and if the boot failure is reproducible on another VM without EFI?
As might have read on other places, I have a number of complaints with LM 18 in VB, but a boot failure did never happen in the month since the beta had been released.

As we are about it I also would like to read, if you see the splash screen in your VM: at boot up and at shutting down?
Related to that: Which VB 5 version exactly? Are the guest additions for that version installed in the guest?

rene
Level 12
Level 12
Posts: 4149
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by rene » Sun Jul 10, 2016 7:14 am

Indeed I did activate EFI. Had already deleted that VM again so had to retest but the issue is fully repeatable for me:

I am on Mint 17.3 Cinnamon 64-bit using the VirtualBox version as installed directly from the Oracle repository after earlier during the Ubuntu 16.04 release timeframe experiencing quite a few issues with the (old) version at that point available from the Ubuntu/Mint repositories. If I'm not mistaken I at the time saw specifically you recommending this as well. In any case, this is to say that I am currently using VirtualBox version 5.0.24 r108355.

I create a new VM with 4G or RAM, 50G dynamically allocated VDI. Earlier I tweaked my usual tweaks of upping CPUs to 4, picking ICH9 in stead of PIIX3, Intel HD Audio instead of AC97, probably immediately enabled 3D acceleration and yes, System -> Mainboard -> Enable EFI. This time during retesting I kept everything other than Enable EFI at default.

The system (18 Cinnamon 64-bit release) installs fine -- well, it here hung for a fairly long time at the "Installing language packs" stage but this was supposedly a transiently busy server only -- and afterwards I reboot into the new system successfully. I can in fact reboot into it as many times as I like but the first time I shutdown Mint 18, the party's over; a subsequent restart of the VM dumps me at the VirtualBox EFI shell only. See attachment.

Earlier I managed to still boot Mint 18 from that shell but just now I did not. Although this might admittedly be me just being a bit too Sunday currently, it seems I cannot currently get it to do anything other than dump me back at the same shell prompt (the "Esc" or "Any other key" choice does not matter). "exit" brings me to a text menu interface where I can tweak to my heart's content, but without result whatsoever.

I in fact just now tried twice, also once with shutdown only after having updated all default-setting updates (75 of them currently). Did not matter. First shutdown on Mint 18 is also the last. Earlier and on the non-EFI install of 18 Cinnamon 64-bit I also have sitting around on a VM I also indeed installed the correct guest additions (through the VB "Insert Guest Additions CD Image" thing after uninstalling the Mint 18 standard ones) but this again was not relevant to the issue: at first shutdown, the fun's over with, tweaked or untweaked, updated or non-updated (on the non-EFI one, it does also give me a non-software rendered Cinnamon, so all's fine there).

Now... I actually quite assume(d) this to be a VirtualBox EFI issue rather than a Mint 18 one. Did also notice this report: viewtopic.php?f=46&t=224833 but other than that, this reply posted just because you explicitly asked. I haven't been installing 18 on Non-VB UEFI firmware so cannot confirm or deny anything in that to Mint 18 more relevant situation.
Attachments
mint18-efi.png

Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Aptus » Sun Jul 10, 2016 8:43 am

Cosmo. wrote:Regarding the second issue:
Create a new user account. Don't do any changes there. Does it give the same result?
Sorry for the delay, only had time to get to it now. I created a dummy account and after four reboots it too experienced the black screen issue. However without changing any settings it is a bit hard to see if anything has reverted.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Sun Jul 10, 2016 11:34 am

As I wrote, my advice was addressed to the second issue (reverting settings), which you named in your starting post as the major issue. So, does this happen in the test account? If not, we can continue to investigate, where the problem is in the first account.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Sun Jul 10, 2016 11:48 am

@rene:

I still would like to discuss this a little bit more.

At first I really want to know your experience with the splash screen in VB5. As you might remember, I had reported on other places, that with VB4 is did never see a splash screen at booting (only with LM 18, in LM 17.x it works fine), and the splash screen at shutting down was only there (but far too late and only visible for a second or so), until I installed the guest additions, after that I see it not more. Do you get the same result regarding the splash screen with VB5?

At second I would like to read, why you consider to use EFI at all inside VB? It is still in experimental state, so problems and bugs are to be expected. IMO it is only worth to use it, if you want to create a VM with dual booting with UEFI-Windows inside of the guest machine for (what will most likely not work) some testing purposes.

rene
Level 12
Level 12
Posts: 4149
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by rene » Sun Jul 10, 2016 1:27 pm

Cosmo. wrote:I still would like to discuss this a little bit more.
Will do but postponed. Certainly while my EFI VM was this afternoon still rebooting, the splash screen seemed to work fine. When I just now tried my regular VM I saw that no splash screen appeared. Fairly certain that it used to directly after installation but since I don't normally use the splash screen (nor "quiet" parameter) on my main system I'm not completely sure; may have not noticed.

When I just now tried to reinstall a BIOS VM to retest I gave it 30 minutes to get past the "Downloading language packs" bit of the Mint 18 (Cinnamon 64-bit) install but this was still not enough. Nor does the "Skip" button at that screen seem to do more than open a syslog view. If that's not just a case of a Mint-side server being down or very busy there may be bug there but the issue in any case currently turns quick tests into long, drawn out attempts. Will have to verify later.
Cosmo. wrote:At second I would like to read, why you consider to use EFI at all inside VB?
For the heck of it basically. Note that I had already deleted the EFI VM again upon seeing trouble and only retested due to your inquiry. My main desktop system is an early generation Core i7 with 8G RAM that was recently upgraded with an SSD. Given the usage pattern for this system, quite a bit too useful to even consider upgrading yet, that is. Still, it's from just before the UEFI era and being technically minded, playing around with UEFI seems fun.

Yes, as mentioned I assume(d) it to be a VB EFI issue rather than anything Mint-side. It is the case that this forum has seen similar reports, such as linked above, on actual UEFI firmware which I find somewhat interesting but without affected hardware or really even any intention of short term install of Mint 18 on actual hardware, someone else may feel free to go debug that if indeed there is anything to debug :)

We are by the way polluting this thread a bit, which is about reset settings -- also experienced, but not repeatably so. If a moderator wants to move these EFI and/or splash screen musings to for example viewtopic.php?f=46&t=224833 or its own thread, certainly with my blessing.

Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Aptus » Mon Jul 11, 2016 4:07 am

Aptus wrote:
Cosmo. wrote:Regarding the second issue:
Create a new user account. Don't do any changes there. Does it give the same result?
Sorry for the delay, only had time to get to it now. I created a dummy account and after four reboots it too experienced the black screen issue. However without changing any settings it is a bit hard to see if anything has reverted.
Made some changes to the test account and performed 20-something reboots. Ran into the black screen issue three times but so far no reverted settings.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Mon Jul 11, 2016 5:44 am

Cosmo. wrote:As I wrote, my advice was addressed to the second issue (reverting settings), which you named in your starting post as the major issue. So, does this happen in the test account? If not, we can continue to investigate, where the problem is in the first account.
Cosmo. wrote:Don't do any changes there.
Last edited by Cosmo. on Mon Jul 11, 2016 5:46 am, edited 1 time in total.

Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Aptus » Mon Jul 11, 2016 5:45 am

Cosmo. wrote:
Cosmo. wrote:As I wrote, my advice was addressed to the second issue (reverting settings), which you named in your starting post as the major issue. So, does this happen in the test account? If not, we can continue to investigate, where the problem is in the first account.
Yes?
Aptus wrote: Made some changes to the test account and performed 20-something reboots. Ran into the black screen issue three times but so far no reverted settings.
Sorry but how else would I be supposed to see if any changes are reverted if I don't do any changes to it?
Last edited by Aptus on Mon Jul 11, 2016 6:03 am, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Mon Jul 11, 2016 5:47 am

Go into your main account.
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Aptus » Mon Jul 11, 2016 5:52 am

Cosmo. wrote:Go into your main account.
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.
Hmm, I had to run that command in sudo which leads me to believe this is some permission issue with the config file?

Results however were:

Code: Select all

find $HOME ! -user $USER -type f
find: ‘/home/aptus/.cache/dconf’: Permission denied
/home/aptus/Coding/Ruby/RubyMineScripts/launcher
aptus@tattersail ~ $ sudo !!
sudo find $HOME ! -user $USER -type f
[sudo] password for aptus: 
/home/aptus/.cache/dconf/user
/home/aptus/Coding/Ruby/RubyMineScripts/launcher

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Mon Jul 11, 2016 6:03 am

No, you should not run this command via sudo!
The good new is, that by doing so, you did nothing, what made the situation worse.
The bad new is, that there are files with wrong ownership; the common reason is, that you used sudo wrongly.

Do this:
Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get promped for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished.
Press twice ctrl-d
Immediately log off and back into your account.

Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Aptus » Mon Jul 11, 2016 6:09 am

Cosmo. wrote:No, you should not run this command via sudo!
The good new is, that by doing so, you did nothing, what made the situation worse.
The bad new is, that there are files with wrong ownership; the common reason is, that you used sudo wrongly.

Do this:
Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get promped for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished.
Press twice ctrl-d
Immediately log off and back into your account.
Done, now when I rerun

Code: Select all

find $HOME ! -user $USER -type f
I get no output btw.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Cosmo. » Mon Jul 11, 2016 6:15 am

That is expected, as the last command given by me resolved the ownership problem.

Aptus
Level 1
Level 1
Posts: 11
Joined: Mon Oct 28, 2013 3:51 am

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by Aptus » Mon Jul 11, 2016 6:16 am

Cosmo. wrote:That is expected, as the last command given by me resolved the ownership problem.
Cheers, I will try restarting a couple times and see if it has resolved the issue then.

EDIT: All right, did a dozen or so reboots and settings are preserved correctly now. I also did not run into the black screen issue so unless it pops up again I'll have to assume it was also related. I'll mark this as resolved. Thanks for the assistance Cosmo!

rene
Level 12
Level 12
Posts: 4149
Joined: Sun Mar 27, 2016 6:58 pm

Re: Mint 18 - 64bit - Cinnamon - Black Screen on login and settings being reset.

Post by rene » Tue Jul 12, 2016 5:04 am

rene wrote:Will do but postponed. Certainly while my EFI VM was this afternoon still rebooting, the splash screen seemed to work fine. When I just now tried my regular VM I saw that no splash screen appeared. Fairly certain that it used to directly after installation but since I don't normally use the splash screen (nor "quiet" parameter) on my main system I'm not completely sure; may have not noticed.
No boot splash on an into a Non-EFI 5.0.24 VirtualBox VM installed Mint 18 Cinnamon 64-bit release, and a single-second flash appearance on reboot only. I did get the boot splash on my EFI configured VM.

[EDIT] And since I believe I saw it claimed otherwise in another VB thread you were in; reverified that indeed Cinnamon hardware-accelerated rendering works fine with the VM configured for 3D acceleration and the 5.0.24 guest additions installed.

Post Reply

Return to “Cinnamon”