[SOLVED] Mint 18: How do I disable the screensaver?

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
User avatar
matt
Level 3
Level 3
Posts: 138
Joined: Sat Jun 04, 2016 3:13 pm
Location: Earth/North America/USA/home

[SOLVED] Mint 18: How do I disable the screensaver?

Post by matt » Wed Jul 27, 2016 3:29 pm

Hi everyone. In Mint 18 Cinnamon, the screensaver settings does not seem to have the GUI feature to disable the screensaver like in Mint 18 Mate. Is there a command that I can run in terminal in order to accomplish this without running into instability/dependency issues?

Thank you for your help in advance.
Last edited by matt on Thu Jul 28, 2016 6:23 pm, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Mint 18: How do I disable the screensaver?

Post by Cosmo. » Wed Jul 27, 2016 3:38 pm

Of course you can disable the screensaver from the settings GUI: select "never" for the time of inactivity.

You might want to do the same setting in the power settings for the monitor, to prevent, that your monitor gets black.

User avatar
matt
Level 3
Level 3
Posts: 138
Joined: Sat Jun 04, 2016 3:13 pm
Location: Earth/North America/USA/home

Re: Mint 18: How do I disable the screensaver?

Post by matt » Thu Jul 28, 2016 6:23 pm

Cosmo. wrote:You might want to do the same setting in the power settings for the monitor, to prevent, that your monitor gets black.
This is what I missed doing. Thank you.

User avatar
White Phoenix
Level 4
Level 4
Posts: 266
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: [SOLVED] Mint 18: How do I disable the screensaver?

Post by White Phoenix » Mon May 14, 2018 8:37 pm

You can disable the screensaver in Mate? How? What is this “never” setting you refer to in respect to the screensaver? I have never seen a setting that allows you to set the screensaver to never activate. The closest I have ever been able to do is to select the Blank screen, uncheck “Activate screensaver when computer is idle” and “Lock screen when screensaver is active”, then set “Regard the computer as idle after” to two hours. The Power Manager settings all have options for never or do nothing, but they do not affect the screensaver. I have yet to find any way to keep the screensaver from activating at all. It is missing the one setting that Windows has. Setting the screensaver to “none”. Unless there is another way to do it somewhere else instead of in the screensaver settings of the Control Center where it should be.
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

User avatar
Faust
Level 4
Level 4
Posts: 333
Joined: Thu Jul 14, 2016 3:40 am

Re: [SOLVED] Mint 18: How do I disable the screensaver?

Post by Faust » Tue May 15, 2018 4:12 am

In 18.3 Cinnamon , I use an applet called " inhibit " to do this ( inhibit@cinnamon.org )

It puts an icon near the clock and network icons , and clicking on it gives the option
of toggling " Power management " from "1" to "0" .

Just what I want , with no permanent changes to the main screensaver/power settings .

IIRC , get it by right-clicking on empty space on the desktop .
" And so it goes " - Kurt Vonnegut
The modern reality and the satirical parody are rapidly converging .

User avatar
MtnDewManiac
Level 6
Level 6
Posts: 1303
Joined: Fri Feb 22, 2013 5:18 pm
Location: United States

Re: [SOLVED] Mint 18: How do I disable the screensaver?

Post by MtnDewManiac » Tue May 15, 2018 6:23 pm

White Phoenix wrote:
Mon May 14, 2018 8:37 pm
You can disable the screensaver in Mate?
I'll be brief because you've asked in a Cinnamon thread (in the Cinnamon DE section of the forum), but look for the setting associated with screensaver use/activation within MATE that deals with how long the computer should be inactive - and, by that, I mean not being actively used by a person (as opposed to not actually doing anything, which is probably far rarer in a computer :roll: ) before activating the screensaver. It is probably either a sliding scale (move slider to number of minutes) or a box with arrows to increase/decrease the number of minutes. I am guessing that, below "1," you'll either see a "0" or the word "Never." Set the time delay to that (0 is basically a misnomer, as a true zero-setting would, AfaIK, see the screensaver get activated every time the user stopped moving the mouse, released the key that he/she had just depressed, et cetera).

Regards,
MDM
Mint 18 Xfce 4.12.

If guns kill people, then pencils misspell words, cars make people drive drunk, and spoons made Rosie O'Donnell fat.

User avatar
White Phoenix
Level 4
Level 4
Posts: 266
Joined: Sun Dec 22, 2013 9:01 am
Location: Ypsilanti

Re: [SOLVED] Mint 18: How do I disable the screensaver?

Post by White Phoenix » Tue May 15, 2018 11:25 pm

MtnDewManiac wrote:
Tue May 15, 2018 6:23 pm
It is probably either a sliding scale (move slider to number of minutes) or a box with arrows to increase/decrease the number of minutes. I am guessing that, below "1," you'll either see a "0" or the word "Never." Set the time delay to that
Nope, from at least 17.3 to 18.2, there is no “never”, only a 5 min to 2 hrs slider. This is what I was referring to with “Regard the computer as idle after”. However, if Cinnamon is able to disable the screensaver, maybe I should switch. Who knows how many other advantages there would be in switching?
Linux Mint 17.3 / MATE
Toshiba Satellite L655d-S5151 (Intel dual processor, 64bit, 4G RAM)

Post Reply

Return to “Cinnamon”