Desktop background reverts to default every boot/reboot [solved]

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Desktop background reverts to default every boot/reboot [solved]

Post by kmb42vt » Sun Aug 21, 2016 11:18 am

Hi folks,

Since the last update for Mint 18/Cinnamon of Mint related components my desktop background image reverts back to the Mint 18 default image every boot or reboot. Somehow the current background image isn't saved for the session.

This is a clean install of Mint 18/Cinnamon (64-bit) with no modifications or PPAs installed and the background images I choose are from the Mint backgrounds repositories for current and past versions. No fudging. I'm not too sure where to go from here so any help will be appreciated.
Last edited by kmb42vt on Sun Aug 28, 2016 11:45 am, edited 1 time in total.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot

Post by Cosmo. » Sun Aug 21, 2016 4:25 pm

My suspicion is a permission issue in your account.

You might create a fresh new user account and check the behavior there. If this works as expected, then we know it for sure.

To check if there is a permission issue in your main account do this in the main(!) account:
Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot

Post by kmb42vt » Mon Aug 22, 2016 11:15 am

@Cosmo, Heh, this is the output of the command:

Code: Select all

/home/kmb42vt/.cache/dconf/user
So it appears all is well? Of course, I booted up this morning and my selected background was there just as it's supposed to be which is typical. Bring your car to the mechanic and the car runs like new and all that. Random problem then? To add a bit more confusion, I checked for this problem on my Thinkpad where I've had both the 64-bit and 32-bit versions of Mint 18/Cinnamon installed and both versions have also exhibited this reverting to the default background image. Go figure.

Let's leave it for now and I'll report back if it happens again with a terminal output.

Now, if you'd be willing to confirm a solid, repeatable glitch I've found in Mint 18/Cinnamon?

When writing an image to a USB thumbdrive using Mint's USB Image Writer, clicking on the "Details" down arrow shows nothing but a dashed line (appears near the bottom of the dialog box) with no details shown. It seems the dialog box fails to expand to show the details.

On the same note, when installing a .deb using Gdebi and Gdebi reports that additional dependencies must be installed as well, (at this point a "Details" button with down arrow appears) clicking the "Details" down arrow only shows a solid line with no details shown. Again, the dialog box seems to fail to expand to show the details.

These two problems are consistent and reproducible in Mint 18/Cinnamon where there was no problem in the 17.* series or any version previous. It also seems to be isolated to Cinnamon 3.0.* as I've bounced this against a Mint 18/MATE installation and the problem does not exist, all details shown properly.

If you could confirm this one way or another I'd appreciate it. If you find the same thing then I can submit a big report but I'd rather not do it without conformation. If I need to start a new forum topic I will, just let me know. And thanks.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot

Post by Cosmo. » Mon Aug 22, 2016 4:10 pm

Let us start at the beginning:

Your output is not OK. But it is not a big deal, to make it correct:
Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get prompted for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished. It does not produce a readable output.
Press twice ctrl-d
Immediately log off and back into your account.

Now to your 2 LM 18 problems:
I cannot say anything about the Mintstick-problem, because I run LM 18 only in a virtual environment. Using a USB drive in this environment is in general a bad idea, so I do not even try it.

Regarding GDebi: I confirm there is a graphical bug as you described. IIRC I described it already some weeks ago. Later I read, that this bug does not seem to happen in every case, so it might be a little bit tricky to reproduce.

The proper place for bug reports is here. If you report, give as much information as you can, this includes of the Gdebi-issue the DEB-file, you want to install.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot

Post by kmb42vt » Mon Aug 22, 2016 4:54 pm

Cosmo. wrote:Let us start at the beginning:

Your output is not OK. But it is not a big deal, to make it correct:
......
Before I start changing things like permissions via the terminal I need to ask a question. First, a little background just so you know how Mint 18 was installed (single user only):

This is a clean install of Linux Mint 18/Cinnamon (64-bit) on newly formatted partitions (root, home and swap). The root and home partitions are EXT4 and I dual boot with Windows (currently Win10). Same type of Mint installation I've been doing since version 5. I back up my data and restore it afterward of course. Now, the external drive I use to back up my data is formatted by default as NTFS since it has to be able to be read by Windows as well as Mint. So the question(s):

Understanding the above, why would a clean install of Mint 18 have incorrect permissions in the first place? And what do your instructions to fix permission actually do to my Mint installation? Just so I know what's happening you understand. My career have been in computers, peripherals, prototyping and such but I was never a coder or programmer. But I still like to know what's happening under the hood as it were.

And thanks for your patience with an old tech-head.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot

Post by Cosmo. » Mon Aug 22, 2016 5:11 pm

It is perfectly OK, that you ask before you apply an advice. You are welcome.

The output, that you provided gave one file with the wrong ownership. This file is in the cache inside of your home. (The first command given by me does not inspect anything except your home).) This file did not come from the installation process, but it had possibly existed in your backup and had been restored from the backup. So the origin of this issue is not Mint itself or the installation process.

My second command again does work also only inside of your home. It searches for all files and folders, which do not belong to you (in your case there is only this single one). If it finds any, it changes the wrong ownership to your own account. Nothing else gets done with the file. All files, that have the correct ownership, do not get touched at all. That is all, what the command does.

Feel free to ask, if you have further questions.

User avatar
Flemur
Level 16
Level 16
Posts: 6289
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Desktop background reverts to default every boot/reboot

Post by Flemur » Mon Aug 22, 2016 5:23 pm

Cosmo, wouldn't it be simpler for the OP to do:

Code: Select all

sudo chown -R kmb42vt:kmb42vt /home/kmb42vt/.cache/dconf/user
?
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot

Post by Cosmo. » Mon Aug 22, 2016 5:45 pm

@Flemur: In principle yes.

I use for my advices a low number of ready-to-use text blocks, mostly for those cases, where command line advices play an important part. I use the text blocks, because I can with this approach be sure, that there is no typo in my advice. (You happened to find a typo by me just an hour ago in an advice, where I did not have a text block.) Such typos in the command line can lead to terrible consequences, which I do avoid by this approach. So this is IMO the safer way. As I also explain in detail, how to apply the command without any technical expressions (which the reader might probably not know), in the practical result it should make no difference in regard of simplicity. For the clipboard it doesn't matter, if the content is more or less complex.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot

Post by kmb42vt » Mon Aug 22, 2016 8:41 pm

@Cosmo - Okay, here's something odd then. I checked permissions of that file in the callout ( ~/.cache/dconf/user) and it shows the "dconf" folder itself belongs to "root" and was created by the system upon install, not restored by me as I never restore any of the system config files or folders in the home directory except for those associated with my usual applications. In this case that would be:

.mozilla
.thunderbird
.filezilla

I also create a ~/.fonts folder where all my additional fonts are stored.

That's it. The rest of the system config files and folders in the home I prefer to be created by the installation of a new version of Mint so the home directory configurations are clean.

Also, ~/.cache/dconf/ was empty.

I checked this out on my older Thinkpad laptop as well and it shows the same as my desktop. The laptop has a clean install of Mint 18/Cinnamon as well although it's the 32-bit version rather than the 64-bit. Could it be possible root is supposed to own ~/cache/dconf/ by default?
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot

Post by kmb42vt » Mon Aug 22, 2016 8:43 pm

Double post. See previous post.
Last edited by kmb42vt on Sun Nov 27, 2016 1:48 pm, edited 1 time in total.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot

Post by Cosmo. » Tue Aug 23, 2016 6:42 am

Most likely you encountered a new bug in LM 18.

I started just a freshly installed LM 18 (not updated at this time) and opened the .cache folder in my home. Finding: there is no subfolder dconf at all, only fontconfig and wallpaper, which have the correct ownership.

As soon as the update manager gets refreshed the subfolder dconf in the cache gets created with wrong root ownership. This is a bug. After correcting the ownership - using my advice some posts above, corrected this mistake.

This problem did never encounter on any of my LM 17 systems.

Summing up: The problem of wrong ownership does exist, but it is not your fault (as I assumed at first), but a bug in the update manager.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot

Post by kmb42vt » Tue Aug 23, 2016 11:32 am

@Cosmo - Good enough then. Glad the bug was found. I'll fix the permission(s) according to your previous instructions although It will be interesting to see if mintupdate recreates the problem or not.

Now if I could ask a favor of you? I'm not going to be available for the next couple of days or so (medical issues) so I'm wondering if you would be willing to file a bug report about this? It's obvious it needs to be fixed and I'm not going to be around to start the process. I'm also quite sure you would be able to be more concise and to the point than I could these days. I'll still be around most of today if you could let me know. And thanks for all your help and patience.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot

Post by Cosmo. » Tue Aug 23, 2016 5:12 pm

kmb42vt wrote:It will be interesting to see if mintupdate recreates the problem or not.
I noticed this bug only today as a consequence of our discussion, so there is no long-time experience available. But with the tests I did today it seems, that once this folder / file exist, the problem will not reappear.

I filed a bug report already this morning. Like you I consider this bug as critical. Job completed. :wink:

I wish you the very best for getting well soon.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot

Post by kmb42vt » Sun Aug 28, 2016 11:39 am

@Cosmo

Just a quick update. Your fix for the permission problem worked fine as you would imagine and it's stayed fixed. All is well there.

The background image switching to default problem seems to have vanished on both my laptop and desktop PC.

And off-topic, it's going to be surgery but it looks to be fairly minor all around. Been there, done that before (disabled veteran and all that). And thanks for your well wishes and filing the bug report.

I'm going to go ahead and mark this one solved.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot [solved]

Post by Cosmo. » Sun Aug 28, 2016 12:04 pm

You may wish to read and add your vote here.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot [solved]

Post by kmb42vt » Sun Aug 28, 2016 12:48 pm

Cosmo. wrote:You may wish to read and add your vote here.
Done
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot [solved]

Post by kmb42vt » Thu Sep 08, 2016 3:14 pm

It's done it again. This time I noticed that the background image was changing to default in mid-session. I'd be running an application in a maximized window (Firefox, Thunderbird, Xplayer, whatever) only to close the application and find the background image back to default.

I ran:

Code: Select all

sudo find $HOME ! -user $USER -type f
And just like last time it returned:

Code: Select all

/home/kmb42vt/.cache/dconf/user
I've been running the above code at least once a day just to see if the problem returned and all was well until today after I noticed the background image changed back to default in mid-session.

There's been a plethora of updates come in since September 1st (most on the 6th, others on the 1st and the 4th) and I didn't have the computer on for at least 2 days during that time period due to day trips so I can't exactly tell when this problem started again.

Not too sure where to go from here but I thought it was worth posting.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot [solved]

Post by Cosmo. » Thu Sep 08, 2016 5:15 pm

As far as until now known, after correcting the permissions for .cache/dconf and .ache/dconf/user the ownership stays correct, except those objects should get deleted. In this case the update manager will recreate them and does this again with the wrong owner.

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: Desktop background reverts to default every boot/reboot [solved]

Post by kmb42vt » Fri Sep 09, 2016 10:54 am

Cosmo. wrote:As far as until now known, after correcting the permissions for .cache/dconf and .ache/dconf/user the ownership stays correct, except those objects should get deleted. In this case the update manager will recreate them and does this again with the wrong owner.
If .cache/dconf and .cache/dconf/user were deleted from my system then it wasn't by my hand. Is it possible that an update to a Mint related package cause the above directory/file to be deleted? The only reason I ask is that the "mintsystem" package, for example, was updated twice within the last few weeks. The first time just before the permission problem showed up the first time and the second time was a few days before the problem showed up again.

I may be way off course here but since the problem did reoccur without my intervention the only thing I can think of is that an update to a system package (not necessarily "mintsystem", that was just an example) deleted either .cache/dconf or .cache/dconf/user or both.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Desktop background reverts to default every boot/reboot [solved]

Post by Cosmo. » Fri Sep 09, 2016 2:12 pm

kmb42vt wrote:Is it possible that an update to a Mint related package cause the above directory/file to be deleted?
Usually updating, installing or removing packages does not alter the user's home.

But I just - after reading your last post and doing some more investigation into this - found a new strange problem:
If I open the folder ~/.cache/dconf with root privileges - by right clicking in the nemo window and selecting to open as administrator - the file user vanishes. If I refresh the update manager (elevated nemo window still open) the file reappears (with wrong ownership); if I now close the elevated nemo window, the file vanishes also (the folder dconf remains as empty folder).

I can reproduce this as often as I want.

Nothing of all what we discuss here should ever happen.

I will add this new finding to the bug report.

Locked

Return to “Cinnamon”