No Thumbnails for Videos in Nemo

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

No Thumbnails for Videos in Nemo

Post by mozart9200 » Tue Oct 04, 2016 1:03 pm

As the title says, I have no thumbnails for videos of any kind, be it an mp4, avi, wma...

I already spoke with some people on IRC and it seems a very rare bug/issue.

I run Cinnamon on Mint 18 Sarah.

Keep in mind that i already checked the "preview" setting the thumbnail for all files below 8gb.

I also noticed the same issue while trying a Mint 18 KDE with an usb key live.

Could you help me finding a solution?

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

Re: No Thumbnails for Videos in Nemo

Post by mozart9200 » Thu Oct 06, 2016 12:40 pm

Tried deleting the ./thumbnails and chache/thumbnails folders. Did not work. Any ideas?

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: No Thumbnails for Videos in Nemo

Post by Cosmo. » Thu Oct 06, 2016 4:32 pm

If you look at text files you will notice, that you also do not get thumbnails for text files. I have been told by a developer, that this caused by the version 3.14 of GTK, which is used in LM 18. Nothing, what can be done about it. I don't know, if the same cause does apply here also. (It appears, as if some developers - I mean those for that library - understand for the expression "new" something like "new: no missing".) I like my "old" Mint 17.3 with more and better features, than Mint 18 has added.

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

[Solved] No Thumbnails for Videos in Nemo

Post by mozart9200 » Thu Oct 06, 2016 6:46 pm

I see, thank you.

I don't see the reason for removing that feature but.. hey, lots of desktop enviroments out there so..

Thanks anyway!

User avatar
Odyseus
Level 2
Level 2
Posts: 53
Joined: Tue May 05, 2015 5:00 am

Re: No Thumbnails for Videos in Nemo

Post by Odyseus » Fri Oct 07, 2016 12:44 am

Hello, g@ys.

I'm using Mint 18 Cinnamon and I do see thumbnails for all videos.

Image

@Cosmo: Mint 18 Cinnamon comes with Gtk 3.18 and Mint 17.3 comes with Gtk 3.10. That's one of the main reasons I switched to Mint 18. Since Firefox switched from Gtk2 to Gtk3, its interface was very buggy with the Gtk3 version 3.10 (at least for me).

User avatar
trytip
Level 6
Level 6
Posts: 1273
Joined: Tue Jul 05, 2016 1:20 pm

Re: No Thumbnails for Videos in Nemo

Post by trytip » Fri Oct 07, 2016 1:39 am

after deleting .thumbnails did you also create it?

not sure why you wouldn't but do you have ffmpegthumbnailer and ffmpegthumbs installed
Last edited by trytip on Thu Apr 19, 2018 10:21 am, edited 1 time in total.
Image

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: No Thumbnails for Videos in Nemo

Post by Cosmo. » Fri Oct 07, 2016 5:43 am

Odyseus wrote:@Cosmo: Mint 18 Cinnamon comes with Gtk 3.18 and Mint 17.3 comes with Gtk 3.10.
I referred to an answer which JosephMcc gave here.

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

Re: No Thumbnails for Videos in Nemo

Post by mozart9200 » Fri Oct 07, 2016 5:52 am

trytip wrote:after deleting .thumbnails did you also create it?

not sure why you wouldn't but do you have ffmpegthumbnailer and ffmpegthumbs installed
Yeas I already tried installing those. Did not work :(

User avatar
trytip
Level 6
Level 6
Posts: 1273
Joined: Tue Jul 05, 2016 1:20 pm

Re: No Thumbnails for Videos in Nemo

Post by trytip » Fri Oct 07, 2016 1:41 pm

do you have totem installed
Image

User avatar
Odyseus
Level 2
Level 2
Posts: 53
Joined: Tue May 05, 2015 5:00 am

Re: No Thumbnails for Videos in Nemo

Post by Odyseus » Fri Oct 07, 2016 2:13 pm

Hello, g@ys.

This is indeed a very strange bug. Here I am, with a feature that I don't want/need working perfectly. And people that do wants/needs it, with the feature not working. I don't even have installed the packages ffmpegthumbnailer nor ffmpegthumbs. Not even totem.

@mozart9200: Did you uninstalled some software that came by default on Mint 18? Do you have the codecs installed? Did you checked the permissions of the ./thumbnails and/or .cache/thumbnails.

@Cosmo: I merely stated that Mint 18 Cinnamon comes with Gtk 3.18, not with Gtk 3.14.
Cosmo wrote:I have been told by a developer, that this caused by the version 3.14 of GTK, which is used in LM 18.

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

Re: No Thumbnails for Videos in Nemo

Post by mozart9200 » Fri Oct 07, 2016 3:14 pm

I tried installing totem (I didn't have it) and nothing changed.
Odyseus wrote:Hello, g@ys.



@mozart9200: Did you uninstalled some software that came by default on Mint 18? Do you have the codecs installed? Did you checked the permissions of the ./thumbnails and/or .cache/thumbnails.

Cosmo wrote:I have been told by a developer, that this caused by the version 3.14 of GTK, which is used in LM 18.

I have uninstalled flash because of security. Also I checked the permissions, I have full access.

User avatar
Odyseus
Level 2
Level 2
Posts: 53
Joined: Tue May 05, 2015 5:00 am

Re: No Thumbnails for Videos in Nemo

Post by Odyseus » Fri Oct 07, 2016 4:28 pm

mozart9200 wrote:I have uninstalled flash because of security. Also I checked the permissions, I have full access.
I also uninstalled flash when I installed Mint 18 for the first time. As flash is part of a meta package, it will also try to uninstall the packages mint-meta-codecs and mint-meta-codecs-core. And those packages contain all kind of codecs not just for media files.

You may have some missing codecs. I just tried in a live session of Mint 18 Cinnamon without the codecs installed. Thumbnails for video files weren't working. I installed the codecs from the Welcome Screen and the thumbnails for videos started working immediately.

Another thing that I observed was that it only showed me the thumbnails of files owned by my user. If the file was owned by root, it wouldn't show a thumbnail.

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: No Thumbnails for Videos in Nemo

Post by Cosmo. » Fri Oct 07, 2016 6:42 pm

Removed meta packages are not the explanation, they contain no binaries. If no other packages get listed as to be removed as consequence, they will stay in the system.

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

Re: No Thumbnails for Videos in Nemo

Post by mozart9200 » Sat Oct 08, 2016 1:16 pm

Is there a way to debug this?

User avatar
Odyseus
Level 2
Level 2
Posts: 53
Joined: Tue May 05, 2015 5:00 am

Re: No Thumbnails for Videos in Nemo

Post by Odyseus » Sat Oct 08, 2016 6:34 pm

Hello, g@ys.

@mozart9200: Do you have your videos stored in an NTFS file system by any chance? This is just a shot in the dark. I don't know if this would affect thumbnails on Nemo. I mention this because I recently had some problems with all my NTFS drives (I couldn't move files to trash) and I fixed it by changing some mount options.

@Cosmo: Sorry for the confusion. I sometimes forget that apt-get isn't pacman (Arch Linux).

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: No Thumbnails for Videos in Nemo

Post by Cosmo. » Sat Oct 08, 2016 6:36 pm

No problem, mate.

User avatar
kyphi
Level 8
Level 8
Posts: 2164
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: No Thumbnails for Videos in Nemo

Post by kyphi » Sat Oct 08, 2016 8:13 pm

Some information.

Running Linux Mint 18 Cinnamon 64 bit on 2 computers. Neither ffmpegthumbnailer nor ffmpegthumbs are installed.

Thumbnails are visible for the following formats: mp4, wmv, m4v, flv and mkv.
No thumbnail for swf.

Flash is installed.

Nemo preferences set to Show thumbnails = Local Files Only
Only for files smaller than = 4 GB

Using a live session, videos cannot be played because of the missing codecs and support files (47.6 MB) as already stated by Odyseus. Possibly one of these is needed to display thumbnails of videos in Nemo.

The current media player is "Xplayer" called "Videos" in the main menu. There is no connection between the media player and the display of thumbnails in Nemo.
Linux Mint 18.3 Cinnamon - 64bit

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

Re: No Thumbnails for Videos in Nemo

Post by mozart9200 » Sun Oct 09, 2016 8:28 am

Odyseus wrote:Hello, g@ys.

@mozart9200: Do you have your videos stored in an NTFS file system by any chance? This is just a shot in the dark. I don't know if this would affect thumbnails on Nemo. I mention this because I recently had some problems with all my NTFS drives (I couldn't move files to trash) and I fixed it by changing some mount options.

It's not related to the file system. The issue appears both on my nfts external drive and my filesystem (which is ext4 or something like that... the default one)

User avatar
mozart9200
Level 1
Level 1
Posts: 9
Joined: Thu Sep 29, 2016 8:28 am

Re: No Thumbnails for Videos in Nemo

Post by mozart9200 » Wed Oct 12, 2016 4:54 pm

Well looks like I'll have to wait for my next installation. I'll let you know when I'll format my pc if the thumbnails work or if the problem persists.

dwreck621
Level 1
Level 1
Posts: 1
Joined: Wed Nov 23, 2016 2:25 pm

Re: No Thumbnails for Videos in Nemo

Post by dwreck621 » Wed Nov 23, 2016 2:27 pm

came here just to say i notices i STOPPED generating NEW file previews. so old files show thumbs, new ones do not. how odd..

Post Reply

Return to “Cinnamon”