Windows start jumping back and forth on laptop

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
User avatar
TooMuchTime
Level 4
Level 4
Posts: 407
Joined: Fri Mar 11, 2016 10:30 pm

Re: Windows start jumping back and forth on laptop

Post by TooMuchTime » Sat Nov 26, 2016 1:40 pm

I get the same thing using a USB mouse on my Dell laptop. Whenever I scroll with the wheel, I will press the wheel which will click the wheel button. This seems to enable auto-scrolling and just a simple mouse movement will scroll the window contents up or down at Warp 9. When I left-click anywhere on the screen, the auto-scroll goes away. Currently, I have not found a way to disable the scroll wheel button in Mint. I wish it was off by default.

I think this is what you are experiencing. Try using a USB mouse and see what happens.

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Windows start jumping back and forth on laptop

Post by turboscrew » Sun Nov 27, 2016 7:44 pm

I've been using a USB mouse only since I disabled the key pad - no problems this far.
I guess I'll try with both enabled and see if left click stops the scrolling. Thanks for the hint.

But as the video shows, the window scrolls in both directions more or less randomly, and it keeps doing that even if I leave the mouse alone with mouse cursor within the window.

User avatar
BG405
Level 7
Level 7
Posts: 1917
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Windows start jumping back and forth on laptop

Post by BG405 » Mon Nov 28, 2016 1:18 pm

You could try disabling tapping on the touchpad to see if that helps. I do this on every machine as I find touchpads, in general, far too sensitive .. in KDE, I have set it to turn off the touchpad when a mouse is plugged in but couldn't find this option in Cinnamon (or Xfce).

In Xfce, I set it to disable the touchpad whilst typing with a 2-second delay before it reactivates. This seems to avoid accidental activation. On my machine running Cinnamon the pad isn't connected internally as I didn't bother to put the ribbon back, since this machine is always used with an external keyboard and mouse, so haven't checked these settings there.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

User avatar
turboscrew
Level 4
Level 4
Posts: 214
Joined: Sat Sep 26, 2009 2:13 pm

Re: Windows start jumping back and forth on laptop

Post by turboscrew » Tue Mar 21, 2017 5:44 pm

Oops. I seem to have forgotten to update...
I disabled the touchpad, and the problem hasn't emerged since.

User avatar
BG405
Level 7
Level 7
Posts: 1917
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Windows start jumping back and forth on laptop

Post by BG405 » Wed Mar 22, 2017 2:14 pm

Excellent! Thanks for posting the update, better late than never. 8)
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

Post Reply

Return to “Cinnamon”