Desktop shortcuts not showing up

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
Sandy
Level 1
Level 1
Posts: 1
Joined: Sun Dec 18, 2016 5:56 am

Desktop shortcuts not showing up

Post by Sandy » Mon Dec 19, 2016 9:06 am

Hi everyone,

I just did a fresh install of Linux MInt 18.1 Serena Cinnamon Ed. 64bit on a dual monitor setup. Everything went smoothly, except after I log in the Desktop is empty (I can see the background image, but no icons for computer, trash or my links to documents). I checked desktop settings and there all the icons I want are checked, but still don't display. When I change the drop down menu for placing desktop symbols only on primary monitor, only on secondary monitor or on both everything appears again on my desktop (icon order is messed up). Even though for example "show desktop symbols on primary monitor" was already selected before. For the rest of the session everything works fine.

When I log out and in again, same problem - empty desktop. I checked dconf settings: org.nemo.desktop: computer-icon-visible true, desktop-layout true::true, trash-icon-visible true, show-desktop-icons true, show-orphaned-desktop-icons true. So according to these settings everything should be displayed. I set show-desktop-icons to false and then to true again and all icons appear on my desktop (icon order is messed up). Log out and log in - empty desktop again.

I searched the internet and found out that Nemo (currently using 3.2.2) probably is the culprit. Similar problem reports go back to Mint 14. In .config/autostart there even is an autostart entry "nemo -n.desktop" that starts nemo in the background in order to "solve problem with desktop shortcuts not showing up". The process "nemo -n" is running, but shortcuts still don't show up. When I do "nemo -q" and "nemo -n" in a terminal shortcuts show up again.

If I autostart a script with "gsettings set org.nemo.desktop show-desktop-icons true" on login icons only show up if it is started with a minimum delay of 6. If started earlier the script gets executed but doesn't show any effect.

The problem could also have something to do with:
~/.cinnamon/configs
~/.config/dconf/user
~/.config/nemo/desktop-metadata

Deleting the latter file restores desktop icons for computer and trash, but not links to documents. I have not found any way to restore desktop icons in their original order. Whenever I manage to have them show up again they are all messed up.

Any help would be highly appreciated!

Yours sincerely,
Sandy

ugly
Level 3
Level 3
Posts: 149
Joined: Thu Nov 24, 2016 9:17 pm

Re: Desktop shortcuts not showing up

Post by ugly » Mon Dec 19, 2016 10:15 am

I'm having the same issue. I did an upgrade from 18.

So far the only thing that works for me is changing the settings from no desktop and then back to primary monitor.

I did find an initial bug report:
https://bugs.launchpad.net/linuxmint/+bug/1650977

asciiman
Level 2
Level 2
Posts: 87
Joined: Sun Sep 15, 2013 10:24 pm

Re: Desktop shortcuts not showing up

Post by asciiman » Fri Dec 23, 2016 4:32 pm

I am having a similar issue here in 18.0 Cinnamon.
I don't remember seeing this issue in the 17.x versions.
When I attempt to drag/drop a browser link onto the desktop, it does not appear on the desktop.
It just vanishes.
In 17.x I seem to remember that it would appear on the desktop in the exact desktop grid area where I dropped it.

However, in 18.0, I found that the browser link DOES appear within the Desktop FOLDER as displayed in NEMO.
And that link can be dragged (i.e. copied) from the Desktop Folder back onto the desktop, and the link will work.

Very clunky to say the least.

Is there a setting I can change to gain back the more logical functionality?

foremancr
Level 1
Level 1
Posts: 1
Joined: Wed Mar 09, 2016 1:09 pm

Re: Desktop shortcuts not showing up

Post by foremancr » Wed Jan 25, 2017 4:51 pm

I have had the problem for sometime where the second won't display any folder after rebooting. Finally I gave up trying to fix 18.1 and bent back to version 18.0, I haven't had any other problems since going back. You would think that this problem could be solved

laboratori
Level 1
Level 1
Posts: 1
Joined: Wed Jun 21, 2017 11:46 am

Re: Desktop shortcuts not showing up

Post by laboratori » Wed Jun 21, 2017 12:01 pm

I'm having the same issue of the desktop icons disappearing after reboot with a dual monitor in Linux Mint 18.1. In case it is useful for someone else, I can force a repaint of the desktop icons in their correct positions this way:

Right click in an empty area of the screen and open "Desktop Settings".
Open the scroll list "Desktop Layout".
Change its value to anything different from the current one.
Open the scroll list "Desktop Layout" again.
Change it to the first value (in my case "Show desktop icons on primary monitor only").

After accepting the last change, all the icons reappear in their correct positions in my primary monitor.

Regards

--- EDIT 11-july-2018 ---
Solved on version 18.2. Thanks to the Linux Mint team!

porfirion
Level 1
Level 1
Posts: 1
Joined: Tue Apr 17, 2018 5:46 am

Re: Desktop shortcuts not showing up

Post by porfirion » Tue Apr 17, 2018 5:55 am

I have the same issue. Switching to "show desktop icons on primary monitor only" and back helped.
In addition - i've found another error: sometimes, when i create new folders (by mouse context menu) - they doesn't appear. But when i restored icons - i've found 6 folders named "Untitled folder %n"!

I use Linux Mint 18.1 Cinnamon 64-bit (v 3.2.7).

Post Reply

Return to “Cinnamon”