Cinnamon failed to start and running in fallback mode

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
ckaibi
Level 1
Level 1
Posts: 5
Joined: Sun Jan 01, 2017 9:51 pm
Location: Switzerland

Cinnamon failed to start and running in fallback mode

Post by ckaibi » Sun Jan 01, 2017 10:04 pm

I rebooted my laptop and I was messing around with my displays. Then I did realize that my main desktop was not going on my main display so I just disconnected all my extra HDMI cables. But meanwhile I tried to install nautilus and do some changes as I did not understand what was going on.
Now i get an error message at startup saying that Cinnamon was unable to start and is running in fallback mode. If I try to restart it, I get the same message again and again. I tried to reinstall cinnamon and remove old files to reset to default but the problem is still happening.
I also realized that running glx info just gives me the following output :
name of display: :0
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
....
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".

System information:

System: Host: Athletics Kernel: 4.4.0-57-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1)
Distro: Linux Mint 18 Sarah
CPU: Quad core Intel Core i5-6500 (-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25535
clock speeds: max: 3600 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz
4: 1627 MHz
Graphics: Card: NVIDIA Device 1b81 bus-ID: 01:00.0
GPU : GTX1070 with driver version 367.44
Display Server: X.Org 1.18.4 driver: nvidia
Resolution: 1680x1050@59.95hz
GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Info: Processes: 187 Uptime: 34 min Memory: 1615.4/16000.0MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.421) inxi: 2.2.35
Desktop environment : Cinnamon

Anyone knows how to solve this issue?
Last edited by ckaibi on Mon Jan 02, 2017 5:54 am, edited 1 time in total.

Tech Freak
Level 2
Level 2
Posts: 63
Joined: Tue Nov 08, 2016 5:25 am

Re: Cinnamon failed to start and running in fallback mode

Post by Tech Freak » Mon Jan 02, 2017 4:21 am

Please read the forum rules and in particular forum rule #5.

Can you follow up on rule #5 about providing details about your system?
Thanks!

ckaibi
Level 1
Level 1
Posts: 5
Joined: Sun Jan 01, 2017 9:51 pm
Location: Switzerland

Re: Cinnamon failed to start and running in fallback mode

Post by ckaibi » Mon Jan 02, 2017 5:55 am

Tech Freak wrote:Please read the forum rules and in particular forum rule #5.

Can you follow up on rule #5 about providing details about your system?
Thanks!
Sorry for that. I have added some information.

ckaibi
Level 1
Level 1
Posts: 5
Joined: Sun Jan 01, 2017 9:51 pm
Location: Switzerland

Re: Cinnamon failed to start and running in fallback mode

Post by ckaibi » Mon Jan 02, 2017 9:53 am

I finally managed to solve the issue by downloading the drivers from Nvidia and reinstalling them.

Post Reply

Return to “Cinnamon”