Time Messed Up In A Dual Boot Installation

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
vw98075
Level 2
Level 2
Posts: 86
Joined: Sat Dec 27, 2014 8:20 pm

Time Messed Up In A Dual Boot Installation

Post by vw98075 » Thu Mar 16, 2017 5:01 pm

After installing 18.1 Cinnamon as a Windows and Linux dual boot, I notice another issue other than the Windows was not shown in the menu. The time on Linux Mint was not correct first. I set it to the right time zone (with the network connection). After going back to Windows 10, I notice the time is 7 hours behind the correct time, the one on Linux Mint. I can't see how to solve this problem.

Penn
Level 5
Level 5
Posts: 752
Joined: Tue Jun 10, 2014 1:12 pm

Re: Time Messed Up In A Dual Boot Installation

Post by Penn » Thu Mar 16, 2017 7:50 pm

Will this help viewtopic.php?f=90&t=240083&p=1281474 starting with MintO's response?

vw98075
Level 2
Level 2
Posts: 86
Joined: Sat Dec 27, 2014 8:20 pm

Re: Time Messed Up In A Dual Boot Installation

Post by vw98075 » Fri Mar 17, 2017 8:09 pm

Thanks for the information. I need to make some changes either on Linux Mint or on Windows 10.

greyskier
Level 2
Level 2
Posts: 58
Joined: Fri Nov 01, 2013 1:25 am
Location: Canada

Re: Time Messed Up In A Dual Boot Installation

Post by greyskier » Wed Mar 29, 2017 5:56 pm

You are probably running 18.1 Cinnamon in UTC(Coordinated Universal Time) mode rather than RTC(Real Time Clock). Try this command
>timedatectl set-local-rtc 1

tinny123
Level 1
Level 1
Posts: 12
Joined: Thu Mar 30, 2017 2:55 am

Re: Time Messed Up In A Dual Boot Installation

Post by tinny123 » Thu Mar 30, 2017 3:40 am

greyskier wrote:You are probably running 18.1 Cinnamon in UTC(Coordinated Universal Time) mode rather than RTC(Real Time Clock). Try this command
>timedatectl set-local-rtc 1

Please eli5 :( :?:

User avatar
Moem
Level 17
Level 17
Posts: 7228
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Time Messed Up In A Dual Boot Installation

Post by Moem » Thu Mar 30, 2017 3:56 am

tinny123 wrote: Please eli5 :( :?:
Sorry, what does that mean?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

tinny123
Level 1
Level 1
Posts: 12
Joined: Thu Mar 30, 2017 2:55 am

Re: Time Messed Up In A Dual Boot Installation

Post by tinny123 » Thu Mar 30, 2017 5:09 am

Moem wrote:
tinny123 wrote: Please eli5 :( :?:
Sorry, what does that mean?
eli5=Explain Like I'm five

User avatar
Moem
Level 17
Level 17
Posts: 7228
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Time Messed Up In A Dual Boot Installation

Post by Moem » Thu Mar 30, 2017 5:51 am

Really? I would never have guessed. Thank you for explaining that to me like I'm 48. :wink:

Anyway, when someone gives you a command such as

Code: Select all

timedatectl set-local-rtc 1
... that is meant to go into a terminal. You can open a terminal from the menu and copypaste it into that; note that ctrl+v does not work in a terminal, but you can use ctrl+v+shift, or use a rightclick and choose 'paste'.

Now if you were five, I would have said 'Better let your parents handle it'. This is how I'd explain it to an adult who is new to Linux. Don't sell yourself short. And please use plain English; this is an international forum with people from many different backgrounds, countries, and walks of life. Thanks!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

lmintnewb2

Re: Time Messed Up In A Dual Boot Installation

Post by lmintnewb2 » Thu Mar 30, 2017 4:15 pm

Someone probably already supplied the fix but wanted to add some related junk in case not.

File someone can edit(as root or with sudo) /etc/adjtime if when you open the file it says UTC change it to LOCAL instead.

Ntp should be running by default and setting your time from servers online, though you do need to make sure it's setup for local/rtc and not UTC.

Not sure what Mint release or desktop you're using but certainly there are going to be gui tools to set things like time/date in it.

Some cli ways to adjust the clock in terminal, Jmo but easier to mess with this stuff as root, so in terminal make your user root, typing any of the following w/o quotes, "su", "sudo su", "sudo -i"

Type "date", it'll output the systems date and time in the 24hr(military time) format. You can set the time with "date --set 18:23:00" goes 18(hour):23(min):00(secs), so in that example I'd be setting it to 6:23pm.

Another handy terminal cmd is hwclock, imo --hctosys and --systohc can be useful. Really it's easier to deal with this stuff with whatever gui tools Mint included in the OS, important thing is that your Mint install knows you want to be setup in rtc/local and not UTC, if that's what your system is setup to use.

2cents.

tinny123
Level 1
Level 1
Posts: 12
Joined: Thu Mar 30, 2017 2:55 am

Re: Time Messed Up In A Dual Boot Installation

Post by tinny123 » Thu Mar 30, 2017 9:15 pm

Moem wrote:Really? I would never have guessed. Thank you for explaining that to me like I'm 48. :wink:

Anyway, when someone gives you a command such as

Code: Select all

timedatectl set-local-rtc 1
... that is meant to go into a terminal. You can open a terminal from the menu and copypaste it into that; note that ctrl+v does not work in a terminal, but you can use ctrl+v+shift, or use a rightclick and choose 'paste'.

Now if you were five, I would have said 'Better let your parents handle it'. This is how I'd explain it to an adult who is new to Linux. Don't sell yourself short. And please use plain English; this is an international forum with people from many different backgrounds, countries, and walks of life. Thanks!
Ah the famous dutch bluntness! anyway eli5 is a pretty common expression.It means to explain to someone like they are a noob. Like BRB or BTW have become pretty universal acronyms. Thank You for yr response

User avatar
Moem
Level 17
Level 17
Posts: 7228
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Time Messed Up In A Dual Boot Installation

Post by Moem » Fri Mar 31, 2017 2:44 am

tinny123 wrote:anyway eli5 is a pretty common expression.
Not in my circles, and I spend a lot of time on the internet. It can't be that universal or I would have heard of it. I stand with my request to kindly not use it here.
Anyway, did the command work? If not, please tell us what exact version of Mint you're using (inclising the DE), so we can help you better.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

OmegaD
Level 1
Level 1
Posts: 31
Joined: Mon Feb 27, 2012 5:15 pm

Re: Time Messed Up In A Dual Boot Installation

Post by OmegaD » Fri Jun 15, 2018 4:07 pm

greyskier wrote:
Wed Mar 29, 2017 5:56 pm
Try this command

Code: Select all

timedatectl set-local-rtc 1
Worked for me. Thanks!

User avatar
Flemur
Level 16
Level 16
Posts: 6286
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Time Messed Up In A Dual Boot Installation

Post by Flemur » Fri Jun 15, 2018 4:16 pm

Pro Tip!

Boot the OS which has the time the most "ahead" - then if you make a mistake, you can boot the other OS and correct the mistake before it happened.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Post Reply

Return to “Cinnamon”