[SOLVED] Cinnamon panel font rendering.

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
draconicrose
Level 1
Level 1
Posts: 42
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

[SOLVED] Cinnamon panel font rendering.

Post by draconicrose » Sun Mar 19, 2017 2:10 pm

I'm trying to change the font in the cinnamon panel and I've succeeded but it doesn't seem to render the same way as it does on the window titles and stuff. You can see what I mean in the screenshot (drive link), especially if you look at the time. Am I seeing things, doing something wrong or did I find a bug? Screenshot

Details:

Code: Select all

System:    Host: DragonNest Kernel: 4.8.0-42-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.2)
           Distro: Linux Mint 18.1 Serena
Machine:   Mobo: Intel model: DG41RQ v: AAE54511-202
           Bios: Intel v: RQG4110H.86A.0011.2009.0626.1639 date: 06/26/2009
CPU:       Dual core Intel Core2 Duo E8400 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 11998
           clock speeds: max: 2997 MHz 1: 1998 MHz 2: 1998 MHz
Graphics:  Card: NVIDIA GK208 [GeForce GT 730] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz, 1280x1024@60.02hz
           GLX Renderer: GeForce GT 730/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 378.13 Direct Rendering: Yes
Audio:     Card-1 Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK208 HDMI/DP Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 JMTek LLC. audio controller
           driver: USB Audio usb-ID: 005-003
           Sound: Advanced Linux Sound Architecture v: k4.8.0-42-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (24.0% used)
           ID-1: /dev/sda model: WDC_WD5000AAKS size: 500.1GB
Partition: ID-1: / size: 202G used: 105G (55%) fs: ext4 dev: /dev/sda4
           ID-2: swap-1 size: 8.39GB used: 1.04GB (12%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A gpu: 0.0:38C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 206 Uptime: 2:52 Memory: 2771.9/3947.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35 
Last edited by draconicrose on Tue Jun 13, 2017 6:37 pm, edited 1 time in total.

User avatar
samuvuo
Level 1
Level 1
Posts: 4
Joined: Mon Apr 24, 2017 4:18 pm

Re: Cinnamon panel font rendering.

Post by samuvuo » Mon Apr 24, 2017 6:09 pm

Please try setting font-family to Noto Sans (leaving out the "Regular" part, which is the font style, not part of the font name).

Quick test on my system:

Code: Select all

$ fc-match 'Noto Sans Regular'
DejaVuSans.ttf: "DejaVu Sans" "Book"

$ fc-match 'Noto Sans'
NotoSans-Regular.ttf: "Noto Sans" "Regular"

draconicrose
Level 1
Level 1
Posts: 42
Joined: Sun Sep 29, 2013 1:53 pm
Location: Portugal
Contact:

Re: Cinnamon panel font rendering.

Post by draconicrose » Tue Jun 13, 2017 6:36 pm

Thank you, this was what I was missing! I had no idea that the 'regular' part wasn't part of the name.

Post Reply

Return to “Cinnamon”