Boots to tty1 before login

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Tue May 30, 2017 11:39 am

Glad to hear it's fixed.

As for marking it solved I would say yes since it's fixed for you and all the advice in here could solve it for someone else. I'm still new here so other people can chime in if I'm wrong about that.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: [Solved] Boots to tty1 before login

Post by Uncle_Snail » Tue May 30, 2017 1:46 pm

I have tried some more, and I still have not been able to replicate the error. I am currently still using the NVidia drivers from the drivers manager, but soon I will have updated to the NVidia driver from their website. Note, this is supposed to be the same driver.
There is one problem I realized though. My NVidia X Server Settings panel is almost empty, and only contains "application profiles" and "NVidia X server config settings". I am going to see if this is fixed when I install the other drivers.
For now though, I think everything is pretty good. If I have the error again, I will update it here.
Less of a Linux noob every day.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Tue May 30, 2017 2:11 pm

Okay, I got the error again.
Simply reinstalling the graphics drivers to the NVidia 340 got me the error, but I have some ideas of how to fix it, once again, and I have more pin-pointed ideas of what might have caused it. I also realized (from using the computer when there was no error) that the text before and after startup is not the only problem. It seems as though in tty1, the graphics drivers are not used, so the terminal is displayed in 600x800 pixels, where when running normally, text is displayed correctly, and much smaller.

Reinstalling did fix the x server problem where I only had two tabs, by the way.

I ran this command again.

Code: Select all

dmesg | grep -i error; dmesg | grep -i warning
However, there was only the one remounting error this time.

Code: Select all

[    3.495214] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
This seems odd, because the problem is still persisting.

When installing it added this file, I know, in /etc/modprobe.d/nvidia-graphics-drivers.conf

Code: Select all

# This file was installed by nvidia-340
# Do not edit this file manually

blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-current
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current-updates
blacklist nvidia-173-updates
blacklist nvidia-96-updates
blacklist nvidia-340-updates
alias nvidia nvidia_340
alias nvidia-uvm nvidia_340-uvm
alias nouveau off
alias lbm-nouveau off
I think this may have something to do with it.
Just a thought though.

Before I did the installation, I ran sudo service mdm stop so that I could perform the installation, however, after it I ran sudo service mdm start again, so this should not be the problem.

Any ideas?
Less of a Linux noob every day.

User avatar
Prsman
Level 4
Level 4
Posts: 204
Joined: Tue Nov 17, 2015 3:15 pm

Re: Boots to tty1 before login

Post by Prsman » Thu Jun 01, 2017 1:38 am

Late to this party, I also have this feature or problem. I get the tty1 login twice, And the text changes color randomly. Might be white, next time yellow, next time brown. my dmesg error is this:

Code: Select all

prs-player@prsplayer-Mint-18 ~ $ dmesg | grep -i error; dmesg | grep -i warning
[   15.822961] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[    0.000000] ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/Pm1aEventBlock: 32/8 (20150930/tbfadt-623)
[    0.000000] ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/Pm1aControlBlock: 16/8 (20150930/tbfadt-623)
[    0.000000] ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/PmTimerBlock: 32/8 (20150930/tbfadt-623)
[    0.000000] ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/Gpe0Block: 64/8 (20150930/tbfadt-623)
[    0.000000] ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/Gpe1Block: 128/8 (20150930/tbfadt-623)
[    0.000000] ACPI BIOS Warning (bug): Invalid length for FADT/Pm1aEventBlock: 8, using default 32 (20150930/tbfadt-704)
[    0.000000] ACPI BIOS Warning (bug): Invalid length for FADT/Pm1aControlBlock: 8, using default 16 (20150930/tbfadt-704)
[    0.000000] ACPI BIOS Warning (bug): Invalid length for FADT/PmTimerBlock: 8, using default 32 (20150930/tbfadt-704)
[   17.916968] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C7F conflicts with OpRegion 0x0000000000001C40-0x0000000000001C45 (\_SB_.PCI0.SM01) (20150930/utaddress-254)
[   17.916975] ACPI Warning: SystemIO range 0x0000000000001C40-0x0000000000001C7F conflicts with OpRegion 0x0000000000001C40-0x0000000000001C45 (\_SB_.PCI0.SM00) (20150930/utaddress-254)
I thought this was a feature. I haven't tried to login at that point. My grub has quiet splash. I also get the tty1 login at shutdown too. Ideas anyone? Thanks

theaterghost
Level 1
Level 1
Posts: 13
Joined: Thu Mar 30, 2017 3:03 pm

Re: Boots to tty1 before login

Post by theaterghost » Thu Jun 01, 2017 2:26 am

Coming from Xubuntu, I expected X to be bound to VT7, but I was suprised to find that it was being moved around when I switched to tty1 and back, as far as tty9
The problem was the mdm default options located in /usr/share/mdm/defaults.conf
I cherry-picked a few setting, adding them to /etc/mdm/mdm.conf, and now the desktop stays on vt7.
The first time the problem occured I thought X had crashed, but running ps aux | grep xorg will show which vtXX it was moved to.
There may be a setting to keep it on VT7 during shutdown, I haven't tried it yet.

Code: Select all

[daemon]
Greeter=/usr/lib/mdm/mdmwebkit

#ADDED SECTION HERE
FirstVT=7    
VTAllocation=false
#END OF ADDED SECTION

Code: Select all

[servers]

# Also note, that if you redefine a [server-foo] section, then MDM will
# use the definition in this file, not the MDM System Defaults configuration
# file.  It is currently not possible to disable a [server-foo] section
# defined in the MDM System Defaults configuration file.
#
# ADDED SECTION HERE
[server-Standard]
name=Standard server
command=/usr/bin/X -audit 0 vt7 
flexible=true
# END OF ADDED SECTION
# Indicates that the X server should be started at a different process
# priority.  Values can be any integer value accepted by the setpriority C
# library function (normally between -20 and 20) with 0 being the default. For
# highly interactive applications, -5 yields good responsiveness. The default
# value is 0 and the setpriority function is not called if the value is 0.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 5:49 am

Uncle_Snail:

At this point I'm not even sure what your second problem is or if it's even the same as the first problem we fixed. A video would be helpful but I can't promise I will know even then.

As I've said these descriptions of booting up and showing a console screen are normal, as well as at shutdown time. I can't remember how much is shown during quiet splash since I don't use that feature. If it's not supposed to be shown at all then it may actually just be a bug that needs to be fixed in the programming. Without seeing it myself I can't really say since it just sounds normal to me.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 9:58 am

theaterghost wrote: The problem was the mdm default options located in /usr/share/mdm/defaults.conf
I cherry-picked a few setting, adding them to /etc/mdm/mdm.conf, and now the desktop stays on vt7.
The first time the problem occured I thought X had crashed, but running ps aux | grep xorg will show which vtXX it was moved to.
There may be a setting to keep it on VT7 during shutdown, I haven't tried it yet.
Okay, thanks for the suggestions. I am too beginning to suspect it has some connection to mdm, at least a little. I tried adding your suggested code, saving, then restarting, but it did not fix the problem. That was sort of expected for me, considering what your code does, and that my X was already on vt7. It did change one thing though. Previously, the tty1 screen, after the error, had always been blue. Now it is brown. (normal, no error, is white). I'm not sure if your code is what caused the change, or something else. I have reverted the files now. I will restart and see if it is blue again.

By the way, after reinstalling the driver, the login screen, once it loads, is appearing correctly, not as shown in one of my previous screenshots. If it messes up again, I'll keep you updated.
Prsman wrote:I get the tty1 login twice, And the text changes color randomly. Might be white, next time yellow, next time brown.
Yes, mine is randomly changing colors as well. Most of the time it has been blue though.
sgtor wrote: At this point I'm not even sure what your second problem is or if it's even the same as the first problem we fixed. A video would be helpful but I can't promise I will know even then.

As I've said these descriptions of booting up and showing a console screen are normal, as well as at shutdown time. I can't remember how much is shown during quiet splash since I don't use that feature. If it's not supposed to be shown at all then it may actually just be a bug that needs to be fixed in the programming. Without seeing it myself I can't really say since it just sounds normal to me.
Okay, I will try to do that soon.
Less of a Linux noob every day.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 10:32 am

sgtor wrote: At this point I'm not even sure what your second problem is or if it's even the same as the first problem we fixed. A video would be helpful but I can't promise I will know even then.

As I've said these descriptions of booting up and showing a console screen are normal, as well as at shutdown time. I can't remember how much is shown during quiet splash since I don't use that feature. If it's not supposed to be shown at all then it may actually just be a bug that needs to be fixed in the programming. Without seeing it myself I can't really say since it just sounds normal to me.
Okay. My first problem, and what I am having now, is simply that the tty terminals have large font and a random color. They also show up when shutting down and starting up.
My second problem, which was fixed when reinstalling the graphics drivers, but I had it a couple of other times too. It seemed to happen after a few restarts of having the first issue.
It is the same, except the tty1 terminal shows for a shorter amount of time than with the first issue, and the login screen appears incorrectly. Here is a video of the second problem explaining what happens.
Also, in both versions of the issue, there is the Linux Mint loading screen with the four dots, which is not the correct look of the Mint loading screen.
https://www.youtube.com/watch?v=iBFQLTW ... e=youtu.be
Less of a Linux noob every day.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 11:17 am

I have to say it still looks normal to me. The only that looked off was your screen wasn't totally black but that was screen glare right?

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 11:23 am

sgtor wrote:I have to say it still looks normal to me. The only that looked off was your screen wasn't totally black but that was screen glare right?
That was screen glare, yes. I can't get a video of how it normally looks for a comparison, right now, because I have this error. I may be able to in the future though.
Less of a Linux noob every day.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 11:42 am

The only problem you've mentioned is that it seems 3 or 4 seconds slower on bootup. Is that really a problem? I really think it's a normal bootup and you've made some sort of change to the system that has caused bootup to take a little more time which as I've said can be normal depending what sort of changed you've made.

The video was also a bit too short. I wish you had left it filming until your whole desktop was visible. As it was though I didn't didn't see anything abnormal.

If you're willing I think you should try one more thing and then you'll really see what's going on with your bootup and if there is truly a problem.

If you turn off quiet splash and reboot you'll be able to see the whole process. As fast as it may be you can still spot errors if you watch the screen.
to do that edit /etc/default/grub

and change this

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to this

Code: Select all

#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
then run

Code: Select all

update-grub
then reboot and watch the screen. If everything is green OK then you're good

EDIT:
my mistake you need to run that as root so put sudo in front of those commands or do

Code: Select all

sudo bash or su

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 12:06 pm

sgtor wrote: If you're willing I think you should try one more thing and then you'll really see what's going on with your bootup and if there is truly a problem.

If you turn off quiet splash and reboot you'll be able to see the whole process. As fast as it may be you can still spot errors if you watch the screen.
to do that edit /etc/default/grub
I couldn't see any errors. Everything looked fine. I then tried commenting the line

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT=""
to see what happened. When rebooting like that, I had the second problem, as well, where the login screen is wrong. I then changed it back, and the login screen is correct again.

But I didn't see any errors or anything.
sgtor wrote: The only problem you've mentioned is that it seems 3 or 4 seconds slower on bootup. Is that really a problem? I really think it's a normal bootup and you've made some sort of change to the system that has caused bootup to take a little more time which as I've said can be normal depending what sort of changed you've made.
There is actually one other major problem (I think I mentioned it more thoroughly in a previous post). The tty terminals do not look right. The text is too large, and the color is changed (should be white). As compared to when the issue is fixed, it is annoying to work in the tty terminals.
Less of a Linux noob every day.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 1:49 pm

Uncle_Snail wrote:
sgtor wrote: There is actually one other major problem (I think I mentioned it more thoroughly in a previous post). The tty terminals do not look right. The text is too large, and the color is changed (should be white). As compared to when the issue is fixed, it is annoying to work in the tty terminals.
That actually could be a video card or driver issue I seem to remember you saying it's a different color every time. I'll have to read back.
Can you remember if you changed anything before that and if so what? These things don't generally happen by themselves unless it's hardware failing. It's not always a software issue. Have you tried making sure all the cables are fully plugged in the monitor and the computer? Did you unplug them recently? If so you should check them to make sure no pins are bent.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 2:00 pm

Oh yeah I forgot to ask. You are still referring to TTY1 right?

If instead you're talking about the windows terminal emulator then you may have just changed settings under profile from the menu and forgot?
There's also a way to enlarge the text with a key combination I can't remember off the top of my head what works on mint because I never use it.

Maybe you were typing away and hit that key combination without realizing it. It's usually Ctrl+ + or something.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 3:19 pm

sgtor wrote:Oh yeah I forgot to ask. You are still referring to TTY1 right?

If instead you're talking about the windows terminal emulator then you may have just changed settings under profile from the menu and forgot?
There's also a way to enlarge the text with a key combination I can't remember off the top of my head what works on mint because I never use it.

Maybe you were typing away and hit that key combination without realizing it. It's usually Ctrl+ + or something.
Yes, I am talking about tty1, and all the other tty's.
I am quite sure that I did not accidentally enlarge the text, because I had this issue, fixed it by reinstalling graphics drivers, then got it to break again, just be reinstalling the exact same driver as before.
Less of a Linux noob every day.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 4:20 pm

Just out of curiosity do you have a live CD that you're booting to maybe you forgot it in the machine?
That Linux Mint.... on the boot screen is pretty visible from a live CD.

If not then try booting from a live CD and see if you have the same problems, just out of curiosity.

Theres also a command that you run in the terminal that will change font size on TTY terminals but I can't remember the darn thing it was so long ago that I used it. Maybe someone knows which one I mean? It brings up a blue screen like the setup command on slackware used to do.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 4:31 pm

sgtor wrote:Just out of curiosity do you have a live CD that you're booting to maybe you forgot it in the machine?
That Linux Mint.... on the boot screen is pretty visible from a live CD.

If not then try booting from a live CD and see if you have the same problems, just out of curiosity.
I could boot from a live cd, but I am quite sure that I am not doing so right now. I can see that my disk drive is empty :P
I think I will install LMDE on a new partition and see if this problem persists. I'm getting a little busy right now though, so I may not any time soon.
Less of a Linux noob every day.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 4:37 pm

Sounds like a plan but booting from a live CD first would be faster and less obtrusive than installing to another drive or partition.

Uncle_Snail
Level 1
Level 1
Posts: 22
Joined: Sat May 27, 2017 11:43 pm

Re: Boots to tty1 before login

Post by Uncle_Snail » Thu Jun 01, 2017 4:45 pm

sgtor wrote:Sounds like a plan but booting from a live CD first would be faster and less obtrusive than installing to another drive or partition.
Yes, I will boot to a live cd first, but it is hard to tell if the error is there, because a live cd boots differently than normal linux mint
Less of a Linux noob every day.

sgtor
Level 2
Level 2
Posts: 93
Joined: Sat May 13, 2017 9:39 pm

Re: Boots to tty1 before login

Post by sgtor » Thu Jun 01, 2017 5:33 pm

Uncle_Snail wrote:
sgtor wrote:Sounds like a plan but booting from a live CD first would be faster and less obtrusive than installing to another drive or partition.
Yes, I will boot to a live cd first, but it is hard to tell if the error is there, because a live cd boots differently than normal linux mint
Yeah I get that I was thinking more to test your TTY1 with the big text and different colors.

I still think your bootup is normal, seriously from everything you've said about it only 3 or 4 second delay on black screen that looks like TTY1.
It's a normal bootup :) I would forget about it.

Post Reply

Return to “Cinnamon”