Autologin on lightdm

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
User avatar
Terryphi
Level 3
Level 3
Posts: 145
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: Autologin on lightdm

Post by Terryphi » Tue Jul 11, 2017 5:47 am

Everything was working fine after tweak to achieve autologin but ........ today on boot Mint logo shows then hangs (blank screen) and does not go to login window. Any suggestions?
Version: LM 19 64bit Mate

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Autologin on lightdm

Post by Cosmo. » Tue Jul 11, 2017 5:50 am

Pjotr wrote:Or request to join that team....
Never! By confirming his previous post in a new one the motivation terminator has closed the door forever. If this continues, it might be at some point not the only door ....

EDIT: Just for the record: I did not request a translation correction; actually I mentioned this in brackets just to describe, why the removal of the official spices names in the dialogs is unfortunate for providing help. (For my own usage I can live with it.) Actually I suggested to bring the official names back, and that has not the least to do with the translators. What followed later may understand, who wants. I would cost me one link to prove, where this person did exactly, what he accused me, but it would bring nothing further.
Last edited by Cosmo. on Tue Jul 11, 2017 6:09 am, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Autologin on lightdm

Post by Cosmo. » Tue Jul 11, 2017 5:54 am

Terryphi wrote:Everything was working fine after tweak to achieve autologin but ........ today on boot Mint logo shows then hangs (blank screen) and does not go to login window. Any suggestions?
What did you change after successfully activating auto-login with lightdm?

User avatar
Terryphi
Level 3
Level 3
Posts: 145
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: Autologin on lightdm

Post by Terryphi » Tue Jul 11, 2017 6:17 am

Cosmo. wrote:
Terryphi wrote:Everything was working fine after tweak to achieve autologin but ........ today on boot Mint logo shows then hangs (blank screen) and does not go to login window. Any suggestions?
What did you change after successfully activating auto-login with lightdm?
Nothing. It worked through several boots yesterday. This problem arose on boot this morning.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Autologin on lightdm

Post by Cosmo. » Tue Jul 11, 2017 6:28 am

My first suspicion in such cases is the graphic driver.

Try this:
Boot into recovery mode, to be found in the sub meu of the grub menu. If the grub menu does not appear for you automatically, press and hold a shift key directly after powering on.

After a few seconds you get a menu. Select the first option = "resume". You will be prompted, that some graphics driver will not get properly loaded; confirm it with the Enter key. If the system boots now successfully my suspicion is very mostly right. Open a new thread in this case in the hardware section, as it is not related to this topic.

User avatar
Terryphi
Level 3
Level 3
Posts: 145
Joined: Mon Jun 06, 2011 6:30 am
Location: West Wales. UK

Re: Autologin on lightdm

Post by Terryphi » Tue Jul 11, 2017 6:51 am

This problem has been reported by several people in the Blog. I tried the suggested solutions but none worked for me. So I removed lightdm and installed mdm making it the default. Problem solved.

Thanks for your thoughts Cosmo but lightdm seems to be the problem for me. I hope future versions go back to mdm. I am seriously considering leaving my other two machines on 18.1 which works perfectly.
Version: LM 19 64bit Mate

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Autologin on lightdm

Post by Cosmo. » Tue Jul 11, 2017 7:12 am

I had played with auto-login in the beta version of 18.2 and it worked well. I also played with it in an upgraded system, after the upgrade path was open (with having replaced mdm by lightdm), again without issues. Both in VirtualBox, where in all cases the system are kept in their original state, except that I had installed the needed VB guest additions. With this results I cannot reproduce the issue (but it does not mean, that I claim, that they do not exist) and cannot investigate into it. How can one look for a failure, which does not appear?

It would be really of interest to see, if also users with a fresh install of 18.2 are affected by the issue. For now I can only watch, what gets reported here and ask back, if I notice anything of interest. I also observe, if there is anything at GitHub, but until now there is nothing.

TitaniumCoder477
Level 1
Level 1
Posts: 1
Joined: Sun Apr 01, 2018 10:32 pm

Re: Autologin on lightdm

Post by TitaniumCoder477 » Tue Oct 16, 2018 3:19 pm

I am running Linux Mint 19 Tara with MATE desktop, and this worked for me.

Edit lightdm.conf to reflect the following:

Code: Select all

[Seat:*]
allow-guest=true
autologin-guest=true
Additionally, since I was setting up a Kiosk computer, I followed these steps:
  • Create a new template account from which the guest account will revert to on each logon, for example: guest-tmpl
  • Login to that account and customize it to what you expect the guest account to be like
  • Open terminal and type: sudo ln -v -s /home/guest-tmpl /etc/guest-session/skel
(where guest-tmpl is whatever you called your template account)
  • Reboot
The above additional steps will link the guest account skeleton to the template account so every time the guest account logs in, it reverts to the template account settings.

Ref: https://sites.google.com/site/easylinux ... our-liking

Finally, since I was setting up a Kiosk computer, I added these lines to lock the logon prompt down to just the guest account:

Code: Select all

greeter-hide-users=true
greeter-show-manual-login=false
Just be warned that if you hide the user list AND prevent manual login, you won't be able to login either! The only account that would be able to logon automatically and from the GUI logon would be guest. You would have to use CTRL+ALT+F1 or so to access the CLI and make changes through there and/or temporarily comment out these last two settings to regain access to your GUI. Basically these last two settings are the final ones you'd want to implement for a kiosk machine. Maybe a tad off topic but possibly worth a mention.

Post Reply

Return to “Cinnamon”