Problem with resume from suspend, 18.2 Cinnamon

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
asquartz
Level 1
Level 1
Posts: 18
Joined: Mon Oct 05, 2015 1:53 pm

Problem with resume from suspend, 18.2 Cinnamon

Post by asquartz » Thu Aug 03, 2017 2:36 pm

Hi,

Lately I have been having trouble with resuming after suspend (when I lift the laptop lid).

instead of the lock screen, I can see the desktop as I left it. I can use the touchpad to move the mouse around, but can't click on anything or type anything. I can only Ctrl-Alt-Backspace to return to the main login screen.

My 18.2 is an upgrade from 18.1, and I have not chosen to change to LightDM, I am still on MDM. I have installed all the updates that have been notified to me.

Can anyone give me a pointer where to start looking please? This is an intermittent issue and does not happen every time.

Code: Select all

System:    Host: sursamen Kernel: 4.10.0-27-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.4 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine:   System: Dell (portable) product: Latitude E6430 v: 01
           Mobo: Dell model: 0H3MT5 v: A00 Bios: Dell v: A07 date: 10/08/2012
CPU:       Dual core Intel Core i5-3210M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9967
           clock speeds: max: 2500 MHz 1: 2470 MHz 2: 2500 MHz 3: 2362 MHz 4: 2245 MHz
Graphics:  Card: NVIDIA GF108GLM [NVS 5200M] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz
           GLX Renderer: Gallium 0.4 on NVC1
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GF108 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-27-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: down mac: <filter>
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 03:00.0
           IF: wlp3s0b1 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (25.8% used)
           ID-1: /dev/sda model: HGST_HTS725050A7 size: 500.1GB
Partition: ID-1: / size: 46G used: 12G (28%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 138G used: 105G (81%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 4.00GB used: 0.03GB (1%) fs: swap dev: /dev/sda8
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: N/A gpu: 60.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 219 Uptime: 1 day Memory: 1551.2/3891.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.481) inxi: 2.2.35 
Edit: Looks similar to this problem which someone was having with 18.1. No solution to that one...
viewtopic.php?t=236041

User avatar
kyphi
Level 8
Level 8
Posts: 2264
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by kyphi » Fri Aug 04, 2017 5:32 pm

Upgrade the kernel from 4.10.0-27 to 4.10.0-28. That fixed it for me.
Linux Mint 19 Cinnamon - 64bit

Nesbit
Level 1
Level 1
Posts: 21
Joined: Tue Dec 02, 2014 11:57 am

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by Nesbit » Mon Aug 07, 2017 11:17 am

I have exactly the same problem (with a fresh installation of 18.2). Any help would be very appreciated!

Nesbit
Level 1
Level 1
Posts: 21
Joined: Tue Dec 02, 2014 11:57 am

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by Nesbit » Mon Aug 07, 2017 11:19 am

P/s: My active Linux Kernel is 4.10.0-30.

asquartz
Level 1
Level 1
Posts: 18
Joined: Mon Oct 05, 2015 1:53 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by asquartz » Tue Aug 15, 2017 4:39 pm

Hi kyphi

Thanks for the suggestion, sorry I seemed to ignore it, as the forum didn't give me a notification.

I had actually rolled back from 4.10.something to 4.8.something to see if it helped. I will try going forward again to the most recent and see what happens.

User avatar
kyphi
Level 8
Level 8
Posts: 2264
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by kyphi » Tue Aug 15, 2017 5:58 pm

Regarding "suspend" and kernel version, I tested the following:

1. kernel 4.4.0.87 - suspend worked perfectly.
2. kernel 4.8.0-53 - suspend worked perfectly.
3. kernel 4.10.0-27 - suspend worked for short periods but not for long periods. Possibly a conflict with automated programs.
4. kernel 4.10.0-28 - suspend worked perfectly.
5. kernel 4.10.0-30 - suspend worked perfectly.
Linux Mint 19 Cinnamon - 64bit

asquartz
Level 1
Level 1
Posts: 18
Joined: Mon Oct 05, 2015 1:53 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by asquartz » Sat Sep 16, 2017 8:47 am

Resurrecting an old thread here, but I'm still having problems with suspend and resume. I've tried a variety of kernels and am now on the most recent one offered in the update manager. All give me problems when resuming from suspend, say three times out of five I have to CTRL-ALT-Backspace and log in again. Usually have to restart the network-manager to get wifi going again too.

Any ideas other than the kernel as to what might cause this? At the moment it is causing me to consider other distros... :(

inxi information is in the OP.

Thanks :)

an7894na
Level 1
Level 1
Posts: 1
Joined: Tue Sep 26, 2017 12:24 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by an7894na » Tue Sep 26, 2017 12:28 pm

I have the exact same problem, and have for the last months. So far I have not found anything that solves this, but will post if I do.

User avatar
songhuijohn
Level 3
Level 3
Posts: 166
Joined: Thu Apr 28, 2016 5:00 pm
Location: Arlington, Texas USA

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by songhuijohn » Sat Nov 18, 2017 7:30 pm

On one of my three Linux Mint 18.2 computers I am having this problem. All three computers have the latest updates.
This is the computer that is having the problem:
john@john-100-5155 ~ $ inxi -Fzx
System: Host: john-100-5155 Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya
Machine: System: Hewlett-Packard product: 100-5155 v: 1.00
Mobo: PEGATRON model: 2AAE v: 1.03
Bios: American Megatrends v: 6.07 date: 03/18/2011
CPU: Dual core AMD Athlon II X2 260u (-MCP-) cache: 2048 KB
flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 7200
clock speeds: max: 1800 MHz 1: 1800 MHz 2: 1800 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
bus-ID: 01:05.0
Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1600x900@60.00hz
GLX Renderer: Gallium 0.4 on AMD RS880 (DRM 2.49.0 / 4.10.0-38-generic, LLVM 4.0.0)
GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network: Card-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe
driver: rt2800pci v: 2.3.0 bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: e800 bus-ID: 04:00.0
IF: enp4s0 state: down mac: <filter>
Drives: HDD Total Size: 60.0GB (21.2% used)
ID-1: /dev/sda model: KingDian_S200_60 size: 60.0GB
Partition: ID-1: / size: 52G used: 8.3G (18%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.02GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 33.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 200 Uptime: 1 min Memory: 569.7/3697.8MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0

Can any one help me with this problem???

I am very sure that in the past on some level of 18.2 resume from suspend was working on this computer.

Additional information - went back to Linux Mint 17.3 Cinnamon ( Linux Kernel 3.19.0-32 and Cinnamon Version 2.86) and suspend now works on my computer. I think I had discovered a bug - how do I report this bug?
Last edited by songhuijohn on Sat Feb 03, 2018 4:03 pm, edited 1 time in total.
Linux Mint 18.3 Cinnamon, Mobo MSI A68HM Grenade, AMD A8-7600, 4GIG DDR3 1600, SSD Patriot Blast 120 GB

disabati
Level 1
Level 1
Posts: 1
Joined: Sat Jan 20, 2018 6:36 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by disabati » Sat Jan 20, 2018 6:42 pm

I've updated to 18.3 Cinnamon and continue to have "resume from suspend" issue. Had never had a single problem with versions 17.3 or before and I too have tried every kernel version including the latest 4.14.11 (til now). Have tried updating drivers, removing drivers, just about every thought someone has had and suspend works about 10% of the time for me. Quite frustrating that so many people are having this issue for so long. And, my hardware is all within 4 years old.

Gamesmedic
Level 1
Level 1
Posts: 4
Joined: Thu Feb 22, 2018 8:35 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by Gamesmedic » Sat Mar 31, 2018 11:02 am

SAME ISSUE.

When resuming from suspend all I get is a black screen. Computer comes to life, but seems to have no hard drive activity.
System: Host: MAN-PC Kernel: 4.13.0-37-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: Gateway product: MD2614U v: Rev 1
Mobo: Gateway model: N/A v: 9A.05
Bios: Phoenix v: 9A.05 date: 12/01/2008
CPU: Dual core AMD Turion X2 Mobile RM-72 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 svm) bmips: 8400
clock speeds: max: 2100 MHz 1: 1050 MHz 2: 2100 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RS780M [Mobility Radeon HD 3200]
bus-ID: 01:05.0
Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1366x768@60.11hz
GLX Renderer: AMD RS780 (DRM 2.50.0 / 4.13.0-37-generic, LLVM 5.0.0)
GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] RS780 HDMI Audio [Radeon (HD) 3000 Series]
driver: snd_hda_intel bus-ID: 01:05.1
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2
Sound: Advanced Linux Sound Architecture v: k4.13.0-37-generic
Network: Card-1: Marvell 88E8057 PCI-E Gigabit Ethernet Controller
driver: sky2 v: 1.30 port: a000 bus-ID: 02:00.0
IF: enp2s0 state: down mac: <filter>
Card-2: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express)
driver: ath9k bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives: HDD Total Size: 120.0GB (15.4% used)
ID-1: /dev/sda model: HITACHI_HTS54251 size: 120.0GB
Partition: ID-1: / size: 24G used: 18G (79%) fs: ext4 dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 77.2C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 173 Uptime: 37 min Memory: 1192.7/3690.5MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Gamesmedic
Level 1
Level 1
Posts: 4
Joined: Thu Feb 22, 2018 8:35 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by Gamesmedic » Sat Mar 31, 2018 11:04 am

It seems to be a problem related to AMD processors

aknickolai
Level 1
Level 1
Posts: 10
Joined: Fri Apr 06, 2018 12:43 pm

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by aknickolai » Thu Apr 12, 2018 3:49 am

For what it is worth I had the same issue on a macbook pro (2007) vintage and an old thinkpad with Cinammon. Drove me nuts since I use the laptops for AVR development, so I go back and fourth between tinkering with circuits and my laptop. Having to restart all the time was a bummer. I REALLY liked everything else about Cinammon. Just never found a solution even after trying some fixes and disabling the screen saver.

anpr22
Level 1
Level 1
Posts: 10
Joined: Wed Apr 25, 2018 5:47 am

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by anpr22 » Thu May 03, 2018 2:45 am

Since my Linux mint 18.1 till 18.3, one problem never got solved is my systems failure to resume from suspend ( Just nothing happens when I press any key to resume but it is suspended well as shown by blinking power indicator ). I must say hibernation works well. also, windows face no problem in sleep/wake. I have Intel motherboard, CPU, and onboard graphics chip.

Please, someone, help me out. I even checked my bios settings and nothing is there for me to tinker with this issue.

User avatar
AZgl1500
Level 8
Level 8
Posts: 2004
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Problem with resume from suspend, 18.2 Cinnamon

Post by AZgl1500 » Thu May 03, 2018 8:30 pm

My ASUS TP500L is an i3 Intel cpu, and it locks up on suspend and hibernate and sleep.

the only solution that works for me is to set every thing to NEVER, and 'Lid closed' to Nothing.
the display blanks when the lid is closed.

4.13.0-39-generic x86_64 (64 bit)
Desktop: Cinnamon 3.6.7 Distro: Linux Mint 18.3 Sylvia

CPU: Dual core Intel Core i3-4030U (-HT-MCP-) cache: 3072 KB
clock speeds: max: 1800 MHz 1: 1061 MHz 2: 1209 MHz 3: 1169 MHz
4: 1297 MHz

Post Reply

Return to “Cinnamon”