[SOLVED] Applications look like Windows 95

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
GiS91
Level 1
Level 1
Posts: 5
Joined: Thu Nov 09, 2017 6:28 am

[SOLVED] Applications look like Windows 95

Postby GiS91 » Thu Nov 09, 2017 7:04 am

Hi everyone.

I have Linux Mint 18.2 "Sonya" - Cinnamon (64-bit). All of sudden, all my applications started to look somewhat like WIndows '95. Here they are two image-URLs for LibreOffice & Pinta respectively which better illustrate the problem:

https://www.dropbox.com/s/g13kwvpxufnarlg/LibreOffice.png?dl=0
https://www.dropbox.com/s/22ejy1mq6ktznec/Pinta.png?dl=0&m=

How could I solve it?

Thank you in advance!
G.

User avatar
Moem
Level 11
Level 11
Posts: 3700
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Applications look like Windows 95

Postby Moem » Thu Nov 09, 2017 7:41 am

Does this effect persist after a reboot?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
karlchen
Level 17
Level 17
Posts: 7951
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Applications look like Windows 95

Postby karlchen » Thu Nov 09, 2017 7:44 am

Hi, GiS91.

Looks like Cinnamon has crashed and you are now running in fallback mode, which seems to be be some Mate desktop actually.
When the same happened here some days ago, Cinnamon told me that it had crashed.
It offered to restart itself. Which worked by the way, without rebooting. Even without logging off from the GUI and logging back in.

Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

User avatar
Moem
Level 11
Level 11
Posts: 3700
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Applications look like Windows 95

Postby Moem » Thu Nov 09, 2017 7:47 am

And if it doesn't offer, you can restart Cinnamon by pressing Ctrl-Alt-Esc.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

GiS91
Level 1
Level 1
Posts: 5
Joined: Thu Nov 09, 2017 6:28 am

Re: Applications look like Windows 95

Postby GiS91 » Thu Nov 09, 2017 7:55 am

Moem wrote:Does this effect persist after a reboot?


Yes. I tried to reboot Cinnamon over and over but the problem persists.

karlchen wrote:Hi, GiS91.

Looks like Cinnamon has crashed and you are now running in fallback mode, which seems to be be some Mate desktop actually.
When the same happened here some days ago, Cinnamon told me that it had crashed.
It offered to restart itself. Which worked by the way, without rebooting. Even without logging off from the GUI and logging back in.

Karl


Unfortunately, rebooting did not solve the problem. I tried to reinstall Cinnamon by typing sudo apt-get install --reinstall cinnamon but without success.

User avatar
minitux
Level 5
Level 5
Posts: 584
Joined: Tue Sep 12, 2017 10:05 am

Re: Applications look like Windows 95

Postby minitux » Thu Nov 09, 2017 8:02 am

Try ti reinstall

Code: Select all

sudo apt install --reinstall libreoffice-style-mint mint-themes-gtk3
and reset the themes Mint x from system settings/themes
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

User avatar
karlchen
Level 17
Level 17
Posts: 7951
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Applications look like Windows 95

Postby karlchen » Thu Nov 09, 2017 8:08 am

Hello, GiS91.

You have verified in the graphical login screen that you have not selected "Cinnamon Fallback Mode" as your session type by accident?

Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

GiS91
Level 1
Level 1
Posts: 5
Joined: Thu Nov 09, 2017 6:28 am

Re: Applications look like Windows 95

Postby GiS91 » Thu Nov 09, 2017 8:37 am

minitux wrote:Try ti reinstall

Code: Select all

sudo apt install --reinstall libreoffice-style-mint mint-themes-gtk3
and reset the themes Mint x from system settings/themes


I executed the command first, then I switched Window borders to Adwaita, Icons to Mint-X and Controls to Mint-Y and... well, It worked for all applications!

Anyway, what I've noted is that there is no Mint-X option for Window borders and Controls. Sincerely, it's not a thing I paid too much attention to thus far, so I'd not want Mint-X is not available because something got "corrupted"...

User avatar
minitux
Level 5
Level 5
Posts: 584
Joined: Tue Sep 12, 2017 10:05 am

Re: Applications look like Windows 95

Postby minitux » Thu Nov 09, 2017 8:45 am

Try also a reboot
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

GiS91
Level 1
Level 1
Posts: 5
Joined: Thu Nov 09, 2017 6:28 am

Re: Applications look like Windows 95

Postby GiS91 » Thu Nov 09, 2017 8:54 am

minitux wrote:Try also a reboot


System rebooted, but Mint-X is not yet available for Window borders and Controls.

User avatar
minitux
Level 5
Level 5
Posts: 584
Joined: Tue Sep 12, 2017 10:05 am

Re: Applications look like Windows 95

Postby minitux » Thu Nov 09, 2017 9:04 am

Code: Select all

sudo apt install --reinstall mint-themes
and retry
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

GiS91
Level 1
Level 1
Posts: 5
Joined: Thu Nov 09, 2017 6:28 am

Re: Applications look like Windows 95

Postby GiS91 » Thu Nov 09, 2017 9:20 am

minitux wrote:

Code: Select all

sudo apt install --reinstall mint-themes
and retry


Solved this one, too! Now I have much more styles in Window border and Controls.

At this point, I think the root cause of the issue was just a certain degree of corruption of MInt's themes.

Thanks everyone for your support, guys :)

User avatar
minitux
Level 5
Level 5
Posts: 584
Joined: Tue Sep 12, 2017 10:05 am

Re: [SOLVED] Applications look like Windows 95

Postby minitux » Thu Nov 09, 2017 9:29 am

Nice....bye
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz


Return to “Cinnamon”