[Solved] Can't Disable Hovering Thumbnails

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
hkphooey
Level 1
Level 1
Posts: 10
Joined: Mon Feb 11, 2008 6:32 am

[Solved] Can't Disable Hovering Thumbnails

Post by hkphooey » Thu Nov 30, 2017 10:41 pm

The thumbnail previews of windows irritate me enormously, as they get in the way, so I turn them off with.

Applets -> Window List -> Configure -> "Show Window Thumbnails on Hover" = Off

Well I used to anyway ... with a recent update to something, the Hovering Thumbnails are back, even though the setting is Off.

How do I turn them off now?
Last edited by hkphooey on Tue Dec 19, 2017 4:09 am, edited 1 time in total.

hkphooey
Level 1
Level 1
Posts: 10
Joined: Mon Feb 11, 2008 6:32 am

Re: Can't Disable Hovering Thumbnails

Post by hkphooey » Sat Dec 02, 2017 11:51 pm

I looked in all the settings from "gsettings list-recursively" and there's nothing in there which controls the hovering thumbnails. Where is the setting held?

I did this on a machine where the hover setting is working correctly and can be toggled on and off.

Code: Select all

gsettings list-recursively > before.txt
Then I changed the hover setting, and did

Code: Select all

gsettings list-recursively > after.txt

Code: Select all

diff before.txt after.txt 
showed no difference between the settings.
irritant.jpg

hkphooey
Level 1
Level 1
Posts: 10
Joined: Mon Feb 11, 2008 6:32 am

Re: Can't Disable Hovering Thumbnails

Post by hkphooey » Mon Dec 18, 2017 10:45 pm

OK, finally found the setting ...
~/.cinnamon/configs/window-list@cinnamon.org

Contains 3.json and 4.json. It seems Cinnamon picks the highest numbered one. There's a stanza at the end containing

Code: Select all

    "window-preview": {
        "type": "switch",
        "default": true,
        "description": "Show window thumbnails on hover",
        "value": true
    },
And if you change value: true to false, and restart cinnamon, the hovers go away.
I was hesitant to do this at first as the config file contains an md5 sum at the end, which I thought might check for file integrity, but it seems that's ignored. However, do take a backup of the file before changing it anyway.

Can't figure out how to mark this as Solved

User avatar
Moem
Level 17
Level 17
Posts: 7010
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Can't Disable Hovering Thumbnails

Post by Moem » Tue Dec 19, 2017 1:20 am

hkphooey wrote:Can't figure out how to mark this as Solved
By editing the first post and adding [SOLVED] to the title. Pretty much like you disabled the unwanted thumbnail setting. :wink:
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

hkphooey
Level 1
Level 1
Posts: 10
Joined: Mon Feb 11, 2008 6:32 am

Re: [Solved] Can't Disable Hovering Thumbnails

Post by hkphooey » Tue Dec 19, 2017 4:11 am

Well it wasn't exactly obvious. Which I guess is why you have it in your forum signature. Some BBSes have a button for it.

Post Reply

Return to “Cinnamon”