Cinnamon crashes when connecting with vnc

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
sjwillar
Level 1
Level 1
Posts: 2
Joined: Fri Dec 01, 2017 11:09 am

Cinnamon crashes when connecting with vnc

Post by sjwillar » Fri Dec 01, 2017 11:34 am

Hey,
I'm trying to install a vnc client so I can use my home desktop as a remote access server. I've tried installing vnc4server, tightvncserver, and tigervncserver all of which present the issue. When I connect, so far only from the desktop, I get a window that says "Cinnamon just crashed. You are currently running in Fallback Mode. Do you want to restart Cinnamon?". Clicking yes just brings the same prompt up over and over again. Since it happened with all three vnc programs I figured this would be the place to ask about it. My xstartup script is as follows (sorry, wouldn't let me attach it):

#!/bin/sh
unset DBUS_SESSION_BUS_ADDRESS
EXEC /etc/X11/xinit/xinitrc

xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
#x-window-manager &
# Fix to make GNOME work
export XKL_XMODMAP_DISABLE=1
/etc/X11/Xsession &
exec cinnamon-session &

I'm running Linux Mint 18.2 Cinnamon 64-bit, Cinnamon 3.4.6 on linux kernel 4.8.0-53-generic. The graphics card is an NVIDIA GeForce GTX 750 Ti.

Downgrading from the nvidia-384 driver to nvidia-340 at least lets me open windows and such, but cinnamon still crashes. I was wondering if anyone knew of a way to resolve the cinnamon crashing issue.

Extra Info:
I installed tiger vnc with this tutorial: http://c-nergy.be/blog/?p=10241
I installed vnc4server with different variations of this tutorial: http://www.stuartellis.name/articles/vnc-on-linux/

Let me know if you need more info from me. Thanks in advance.

User avatar
greerd
Level 5
Level 5
Posts: 952
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Cinnamon crashes when connecting with vnc

Post by greerd » Fri Dec 01, 2017 3:49 pm

Hi sjwillar

I thought vino (a vnc server) was installed by default, you can check by opening a terminal and typing:

Code: Select all

apt policy vino
If the installed line gives a version number then it's installed. It might show up in the menu as Desktop Sharing, or just search in the menu for vino. Remmina should also be a default install and can be used as a vnc client or to allow an incoming connection via vino.

Why the xstartup script?

Also could you tell us more about your system by pasting the output of the following command in the 'Code' tab?

Code: Select all

inxi -Fxz

sjwillar
Level 1
Level 1
Posts: 2
Joined: Fri Dec 01, 2017 11:09 am

Re: Cinnamon crashes when connecting with vnc

Post by sjwillar » Mon Dec 04, 2017 6:18 pm

I didn't use vino because I want a new desktop when I connect remotely, not just viewing the current desktop. Basically, I want to use my desktop as a linux server with the ability to support multiple users simultaneously and as far as I read, vino doesn't support that. I uninstalled vino to make sure the new vnc programs didn't clash with it.

My understanding about the xstartup script is that it is used by the vncserver to start the new desktop environment since it's not just sharing the desktop started on boot. I've tried using the same startup script that linux uses on boot, but that still gave the same error.

Here's the output from the second command.

Code: Select all

System:    Host: sam-Linux Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx
           Bios: American Megatrends v: 2501 date: 04/07/2014
CPU:       Quad core AMD FX-8350 Eight-Core (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 32107
           clock speeds: max: 4000 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz
           4: 1400 MHz 5: 2100 MHz 6: 1400 MHz 7: 1400 MHz 8: 1400 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1680x1050@59.88hz, 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 750 Ti/PCIe/SSE2
           GLX Version: 4.4.0 NVIDIA 340.102 Direct Rendering: Yes
Audio:     Card-1 NVIDIA Device 0fbc driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-3 Logitech Clear Chat Comfort USB Headset
           driver: USB Audio usb-ID: 005-002
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: c000 bus-ID: 09:00.0
           IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1386.5GB (4.1% used)
           ID-1: /dev/sda model: Hitachi_HDS72101 size: 1000.2GB
           ID-2: /dev/sdb model: TOSHIBA_THNSNC12 size: 128.0GB
           ID-3: /dev/sdc model: ST3250820AS size: 250.1GB
           ID-4: USB /dev/sdd model: Flash_Disk size: 8.2GB
Partition: ID-1: / size: 289G used: 45G (17%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 5.37GB used: 0.00GB (0%) fs: swap dev: /dev/sdb7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 12.9C mobo: N/A gpu: 0.0:25C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 231 Uptime: 1:01 Memory: 954.5/7883.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Post Reply

Return to “Cinnamon”