random appearing glitch in text and windows

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
mi2501
Level 1
Level 1
Posts: 28
Joined: Sun Dec 31, 2017 6:57 am

random appearing glitch in text and windows

Post by mi2501 » Mon Jan 08, 2018 1:53 pm

I randomly experience system widely the corrupted display of one text character and, not linked, the disappearing in the window header of 2 of the 3 handling little buttons, more precisely close and minimize, cutting a little rectangle form the last part of the bar and letting see the underlying image. It may appear and disappear in the same session.

I'm wandering if it a known bug or it's something occurring only to me

User avatar
sig
Level 1
Level 1
Posts: 10
Joined: Wed Dec 13, 2017 1:24 pm

Re: random appearing glitch in text and windows

Post by sig » Mon Jan 08, 2018 2:10 pm

Is this what you are seeing?

viewtopic.php?f=208&t=261118

mi2501
Level 1
Level 1
Posts: 28
Joined: Sun Dec 31, 2017 6:57 am

Re: random appearing glitch in text and windows

Post by mi2501 » Mon Jan 08, 2018 2:25 pm

sig wrote:Is this what you are seeing?

viewtopic.php?f=208&t=261118
no, the cut hedge is in windows

User avatar
catweazel
Level 12
Level 12
Posts: 4197
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: random appearing glitch in text and windows

Post by catweazel » Mon Jan 08, 2018 2:53 pm

mi2501 wrote:the disappearing in the window header of 2 of the 3 handling little buttons, more precisely close and minimize, cutting a little rectangle form the last part of the bar and letting see the underlying image. It may appear and disappear in the same session.
In my experience, this has almost always been due to a dodgy theme. If you're not using a standard mint theme then set it back and try that.
There is no spoon.

User avatar
sig
Level 1
Level 1
Posts: 10
Joined: Wed Dec 13, 2017 1:24 pm

Re: random appearing glitch in text and windows

Post by sig » Mon Jan 08, 2018 3:13 pm

This happens when I'm using any theme. But I'm currently using the "linxu mint" theme.

mi2501
Level 1
Level 1
Posts: 28
Joined: Sun Dec 31, 2017 6:57 am

Re: random appearing glitch in text and windows

Post by mi2501 » Mon Jan 08, 2018 3:33 pm

the window borders theme I'm using is Mint-X

User avatar
catweazel
Level 12
Level 12
Posts: 4197
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: random appearing glitch in text and windows

Post by catweazel » Mon Jan 08, 2018 3:51 pm

mi2501 wrote:the window borders theme I'm using is Mint-X
Ok, then to help others to help you, please post the output of this terminal command:

Code: Select all

inxi -Fxz
Enclose the results in code markers, which you can select from the mini toolbar above the textbox where you type your reply.
There is no spoon.

mi2501
Level 1
Level 1
Posts: 28
Joined: Sun Dec 31, 2017 6:57 am

Re: random appearing glitch in text and windows

Post by mi2501 » Mon Jan 08, 2018 4:00 pm

Code: Select all

System:    Host: marco-MacBookPro Kernel: 4.10.0-42-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Apple (portable) product: MacBookPro1 1 v: 1.0
           Mobo: Apple model: Mac-F425BEC8 v: PVT
           Bios: Apple v: MBP11.88Z.0055.B08.0610121325 date: 10/12/06
CPU:       Dual core Intel T2400 (-MCP-) cache: 2048 KB
           flags: (nx pae sse sse2 sse3 vmx) bmips: 7323
           clock speeds: max: 1833 MHz 1: 1833 MHz 2: 1833 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV530/M56-P [Mobility Radeon X1600]
           bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1440x900@60.00hz
           GLX Renderer: ATI RV530
           GLX Version: 2.1 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card-1: Marvell 88E8053 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: 2000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Broadcom BCM4321 802.11a/b/g/n driver: wl bus-ID: 03:00.0
           IF: wls1 state: up mac: <filter>
Drives:    HDD Total Size: 80.0GB (15.4% used)
           ID-1: /dev/sda model: ST98823AS size: 80.0GB
Partition: ID-1: / size: 72G used: 9.7G (15%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 2.13GB used: 0.58GB (27%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 205 Uptime: 12:34 Memory: 1590.2/1997.7MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
and here it is an example of the text glitch
IMG.JPG

User avatar
sig
Level 1
Level 1
Posts: 10
Joined: Wed Dec 13, 2017 1:24 pm

Re: random appearing glitch in text and windows

Post by sig » Mon Jan 08, 2018 4:41 pm

I get the exact same issue as well:

Code: Select all

imac@imac-iMac ~ $ inxi -Fxz
System:    Host: imac-iMac Kernel: 4.10.0-42-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Apple product: iMac5 1 v: 1.0
           Mobo: Apple model: Mac-F4228EC8 v: DVT
           Bios: Apple v: IM51.88Z.0090.B09.0706270921 date: 06/27/07
CPU:       Dual core Intel Core2 T7400 (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 8654
           clock speeds: max: 2167 MHz 1: 1500 MHz 2: 1667 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV530/M56-P [Mobility Radeon X1600] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.88hz
           GLX Renderer: ATI RV530 GLX Version: 2.1 Mesa 17.2.4 Direct Rendering: Yes
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card-1: Marvell 88E8053 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: 1000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Broadcom BCM4321 802.11a/b/g/n driver: wl bus-ID: 03:00.0
           IF: wls1 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (8.0% used) ID-1: /dev/sda model: WDC_WD5000AAKX size: 500.1GB
Partition: ID-1: / size: 456G used: 35G (9%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 2.67GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 951
Info:      Processes: 214 Uptime: 1:56 Memory: 1237.5/2991.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0 Client: Shell (bash 4.3.481) inxi: 2.2.35 
imac@imac-iMac ~ $ 
I see we are both using "Apple" Products, mine being a 2006 iMac using the same graphics.
I get the same as the picture you posted above plus icons half gone or missing in my panel.
1.png
top left corner missing.
1.png (5.2 KiB) Viewed 268 times
Attachments
chunks2.png
Missing "Brightness" applet.
chunks2.png (10.63 KiB) Viewed 265 times
chunks1.png
Half "Show Desktop" icon missing and "Hexchat" tab missing left corner.
chunks1.png (11.93 KiB) Viewed 265 times

mi2501
Level 1
Level 1
Posts: 28
Joined: Sun Dec 31, 2017 6:57 am

Re: random appearing glitch in text and windows

Post by mi2501 » Tue Jan 09, 2018 3:19 am

sig wrote:I see we are both using "Apple" Products, mine being a 2006 iMac using the same graphics.
Are you ok with your keyboard mapping?
Can you post your settings, please?
thank you

mi2501
Level 1
Level 1
Posts: 28
Joined: Sun Dec 31, 2017 6:57 am

Re: random appearing glitch in text and windows

Post by mi2501 » Tue Jan 09, 2018 3:51 am

here it is an example of window bar corruption
snapshot4.png
snapshot4.png (18.18 KiB) Viewed 228 times

User avatar
sig
Level 1
Level 1
Posts: 10
Joined: Wed Dec 13, 2017 1:24 pm

Re: random appearing glitch in text and windows

Post by sig » Tue Jan 09, 2018 1:26 pm

More examples:

workspaces.png
Workspaces in panel
workspaces.png (2.54 KiB) Viewed 206 times
corner1.png
Corner of Software Manager
corner1.png (16.17 KiB) Viewed 206 times

User avatar
sig
Level 1
Level 1
Posts: 10
Joined: Wed Dec 13, 2017 1:24 pm

Re: random appearing glitch in text and windows

Post by sig » Tue Jan 23, 2018 12:32 pm

UPDATE
Since I last posted pictures of my 'Tearing' 'Applets' disappearing and icons only showing half. and corners out of my apps missing. (See above pictures for examples of what I'm talking about). I've done quite a few of updates via apt update/upgrade and now the problems are all gone and I cannot any longer get the above issues to happen. Good news for me! I'm just not sure what fixed it. Here is my current 'inxi -GFx' output from my iMac which I was having the issues with.

Code: Select all

System:    Host: imac-iMac Kernel: 4.13.0-31-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Apple product: iMac5 1 v: 1.0 serial: QP7140X6VUW
           Mobo: Apple model: Mac-F4228EC8 v: DVT serial: 1
           Bios: Apple v: IM51.88Z.0090.B09.0706270921 date: 06/27/07
CPU:       Dual core Intel Core2 T7400 (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 8655
           clock speeds: max: 2167 MHz 1: 1000 MHz 2: 1333 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV530/M56-P [Mobility Radeon X1600]
           bus-ID: 01:00.0
           Display Server: X.org 1.18.4 driver: N/A
           tty size: 80x24 Advanced Data: N/A for root
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-31-generic
Network:   Card-1: Marvell 88E8053 PCI-E Gigabit Ethernet Controller
           driver: sky2 v: 1.30 port: 1000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: 00:17:f2:d8:45:c7
           Card-2: Broadcom BCM4321 802.11a/b/g/n driver: wl bus-ID: 03:00.0
           IF: wls1 state: up mac: 00:19:e3:e0:d0:a7
Drives:    HDD Total Size: 500.1GB (9.0% used)
           ID-1: /dev/sda model: WDC_WD5000AAKX size: 500.1GB temp: 34C
Partition: ID-1: / size: 456G used: 40G (10%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 2.67GB used: 0.08GB (3%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 948
Info:      Processes: 236 Uptime: 18:16 Memory: 1710.3/2986.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (sudo) inxi: 2.2.35 
Not sure that I can say [SOLVED] on this thread since it isn't mine but I'd be curious to find out whether the other guys that were running "Apple" hardware that were having these issues is fixed now or not.
:D :D :D :D :D

Post Reply

Return to “Cinnamon”