Black Screen with Cursor on Login Mint 18.2

Please post suggestions for improvement of Cinnamon here
Post Reply
User avatar
Old Marcus
Level 4
Level 4
Posts: 389
Joined: Sun Jun 08, 2008 4:51 pm
Location: Exeter, UK

Black Screen with Cursor on Login Mint 18.2

Post by Old Marcus » Sat Feb 03, 2018 1:03 pm

Hi there, trying to fix a friend's laptop with Mint 18.2 running Cinnamon. On her account when she tries to log in all she gets is a black screen with a cursor. The cursor moves but nothing else can be done. Ctrl+Alt+F1 works to drop into command line but nothing I have done from reading various forums on the matter has worked. In the mean time I was able to create a second account with sudo privileges and this account logs in fine. The guest account also logs in fine so I'm guessing it's a configuration screw up on her account specifically.

When it happened, she was trying to use the photo frame desklet and got as far as pointing to her photo folder which it claimed was empty (it isn't). The laptp then froze and she had to force shutdown with the power button. Since then the login problem has been here.

I've attempted reinstalling cinnamon, the nvidia graphics drivers and installing all updates, no change. I have no idea how to disable the desklets from another user account and I'm not sure if it will help anyway. Below is the output of .xsessionerrors which seemed to have some useful information:

Any help would be much appreciated. In the mean time she can use the account I've made and access her files through there but its a touch convoluted. Any more information needed let me know.
Linux Mint 8 RC1 = Nice
'apt install' can be used on Linux Mint as a shortcut for 'sudo apt-get install'. 'apt x' can be used for various other apt commands as well.
When a problem is solved, please add [SOLVED] to your thread title.

Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Black Screen with Cursor on Login Mint 18.2

Post by Cosmo. » Sat Feb 03, 2018 7:35 pm

Forcing shutdown with the power button (aka hard shut down) could be the cause of the problem. This should always get avoided. Possibly your friend has damaged the file system; if so a new installation with new formatting the hard drive might be needed.

Do from the new account:

Code: Select all

sudo touch /forcefsck
Than reboot. This forces a file system check at boot time, following that it is possible, that the boot time gets significantly longer (only one time).

In general: If the system does not react on anything, there is in 95 % of all cases still a way to go: Press and hold both the alt key and the print key; while still holding them press those keys: r e i s u b (with a little break after each letter); after the last letter the system will reboot.

Can you open in the old account the terminal by pressing ctrl-alt-t?

Level 1
Level 1
Posts: 1
Joined: Fri Jun 15, 2018 11:01 am
Location: Hessen, Germany

Re: Black Screen with Cursor on Login Mint 18.2

Post by Lindei » Fri Jun 15, 2018 11:21 am

Hi Old Marcus,

i don't know if it's still of interest to you, but today i stumbled over the same problem, exactly as you described it.
A quick (and maybe somehow dirty) solution was to simply delete the folder located in
/usr/share/cinnamon/desklets and reboot. That brought cinnamon back to life on my machine and i could not find any
backdraws so far. To delete the folder and its contents you need administrative rights.

greetings Robert

Post Reply

Return to “Cinnamon”