Desktop does not awake since kernel change

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
balint
Level 1
Level 1
Posts: 6
Joined: Sun Mar 04, 2018 2:52 pm
Location: Hungary, Budapest

Desktop does not awake since kernel change

Post by balint » Sun Mar 04, 2018 4:31 pm

My desktop does not awake from sleep, since I changed kernel to 4.13.0-36 from 4.8.0-53. The screen remains black, and does not answer any keyboard or mouse action. I have to force stop the laptop to restart.

Details: OS: LxMint 18.3/Cinnamon 3.6.7+sylvia / 64-bit / Kernel~4.13.0-36-generic x86_64
HW: Aspire V3-372_104C_1.02 / CPU~Dual core Intel Core i5-6200U (-HT-MCP-) Speed/max~2400/2800 MHz
Mem 7883.7MB SSD~500.1GB / Intel HD graphics 520

No other fallback I experienced however.
:idea: :?:

User avatar
Moem
Level 17
Level 17
Posts: 7251
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Desktop does not awake since kernel change

Post by Moem » Sun Mar 04, 2018 5:55 pm

I'd go back to the previous kernel then. Any specific reason why you made that change?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
karlchen
Level 19
Level 19
Posts: 9541
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Desktop does not awake since kernel change

Post by karlchen » Sun Mar 04, 2018 6:07 pm

Any specific reason why you made that change?
Let me make an educated guess:
Kernel series 4.8.0 is no longer supported by Ubuntu. As a consequence any 4.8.0 kernel has not received any of the workarounds against the CPU vulnerabilities named "Spectre 1", "Spectre 2" and "Meltdown".
Kernel series 4.13.0 currently is supported by Ubuntu and has received all available workarounds against the CPU vulnerabilities named "Spectre 1", "Spectre 2" and "Meltdown".
Finally, replacing de-supported kernel series by supported ones is officially recommend by Linux Mint.
How to update your kernel for Meltdown and Spectre
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

User avatar
Moem
Level 17
Level 17
Posts: 7251
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Desktop does not awake since kernel change

Post by Moem » Sun Mar 04, 2018 6:17 pm

Okay, I misread 'from' as 'to' and 'to' as 'from'... :oops:
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
karlchen
Level 19
Level 19
Posts: 9541
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Desktop does not awake since kernel change

Post by karlchen » Sun Mar 04, 2018 7:23 pm

Hello, balint.

In order to get an idea why kernel 4.13.0 prevents your system from starting up properly, we need more technical details about your system.
In order to provide these details to us, please, proceed like follows:
  • Reboot your Linux Mint to the previous kernel, i.e to the working kernel 4.8.0.
  • Open a terminal window.
  • Execute the commandline

    Code: Select all

    inxi -Fxz
    exactly as it has been typed here.
  • Mark the complete output which inxi will display, copy it and paste it into your next reply.
Till the issue with kernel 4.13.0 has been solved (hopefully), you will have to go on booting to your previous kernel 4.8.0 as a workaround.

P.S.
I knew I had read about a similar problem only recently. Note, similar, not totally identical. But maybe the steps to solve the issues, explained by jw jensen in this thread will help you as well: 18.2 System freezes
(although it is kind of hidden between a lot of verbose complaints about insufficient Linux Mint support).

Best regards,
Karl
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

User avatar
Schultz
Level 6
Level 6
Posts: 1368
Joined: Thu Feb 25, 2016 8:57 pm

Re: Desktop does not awake since kernel change

Post by Schultz » Sun Mar 04, 2018 8:57 pm

karlchen wrote:
Till the issue with kernel 4.13.0 has been solved (hopefully), you will have to go on booting to your previous kernel 4.8.0 as a workaround.
Wouldn't it be better for the OP to go with kernel series 4.4 since it's an LTS kernel still getting security updates and has gotten the Spectre/Meltdown fixes? As already noted kernel series 4.8 is end-of-life (since August).

balint
Level 1
Level 1
Posts: 6
Joined: Sun Mar 04, 2018 2:52 pm
Location: Hungary, Budapest

Re: Desktop does not awake since kernel change

Post by balint » Mon Mar 05, 2018 4:58 am

Hi Karl and Everybody,
many thanks for all the answers. Exactly, I have changed my kernel as I was advised by the article 'Security notice: Meltdown and Spectre' (https://blog.linuxmint.com/?p=3496).

Now, for a short time I switched back to the kernel 4.8 and I've got the system information:
-----------------------------------------------------------------------

Code: Select all

balint@Aspire-V3 ~ $ inxi -Fxz
System:    Host: Aspire-V3 Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Acer (portable) product: Aspire V3-372 v: V1.02
           Mobo: Acer model: Aspire V3-372 v: V1.02
           Bios: Insyde v: V1.02 date: 10/19/2015
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9600
           clock speeds: max: 2800 MHz 1: 626 MHz 2: 500 MHz 3: 499 MHz
           4: 541 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (55.9% used)
           ID-1: /dev/sda model: Samsung_SSD_750 size: 500.1GB
Partition: ID-1: / size: 28G used: 21G (78%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 431G used: 241G (59%) fs: ext4 dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: 49.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 253 Uptime: 3 min Memory: 1682.0/7888.9MB
           Init: systemd Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
balint@Aspire-V3 ~ $ 
-----------------------------------------------------------------------
Even, I cheked the sleep/awake behavior and it worked perfectly.
Finally, I switched again to the new 4.13 kernel, and gained the system info here as well, see them parallelly in the attached file (balintsAspire.ods). I did not find any essential change. However, inxi did not detetcted that instead of a HDD I have an SSD.

If I do not experience any other problem, I rather keep 4.13 and live together with this sleep confusion for a time than with a security risk...
Best regards,
Balint
Attachments
balintsAspire.ods
(26.14 KiB) Downloaded 7 times

User avatar
AZgl1500
Level 9
Level 9
Posts: 2885
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Desktop does not awake since kernel change

Post by AZgl1500 » Mon Mar 05, 2018 5:20 am

I am using Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia

and the only solution that I was able to come up with was set everything to NEVER....
I close the lid, and the screen turns off, but the PC does not go into Sleep mode.

at end of day, I just power it down.

for me, it has been quite acceptable, as when the lid is opened, it is already to go instantly..
My laptop is a very low heat generating ASUS TP500L specifically marketed for low heat situations.

On my older Dell Inspiron, I had to use a fan support kit under the laptop, it had two fans blowing all the time pushing air into the bottom of the laptop. It worked well, but very klutzy.

balint
Level 1
Level 1
Posts: 6
Joined: Sun Mar 04, 2018 2:52 pm
Location: Hungary, Budapest

Re: Desktop does not awake since kernel change

Post by balint » Mon Mar 05, 2018 5:31 am

Thanks AZgl1500,
I concluded to do now the same. For the SSD I use I do not think this would be a disadvantage.

User avatar
Pjotr
Level 20
Level 20
Posts: 11064
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Desktop does not awake since kernel change

Post by Pjotr » Mon Mar 05, 2018 5:33 am

Try if it helps when you roll back your kernel to the latest one of the 4.4 series, which also contains the Meltdown/Spectre fixes.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
karlchen
Level 19
Level 19
Posts: 9541
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Desktop does not awake since kernel change

Post by karlchen » Mon Mar 05, 2018 5:42 am

Schultz wrote:
Sun Mar 04, 2018 8:57 pm
Wouldn't it be better for the OP to go with kernel series 4.4 since it's an LTS kernel still getting security updates and has gotten the Spectre/Meltdown fixes? As already noted kernel series 4.8 is end-of-life (since August).
I wanted to see the inxi report before giving any advice on how to proceed. If the machine had been brandnew kernel 4.4.0-116 might not have been good enough.
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

Hoser Rob
Level 12
Level 12
Posts: 4464
Joined: Sat Dec 15, 2012 8:57 am

Re: Desktop does not awake since kernel change

Post by Hoser Rob » Mon Mar 05, 2018 9:28 am

Schultz wrote:
Sun Mar 04, 2018 8:57 pm
karlchen wrote:
Till the issue with kernel 4.13.0 has been solved (hopefully), you will have to go on booting to your previous kernel 4.8.0 as a workaround.
Wouldn't it be better for the OP to go with kernel series 4.4 since it's an LTS kernel still getting security updates and has gotten the Spectre/Meltdown fixes? As already noted kernel series 4.8 is end-of-life (since August).
That's what I'm thinking. It's not all that unusual for newer kernels to break something but hopefully there's one pached for meltdown that'll work.

lexattor
Level 1
Level 1
Posts: 1
Joined: Tue Mar 06, 2018 3:34 am

Re: Desktop does not awake since kernel change

Post by lexattor » Tue Mar 06, 2018 4:06 am

I have the same problem, I switched to Mint from Kubuntu a week or so ago. I used Kubuntu for more than 10 years. Same problem there only much worse, at least on Mint everything else that does not work in Kubuntu is fine except for this issue. I have two desktop machines. The one with older hardware I used to test on before I did the upgrade (I learned the hard way with linux) and then my daily work machine (newer but still old in technology terms). The older machine is fine, goes to sleep and wake up normally without glitches. It had all the same issues, but all that was solved after I installed the intel-microcode upgrade from the Driver manager. The other one no. Before installing the intel-microcode it was just as bad as under Kubuntu (16.04 and 17.04). I had to deactivate the screen locker totally in System settings to have a usable system. Before switching to Mint (only to learn that KDE will not be developed further as a Mint flavour) I switched between three different nVidia cards - each switch made the problem less bad or at least have different symptoms. The nouveau driver is slllooooowww and gives worse problems than the nVidia drivers (apps would freeze and the cursor vanish). Okay, maybe this information is of assistance. If you want me to do anything that will assist to solve the issue, please let me know. For now I seem to have solved the remaining issue by simply deactivating screen shutdown - its not ideal, I know, but I need to work on my machine and can't fiddle all day long and reinstall new distros all the while.

P.S. Linux Mint is a very good distibution, I am mightily impressed. Just a pity about KDE in future.

balint
Level 1
Level 1
Posts: 6
Joined: Sun Mar 04, 2018 2:52 pm
Location: Hungary, Budapest

Re: Desktop does not awake since kernel change

Post by balint » Fri May 11, 2018 10:09 am

"Linux Mint is a very good distibution, I am mightily impressed." - So am I.

Kernels:
With 4.13 I am ok, all the hardware are fuctioning well, except sleep/awake.
With 4.4 I had problems, wifi, bluetooth did not work.
4.8 was ok, however it is not supported any more.
Anyway, I am using 4.13 now, and for a longer period I turn off my laptop.

I blogged this bug at Kernel.org Bugzilla – (Bug 199201).

Post Reply

Return to “Cinnamon”