[ SOLVED] Desktop shortcuts to web pages (URLs) have stopped working

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
ppguasch
Level 1
Level 1
Posts: 19
Joined: Fri Dec 09, 2016 7:46 pm

[ SOLVED] Desktop shortcuts to web pages (URLs) have stopped working

Post by ppguasch » Tue Mar 06, 2018 2:25 pm

Hello.

I'm not very experienced in Linux although I have been using it on and off for several years.

I'm running on a:

System: Host: LNXPC Kernel: 4.4.0-21-generic x86_64 (64 bit)
Desktop: Cinnamon 3.0.7 Distro: Linux Mint 18 Sarah

My windows like shortcuts to web pages that I had in my desktop for quick access (URLs), like web accesses to several cloud services and many others, have ceased to work.

Those shortcuts were working perfectly fine until now when, for some reason I ignore, they have stopped working. If I double click on any of them the little round clock appears and remains there for a while seemingly doing something until it disappears but the page doesn't open in the default web browser (Mozilla in my case) as they used to.

The method I originally used to create those shortcuts was simply search for the desired web page on my browser, copy the contents of the URL window in the browser and paste it on the desktop. To be more precise the method used was select the URL from the URL window and then drag and drop it to the desktop (All done with the mouse which was quicker).

This worked perfectly fine until very recently.

To make matters worst I have been keeping many folders full of relevant URLs (obtained with the above mentioned procedure) of many different subjects that interest me and they have ALL ceased to work. I do not use the Bookmark facilities that Mozilla or other browsers offer.

The way they used to work was that once the shortcut was created a simple doubleclick on the desktop icon would open the web browser at the desired URL page.

If I want any of those shortcuts to work now I have to right-click on the desktop icon, select the "Open With" option from the menu window, then select "Other Application" and finally select the "Firefox Web Browser" from the list (Which paradoxically appears under the "Default Application" header already (?) ).

If I then double click on the "Firefox Web Browser" this then opens at the desired URL.

Obviously something is broken but I don't know where to even start looking for. As always I'm a bit reluctant to start trying remedies without first checking with somebody more knowledgeable so as not to make matters worst (It has already happened to me several times).

Do you have any suggestions?

Thank you for your time and interest!

Josep
Last edited by ppguasch on Sat Mar 10, 2018 9:16 am, edited 1 time in total.

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Desktop shortcuts to web pages (URLs) have stopped working

Post by kyphi » Thu Mar 08, 2018 1:04 am

Your method of dragging a URL to the Desktop from the search bar of your browser creates a "Link to ..." icon to that URL - that is quite correct.

Some users have multiple browsers installed because not all browsers are equally competent and therefore the browser you use most of the time is marked as "Default". This is easily done in two locations. One is in the browser itself and the other is in System Settings, Preferences, Preferred Applications. Normally, a selection made in one of these locations will also reflect in the other.

Check that Firefox is marked as the "default" browser in both locations.

When you right click on one of your URL-created icons and then proceed to "Open with" and "Other application ...", you can type into the field at the bottom of the screen, e.g. firefox %u and then click on "Set as default". If firefox is already listed as the default you can still click on "Set as default".

Hopefully that will fix it.
Linux Mint 19 Cinnamon - 64bit

ppguasch
Level 1
Level 1
Posts: 19
Joined: Fri Dec 09, 2016 7:46 pm

Re: Desktop shortcuts to web pages (URLs) have stopped working

Post by ppguasch » Fri Mar 09, 2018 3:52 am

Hello kyphi .

Thanks for your reply. I have checked what you say about the two locations where the "Default browser" should be set and yes, Firefox is set as the default browser in both locations.

(By the way, when I go into "menu > preferences > General", within the Firefox browser, the option "Always check that firefox is your default browser" appears with a check mark in the check box in front, with a yellow smiley face underneath stating in bold letters that firefox is my default browser but the whole option on top is grayed out and if I wanted to clear up the check box so as to not make it my default browser I could not do it here (?))

I mention the above just in case it's relevant and a sign that something else is not set properly.

I have made the changes you suggest within the right click on desktop icon > menu > "Open with ..." > "Other applications ..." setting up the "firefox %u" as default.

Now I have firefox set up twice in that "Open with" > "Other applications ..." menu.

One under "Default application" and the other under "Recommended application".

They both work ok and open the desired URL if I right click the icon, go to "open with" > "Other application ..." and select any of the two and click "Accept" but if I simply double click the icon of the desktop shortcut it refuses to open (The clock goes around for a while until it disappears and nothing happens). This used to work before and was quite fast also.

Thank you for your interest anyway.

Josep

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Desktop shortcuts to web pages (URLs) have stopped working

Post by kyphi » Fri Mar 09, 2018 8:53 pm

If Firefox is the only browser installed then that would be your default browser.

If you are using any Firefox Add-ons or Extensions would you temporarily disable these to see if that makes a difference.
Linux Mint 19 Cinnamon - 64bit

User avatar
Spearmint2
Level 15
Level 15
Posts: 5719
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Desktop shortcuts to web pages (URLs) have stopped working

Post by Spearmint2 » Fri Mar 09, 2018 10:12 pm

Did you setup profile manager for multiple users of Firefox? If so, that may be the problem.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

ppguasch
Level 1
Level 1
Posts: 19
Joined: Fri Dec 09, 2016 7:46 pm

Re: Desktop shortcuts to web pages (URLs) have stopped working

Post by ppguasch » Sat Mar 10, 2018 9:12 am

Hello kyphi and Spearmint2.

Thank you for your interest and prompt response. You were right Kyphi about the disabling the Firefox Add-ons and extensions.

I disabled all Firefox Add-ons and Extensions and I also switched to Google Chrome browser as the default browser.

I Checked that Google Chrome had no problem in opening my desktop shortcuts and then I switched back to Firefox as my default Browser.

I then double clicked on the desktop shortcuts that didn't open properly before in Firefox and now they all opened without a problem.

I then re-enabled all Firefox Add-ons and Extensions that I had disabled before and checked again double clicking my desktop shortcuts and noe everything works as intended.

Thank you very much for your help!!

Post Reply

Return to “Cinnamon”