Cinnamon System Tray Spacing [Solved]

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
benmandude
Level 1
Level 1
Posts: 2
Joined: Sun Apr 08, 2018 12:35 am

Cinnamon System Tray Spacing [Solved]

Post by benmandude » Sun Apr 08, 2018 1:08 am

I'm having trouble with the width for icons in the system tray.
The icons themselves are fine, but the space allocated to each icon seems to be wider than it should be.
This is more apparent when compared to other applets on the panel.

Is there a way to remove the extra width allocated for the icons in the system tray?
Allowing custom scaling in the panel options doesn't make any difference.

Here are two screenshots showing the discrepancy I'm seeing.
Mouse hovered over them to show the allocated widths.
Wide.png
Wide spacing for system tray
Normal.png
Normal spacing for applet
Last edited by benmandude on Sun Apr 08, 2018 3:53 pm, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Cinnamon System Tray Spacing

Post by Cosmo. » Sun Apr 08, 2018 5:47 am

What is your version of Mint and what is the desktop environment? Which kernel and which architecture? If you don't know open a terminal and enter:

Code: Select all

inxi -Szxx
Paste the output here.

You need to give this information for every help request in every thread.
Do not forget this in the future.

Try this: Open the general settings for the system and disable the indicator support. You need to restart Cinnamon (usually ctrl-alt-esc) or log out of the account and back in to make it effective.

benmandude
Level 1
Level 1
Posts: 2
Joined: Sun Apr 08, 2018 12:35 am

Re: Cinnamon System Tray Spacing

Post by benmandude » Sun Apr 08, 2018 6:09 am

Your suggestion solved the issue.

For posterity's sake, here is my info.
System:
Host: XPS13-9333
Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
dm: lightdm
Distro: Linux Mint 18.3 Sylvia

Post Reply

Return to “Cinnamon”