Arrows in scrollbars - mint 19

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
dailies3000
Level 1
Level 1
Posts: 2
Joined: Wed Jun 20, 2018 9:10 am

Arrows in scrollbars - mint 19

Post by dailies3000 » Wed Jun 20, 2018 9:22 am

I'm able to add arrows by:

Code: Select all

sudo xed /usr/share/themes/Mint-Y/gtk-2.0/main.rc

Code: Select all

sudo xed /usr/share/themes/Mint-Y/gtk-3.0/gtk.css
and setting true to:

Code: Select all

* {
    -GtkScrollbar-has-backward-stepper: true;
    -GtkScrollbar-has-forward-stepper: true; }
but i get a very wide scrollbar.
Even they disappear in programs like xed or nemo when not hovering.

If you know a way to add normal scrollbars for every program GTK 2.0 and GTK 3.0, please post it here.
i know how to solve it for previous releases, not this 19 anymore.
Last edited by dailies3000 on Wed Jun 20, 2018 12:56 pm, edited 2 times in total.

whm1974
Level 4
Level 4
Posts: 237
Joined: Fri Jan 19, 2018 11:07 pm

Re: Arrows in scrollbars - mint 19

Post by whm1974 » Wed Jun 20, 2018 9:34 am

Personally I think scrollbars should be the default.

User avatar
Moem
Level 17
Level 17
Posts: 7759
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Arrows in scrollbars - mint 19

Post by Moem » Wed Jun 20, 2018 9:44 am

dailies3000 wrote:
Wed Jun 20, 2018 9:22 am
Even they disappear in programs like xed or nautilus when not hovering.

If you know a way to add normal scrollbars for every program GTK 2.0 and GTK 3.0, please post it here.
i know how to solve it for previous releases, not this 19 anymore.
Are you sure you're on Cinnamon? Because you're mentioning Nautilus ...
What all have you tried? Did you try ...
- changing the theme ?
- changing this setting: viewtopic.php?f=208&t=270983#p1480100 ?

And, of course, you are running a beta, which is unsupported, and always at your own risk. But you knew that. :wink:
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

dailies3000
Level 1
Level 1
Posts: 2
Joined: Wed Jun 20, 2018 9:10 am

Re: Arrows in scrollbars - mint 19

Post by dailies3000 » Wed Jun 20, 2018 12:54 pm

Nemo.

What is more, in nemo, xed and other programs, the arrows apart from being fat, are horizontal.
Attachments
browser_arrows.png
updates_arrows.png

lmuserx4849

Re: Arrows in scrollbars - mint 19

Post by lmuserx4849 » Tue Jun 26, 2018 4:51 am

dailies3000 wrote:
Wed Jun 20, 2018 12:54 pm
Nemo.

What is more, in nemo, xed and other programs, the arrows apart from being fat, are horizontal.
I repeated your steps and can second it.

Rather than updating files in /usr/share/themes, you can create a $HOME/.config/gtk-3.0/gtk.css and copy those lines over, as well as the selector:

scrollbar {
-GtkScrollbar-has-backward-stepper: true;
...
}

But...that's clearly a bug and should be reported.
This BETA release might contain critical bugs, please only use it for testing purposes and to help the Linux Mint team fix issues prior to the stable release.

Bug reports:

Please report bugs below in the comment section of this blog.

https://blog.linuxmint.com/?p=3582
I think the future is bleak for scrollbars and gtk. :-( Hopefully, Clem will work his magic. :-)

I'm trying LM19 Mate. I'm coming from KDE so this is all a little strange to me. I installed konsole and for whatever reason it has traditional, awesome, scrollbars. So I started down the Appearance Preferences path.

I started looking for traditional/basic themes at gnome-look.org and came up with OneColor. I thought if I could find a theme that did what I wanted, I could just get the parts I wanted and put them into the gtk.css file.

I'm using the Clearlooks-Phenix theme, which I saw mentioned here. The package is clearlooks-phenix-theme. It is super nice and has traditional scrollbars.
I clicked the customize button and the Controls > Clearlooks-Phenix, Window Borders > Doppler-Left, Icons > Tango. I did the WinMe for awhile.

I did get normal scrollbars in all windows, except Synaptic Manager. They still auto-hide.
Now I'm going to go back and figure out why this theme worked.... My initial tries (environmental variables, css) of what use to work, did not.
Attachments
window.jpg
A LM Window with normal Scrollbars.

MSt1982
Level 2
Level 2
Posts: 61
Joined: Mon Jul 13, 2015 11:01 pm

Re: Arrows in scrollbars - mint 19

Post by MSt1982 » Sun Dec 30, 2018 5:49 am

lmuserx4849 wrote:
Tue Jun 26, 2018 4:51 am
I'm using the Clearlooks-Phenix theme, which I saw mentioned here. The package is clearlooks-phenix-theme. It is super nice and has traditional scrollbars.
I clicked the customize button and the Controls > Clearlooks-Phenix, Window Borders > Doppler-Left, Icons > Tango. I did the WinMe for awhile.

I did get normal scrollbars in all windows, except Synaptic Manager. They still auto-hide.
Now I'm going to go back and figure out why this theme worked.... My initial tries (environmental variables, css) of what use to work, did not.
How did you installed this theme? It seems to me the theme must have the tar.gz-ending to be installable. I've downloaded 7.0.1, copied it to usr/share/themes, when I choose the file from theme-manager/install it says "successfully installed" - 2 seconds later the symbol of Clearlooks appears with a question mark and its telling me "Clearlooks-Phenix is not installed"?!?!?? :roll: :lol: :x :?

What was the result of
lmuserx4849 wrote:
Tue Jun 26, 2018 4:51 am

I thought if I could find a theme that did what I wanted, I could just get the parts I wanted and put them into the gtk.css file.
? How to get such nice scrollbars without installing the whole theme by just edi the gtk.css, how to set the size of the stepper-arrows for example?

MSt1982
Level 2
Level 2
Posts: 61
Joined: Mon Jul 13, 2015 11:01 pm

Re: Arrows in scrollbars - mint 19

Post by MSt1982 » Sun Dec 30, 2018 6:29 am

Now I cant remove the Clearlooks-theme-symbol anymore :( Great. Cant click it, delete is not selectable and its still there even though I removed its folder and file from /usr/share/theme with rm...great.

I was able to install it through the packetmanager, but it did not work good at all (I was not mark symbols on the desktop with my mouse - the grid was completely white)...then I uninstalled it and now I have the symbol with a question mark still in the settings...what do I have to delete to remove it?


And much more important - how to get normal slider-bars easily?!

Post Reply

Return to “Cinnamon”