Flashing black borders around windows with Nvidia-390 and Mint 19

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Oblias
Level 1
Level 1
Posts: 39
Joined: Sat Jul 21, 2018 11:15 pm

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by Oblias »

lucask wrote:
Thu Dec 20, 2018 1:36 pm
Unfortunately the upgrade to Linux Mint 19.1 did not resolve the issue for me :(

Update: Although updating from kernel 4.15.0-43 to 4.18.0-13 (through the Update Manager this time, instead of doing it manually like I tried before) for now seems to solve the issue. I've had before that it seems to work for a while but comes back later, so I'm only cautiously enthusiastic.
Since you are now on 19.1 you might consider trying out the two new options in System Settings/General/Compositor Options ... It just might be the ticket!
clu801
Level 1
Level 1
Posts: 1
Joined: Thu Feb 07, 2019 1:48 pm

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by clu801 »

I was also having this issue. I have a Dell laptop running mint 19 as well.. I dont use the laptop screen.. just 2 external monitors one of which is a 4k TV @60hz.

I have been running Mint for over a week without the issue until today.
It seemed to only be a problem when i was mousing over a terminal.. or anything that had transparency.

I tried the ~/.config/gtk-3.0/gtk.css at 1px and this did NOT fix the issue at all.

I was looking at upgrading my kernel etc. then i decided to set the gtk.css to 0px I like boarderless anyway. and it for some reason fixed my issue. I am not sure if it will last.. but I am hoping. Otherwise.. Mint my be a thing of the past for me.
AuFreefer
Level 1
Level 1
Posts: 1
Joined: Fri Feb 15, 2019 1:46 am

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by AuFreefer »

I had a similar problem, where I have black boxes whenever I hover at the panel (close to the date, and update manager, also near the menu button). I solved it afer removing libpoppler packages.
This started after an update for (libpoppler73, poppler-utils, and libpoppler-glib8) libraries.
I used (sudo apt-get remove libpoppler73), (sudo apt-get remove libpoppler-utils), and (sudo apt-get remove libpoppler-glib8).
I hope this helps.
MarcusWillby
Level 1
Level 1
Posts: 1
Joined: Tue Mar 19, 2019 9:22 am

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by MarcusWillby »

Oblias wrote:
Thu Dec 20, 2018 6:16 pm
Since you are now on 19.1 you might consider trying out the two new options in System Settings/General/Compositor Options ... It just might be the ticket!
This worked for me. I simply turn on the VBlank setting and restarted Cinnamon.
Thanks.
wiserweb
Level 1
Level 1
Posts: 2
Joined: Fri Mar 22, 2019 6:03 pm

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by wiserweb »

Confirming that setting VBlank to Off on Mint 19.1 does resolve the black window redrawing issue.

Main Menu->System Settings->General-> Enable VBlank (Requires Cinnamon restart).

However, a new issue is occurring where the window is being redrawn as transparent and displays the underlying background in rectangle shapes. This seems like a form of tearing.

This issue only occurs on the far right monitor in a dual monitor setup, each set at 3440x1440.

This solution was helpful to address the transparent tearing, perhaps it can help others.

https://www.youtube.com/watch?v=4YQSL3xWrJA
wiserweb
Level 1
Level 1
Posts: 2
Joined: Fri Mar 22, 2019 6:03 pm

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by wiserweb »

Regrettably, the above solutions did not entirely resolve the issue.

However, more tweaks with NVIDIA panel did solve the issue!!!

Open 'NVIDIA X Server Settings'.

On the option on the left choose, 'X Server Display Configuration'.

1. Select your monitor(s) in the Layout diagram.

2. Click the 'Advanced' button.

3. Check 'Force Composition Pipeline' and 'Force Full Composition Pipeline'.

4. Click 'Apply'.

5. Click 'Save to X Configuration File' to make these changes permanent.

Repeat the above five steps for each monitor.

Your X11 configuration file should be located at '/etc/X11/xorg.conf' if you are using Mint 19. When you click 'Save to X Configuration' it's okay to leave 'Merge with existing file' checked.

You can verify if the options are being persisted by looking for something similar to these lines in '/etc/X11/xorg.conf'

Option "metamodes" "DP-4: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-0: nvidia-auto-select +3440+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
Option "SLI" "Off"


You can test to see that this will eliminate all screen tearing issues and remove black borders around windows.

Now, reboot to verify if the changes have stayed. If they haven't then repeat the steps and save your file again.

Also of note, it is safe to re-enable 'Sync to VBlank' and 'Allow Flipping' after setting 'Force Composition Pipeline' and 'Force Full Composition Pipeline'.

This issue took almost two years to resolve. This started with Mint 18.

Does someone have a suggestion to make this a default setting on Mint when using Cinnamon?
duper
Level 1
Level 1
Posts: 1
Joined: Fri May 03, 2019 2:57 pm

Re: Flashing black borders around windows with Nvidia-390 and Mint 19

Post by duper »

Thank you very much. It worked!
Locked

Return to “Cinnamon”