How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
andrewsmith
Level 1
Level 1
Posts: 30
Joined: Thu Mar 08, 2012 10:33 pm

How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by andrewsmith » Sun Jul 15, 2018 1:32 pm

Hello

I had this configured to work as I wanted in Mint 18.3 but I don't remember how I did it and am having a hard time figuring it out.

What I want is to disable the feature where the screen locks when my laptop's lid is closed.

It's fine if the screen turns off but I don't want the laptop to sleep or to lock the screen, requiring me to type in a password.

I went to the screensaver settings and set the "Delay before starting screensaver" to never, which I hope means it will never start but I don't know.

I also turned off the "Lock the computer after the screensaver starts" option, though I would like the screensaver to never start.

Under "Power management" both dropdowns for "when lid is closed" are set to "do nothing".

Can someone please help me figure this out?

Thanks in advance.

Digby
Level 1
Level 1
Posts: 5
Joined: Wed Jul 04, 2018 8:48 am

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by Digby » Sat Jul 21, 2018 10:05 am

I have the same problem and it is annoying. If power management is set to suspend and you open laptop no password needed so I assume this is a bug but not sure how to articulate it.

tothpeter
Level 1
Level 1
Posts: 1
Joined: Sun Jul 22, 2018 7:44 am

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by tothpeter » Sun Jul 22, 2018 7:48 am

I have exactly the same problem. On LM 19, all updates applied (and home partition encrypted), after the lid is closed, the screen is locked. I use exactly the same settings as in LM 18.3 and the screen was not locked here.

mattmint
Level 1
Level 1
Posts: 4
Joined: Wed Nov 15, 2017 8:21 pm

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by mattmint » Mon Jul 23, 2018 2:27 am

This is really bugging me as well. The power management option says "Do Nothing" when lid is closed. That is inaccurate. It does something when the lid is closed: it activates the lock screen.

edit - this is on version 18.2, so it's not something new in 19 as far as I can tell.

User avatar
lannatwin
Level 2
Level 2
Posts: 86
Joined: Sat Jun 20, 2009 9:14 pm
Location: Thailand

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by lannatwin » Wed Jul 25, 2018 10:35 am

Same here. In 17.3 there was a setting under screensaver to "lock the computer when the screen turns off". That switch is missing in Mint 19.

andrewsmith
Level 1
Level 1
Posts: 30
Joined: Thu Mar 08, 2012 10:33 pm

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by andrewsmith » Fri Jul 27, 2018 3:45 am

Has anyone found a solution yet? I'm pretty sure it's the screensaver that turns on, but I don't know how to get stop it.

andrewsmith
Level 1
Level 1
Posts: 30
Joined: Thu Mar 08, 2012 10:33 pm

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by andrewsmith » Fri Jul 27, 2018 3:59 am

I can chmod 0 /usr/bin/cinnamon-screensaver and that keeps it from locking when the lid is closed, but that also prevents it from locking when the laptop is suspended.


User avatar
smurphos
Level 7
Level 7
Posts: 1600
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by smurphos » Wed Aug 08, 2018 1:34 am

zacktheperson wrote:
Wed Aug 08, 2018 1:07 am
This helped me solve the problem: https://askubuntu.com/questions/15520/h ... laptop-lid
Good find zacktheperson.... there was one fix suggested on there that I hadn't tried and hey presto it works...

sudoedit /etc/UPower/UPower.conf

Change IgnoreLid=false to IgnoreLid=true, Ctrl-X and then Y and enter to save. Reboot.

This has a side effect of removing Lid Actions entirely from the Power Manager GUI, but also kills the bug of the screensaver kicking in despite settings on lid close. Screensaver remains operational otherwise.

Reverting the edit and rebooting restores the Options in Power manager GUI as-well as the bug...

andrewsmith
Level 1
Level 1
Posts: 30
Joined: Thu Mar 08, 2012 10:33 pm

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by andrewsmith » Wed Aug 08, 2018 2:25 pm

Thanks guys!

To clarify for others who might run into this problem, this is what I had to do:

* Edit /etc/UPower/UPower.conf and change the IgnoreLid to true:

Code: Select all

IgnoreLid=true
* Then edit /etc/systemd/logind.conf, uncomment the HandleLidSwitch and change it to ignore:

Code: Select all

HandleLidSwitch=ignore
* Then reboot.

The screen still turns black when the lid is closed (must be a hardware thing) and if I suspend the machine manually it will still resume when I open the lid. But it will not sleep or turn on the screensaver when I close the lid.

Too bad the UI for this doesn't work, but at least there is this workaround!

exiteden
Level 1
Level 1
Posts: 9
Joined: Sun Sep 07, 2014 1:22 am

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by exiteden » Fri Aug 10, 2018 9:35 pm

Thanks for this post, everyone.

I've been having trouble with my system freezing and suspect it has something to do with the lock screen. I don't know if the freezing issue is fixed, but I was trying to disable the lock screen everywhere so I was going crazy when I couldn't disable lock after lid close. I appreciate the help from you all!

bradwww
Level 1
Level 1
Posts: 8
Joined: Sun Jun 13, 2010 7:11 pm

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by bradwww » Mon Aug 13, 2018 3:49 am

it looks like i need this fix too - can you dumb down the instructions to fix? what do you mean by edit? thanks.

redlined
Level 1
Level 1
Posts: 8
Joined: Wed Jun 06, 2018 8:12 pm

Re: How to disable screen locking on lid closed in Cinnamon in Linux Mint 19

Post by redlined » Mon Oct 08, 2018 2:50 pm

andrewsmith wrote:
Wed Aug 08, 2018 2:25 pm
Thanks guys!

To clarify for others who might run into this problem, this is what I had to do:

* Edit /etc/UPower/UPower.conf and change the IgnoreLid to true:

Code: Select all

IgnoreLid=true
* Then edit /etc/systemd/logind.conf, uncomment the HandleLidSwitch and change it to ignore:

Code: Select all

HandleLidSwitch=ignore
* Then reboot.

The screen still turns black when the lid is closed (must be a hardware thing) and if I suspend the machine manually it will still resume when I open the lid. But it will not sleep or turn on the screensaver when I close the lid.

Too bad the UI for this doesn't work, but at least there is this workaround!
this worked! Running LM19 cinnamon on an old laptop and main issue has been computer locks up completely every time lid is lowered too far, editing both files as @andrewsmith suggests solved it for me, thanks for both question and answer good Sir!

Post Reply

Return to “Cinnamon”