[Solved] MINT "Display" pops up frequently

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
Guenter
Level 1
Level 1
Posts: 10
Joined: Tue Sep 30, 2014 5:49 am

[Solved] MINT "Display" pops up frequently

Post by Guenter » Sun Jul 22, 2018 7:56 am

After fresh installation of DISTRIB_DESCRIPTION="Linux Mint 19 Tara"
the "Display" window pops up frequently with "Configure screen settings and layout".
No chance to get it satisfied to be quiet. No idea why! :roll:
Any pointer how to get it solved?
Last edited by Guenter on Wed Aug 08, 2018 1:05 pm, edited 1 time in total.

User avatar
MrEen
Level 6
Level 6
Posts: 1464
Joined: Mon Jun 12, 2017 8:39 pm

Re: MINT "Display" pops up frequently

Post by MrEen » Sun Jul 22, 2018 10:44 am

Just a guess here. Make sure the monitor connection is properly seated. Maybe even disconnect and clean the port (carefully.)

Guenter
Level 1
Level 1
Posts: 10
Joined: Tue Sep 30, 2014 5:49 am

Re: MINT "Display" pops up frequently

Post by Guenter » Sun Jul 22, 2018 11:07 am

@MrEen
Good point .. but doesn't count with a Laptop installation .. should have said, sorry

Guenter
Level 1
Level 1
Posts: 10
Joined: Tue Sep 30, 2014 5:49 am

Re: MINT "Display" pops up frequently

Post by Guenter » Thu Aug 02, 2018 6:20 am

Anyone else having a good idea?

All settings/variations on the "Display" window pops up doesn't help. During writing this message I have up to five popups, really unacceptable. That wasn't with my previous Mint Rosa setup. Just double check with that, the Rosa is on the system so move back to it?

Guenter
Level 1
Level 1
Posts: 10
Joined: Tue Sep 30, 2014 5:49 am

Re: MINT "Display" pops up frequently

Post by Guenter » Tue Aug 07, 2018 1:40 pm

:oops: No ideas? :cry:

Should I really go back to Rosa version?


Any idea which program / device / setting to check?
HOPE for helpful hands / ideas .... THANKS

User avatar
MrEen
Level 6
Level 6
Posts: 1464
Joined: Mon Jun 12, 2017 8:39 pm

Re: MINT "Display" pops up frequently

Post by MrEen » Tue Aug 07, 2018 3:28 pm

Hi Guenter.

Sorry you haven't received any other advice as yet.

On my system, the Windows key and p used together will pop up that window you are referring to. Also, if you have multimedia keys, one of those can do it as well. I guess you could see if there's a possibility you're invoking it yourself with either of those.

Also, take a look at your keyboard settings to see if there's any other shortcut listed for that. On mine, the command is xfce4-display-settings --minimal which is listed twice with each entry I mentioned above (the mm key is XF86Display.)

The window you mention, on my system, has a checkbox for "Configure new displays when connected" that is not checked. If yours is checked, trying unchecking it to see if that helps.

Good luck.

User avatar
mint4all
Level 2
Level 2
Posts: 80
Joined: Tue Feb 13, 2018 1:16 pm

Re: MINT "Display" pops up frequently

Post by mint4all » Tue Aug 07, 2018 3:46 pm

MrEen wrote:
Tue Aug 07, 2018 3:28 pm
Hi Guenter.
Sorry you haven't received any other advice as yet. ...
Greetings, and i'd second THAT!

Like MrEen, i am using Mint's XFCE-spin as my primary DE. His mention of those two shortcuts, especially the "super+p" combo, is right on point. Just to be sure, I booted up with my LM18.3-Cinnamon dvd, and looked over Cinnamon's keyboard shortcuts. Thus I can confirm that your desktop is also using the same pre-configured "Super+p" shortcut Mint's XFCE-system(s) have.

My take: unless you accidentally are pressing that shortcut whilst typing, your laptop's keyboard may have a quirk, or some sticky keys (laptop keyboards are notorious for deteriorating over time). Just for testing my theory, you may want to disable that shortcut for the time being and see what happens (look in Menu > Preferences > Keyboard > Shortcuts > System). Hopefully, this works. If not, would you have access to and try an external keyboard?

Guenter
Level 1
Level 1
Posts: 10
Joined: Tue Sep 30, 2014 5:49 am

Re: MINT "Display" pops up frequently

Post by Guenter » Tue Aug 07, 2018 5:56 pm

Thank to @mint4all and @MrEen
Yes the window + p opens that "Display" and I cross checked with my Rosa installation, basically both look same. I had tested both settings "Configure new displays when connected", no difference.
Because the Rosa installation doesn't popup the "Display" I would not expect a problem with the keyboard. Just disabled the shortcut as recommended, waiting to see if that helps.

Maybe a look into the different installations can help. See the attached zip including os-release and inxi -Fz for both systems.
Attachments
OS_Linux_MINT_installInfos.tar.gz
(1.8 KiB) Downloaded 10 times

User avatar
MrEen
Level 6
Level 6
Posts: 1464
Joined: Mon Jun 12, 2017 8:39 pm

Re: MINT "Display" pops up frequently

Post by MrEen » Tue Aug 07, 2018 6:15 pm

Hi Guenter.

I seriously doubt it has any effect on your issue, but the only thing I saw different between your two installs is the driver for the Intel video (modesetting in 19, Intel in Rosa.)

Maybe one place to check is in keyboard settings if the same layout is used in both installs.

Hope that helps.

Guenter
Level 1
Level 1
Posts: 10
Joined: Tue Sep 30, 2014 5:49 am

KILLED that beast: MINT "Display" pops up frequently

Post by Guenter » Wed Aug 08, 2018 10:53 am

Hi dear MrEen, dear mint4all,

seems to disable the keyboard shortcut for "Display" made the success! :D :D

Also I compared that shortcut setting on Rosa and Tara and found Rosa doesn't has any "Display" shortcut. After removing on Tara no more popups until now .. after a few hours working.

GREAT help .. THANKS again!
Günter

User avatar
MrEen
Level 6
Level 6
Posts: 1464
Joined: Mon Jun 12, 2017 8:39 pm

Re: [Solved] MINT "Display" pops up frequently

Post by MrEen » Wed Aug 08, 2018 1:52 pm

That's great! Nice work, Guenter. Love the topic change as well. :D

Post Reply

Return to “Cinnamon”