(SOLVED)Logon Background

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
RockWrangler
Level 1
Level 1
Posts: 3
Joined: Sat Aug 11, 2018 9:30 am

(SOLVED)Logon Background

Post by RockWrangler » Sat Aug 11, 2018 9:51 am

Hi, Running Tara I cannot find a way to switch between solid color and image on logon window. I set a solid color, but now want an image, but no way to switch between the two. I would have thought radio buttons beside each for selection? See Attached for what I have. The image won't overide the solid color.
Attachments
Logon Settings.png
Last edited by RockWrangler on Sun Aug 12, 2018 8:05 am, edited 1 time in total.

User avatar
kyphi
Level 8
Level 8
Posts: 2292
Joined: Sat Jul 09, 2011 1:14 am
Location: The Hunter, Australia

Re: Logon Background

Post by kyphi » Sat Aug 11, 2018 8:24 pm

Turn on "Draw user backgrounds" and specify the pathname to the background of your choice, e.g. /usr/share/backgrounds/linuxmint-tara/jplenio_lake.jpg
Linux Mint 19 Cinnamon - 64bit

RockWrangler
Level 1
Level 1
Posts: 3
Joined: Sat Aug 11, 2018 9:30 am

Re: Logon Background

Post by RockWrangler » Sat Aug 11, 2018 10:47 pm

kyphi wrote:
Sat Aug 11, 2018 8:24 pm
Turn on "Draw user backgrounds" and specify the pathname to the background of your choice, e.g. /usr/share/backgrounds/linuxmint-tara/jplenio_lake.jpg
Yep, already tried that, the solid color still over-rides the chosen image.

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Logon Background

Post by smurphos » Sun Aug 12, 2018 12:45 am

What's the location in the file system of the image you are using?

If under your home folder is your home encrypted?

If yes then you need to move the image in question out of home and to another location in the file system - a custom made folder in /opt/ is a good choice - so that slick-greeter can access the image without your user being logged in.

If you are not using an encrypted home then the issue will be permissions on the image file. It must be readable by the Others for slick-greeter to be able to display it - i.e have permissions of at least 644 or -rw-r--r--

This applies to images set as the main background for all users or if you use the draw user image option - the user backgrounds can't be in an encrypted home and must have permission for Others to read them.

RockWrangler
Level 1
Level 1
Posts: 3
Joined: Sat Aug 11, 2018 9:30 am

Re: Logon Background

Post by RockWrangler » Sun Aug 12, 2018 8:04 am

smurphos wrote:
Sun Aug 12, 2018 12:45 am
What's the location in the file system of the image you are using?

If under your home folder is your home encrypted?

If yes then you need to move the image in question out of home and to another location in the file system - a custom made folder in /opt/ is a good choice - so that slick-greeter can access the image without your user being logged in.

If you are not using an encrypted home then the issue will be permissions on the image file. It must be readable by the Others for slick-greeter to be able to display it - i.e have permissions of at least 644 or -rw-r--r--

This applies to images set as the main background for all users or if you use the draw user image option - the user backgrounds can't be in an encrypted home and must have permission for Others to read them.
BINGO! That was the problem, the encrypted home folder that is. Thanks a million!

Post Reply

Return to “Cinnamon”