Laptop keyboard no input on lock-screen or login screen

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
mrojo
Level 1
Level 1
Posts: 2
Joined: Tue Sep 04, 2018 7:05 am

Laptop keyboard no input on lock-screen or login screen

Post by mrojo » Tue Sep 04, 2018 8:48 pm

On normal cold boot there is no issue nor after a restart. The problem is only on lock screen always after suspend due to auto lock that, I have no input from keyboard. Ubuntu Mate has the same bug on the same laptop. On lock screen once it started to type rapid inputs automatically by itself, the keyboard was not working at all.
Mouse still works at all times.
My workaround: From regular log-in screen I use accessibility on screen keyboard to type the firs letter > then the keyboard starts working again. From lock screen I have to select switch user to get to the regular log-in screen to again make use of the accessibility on screen keyboard. If anyone has a clue as to how fix this issue I will be greatly appreciated.

Laptop: Sony Vaio Model: sve15125cxs OS: Linux Mint 19 cinnamon 64-bit. Fresh install.

User avatar
catweazel
Level 17
Level 17
Posts: 7741
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Laptop keyboard no input on lock-screen or login screen

Post by catweazel » Wed Sep 05, 2018 1:50 am

mrojo wrote:
Tue Sep 04, 2018 8:48 pm
Laptop: Sony Vaio Model: sve15125cxs OS: Linux Mint 19 cinnamon 64-bit. Fresh install.
Please post the output of this terminal command:

Code: Select all

inxi -Fxz
Enclose the results between [ⅽode] and [/ⅽode] code markers by selecting </> from the mini toolbar above the textbox where you type your reply.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

mrojo
Level 1
Level 1
Posts: 2
Joined: Tue Sep 04, 2018 7:05 am

Re: Laptop keyboard no input on lock-screen or login screen

Post by mrojo » Wed Sep 05, 2018 6:46 pm

Code: Select all

System:    Host: jennifer-Vaio Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Sony product: SVE15125CXS v: C10FTAU3 serial: N/A
           Mobo: Sony model: VAIO serial: N/A
           UEFI: Insyde v: R0200D5 date: 09/26/2016
Battery    BAT1: charge: 27.1 Wh 100.0% condition: 27.1/45.0 Wh (60%)
           model: SONY VGP-BPS26 status: Full
CPU:       Dual core Intel Core i5-3210M (-MT-MCP-) 
           arch: Ivy Bridge rev.9 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9977
           clock speeds: max: 3100 MHz 1: 1590 MHz 2: 1353 MHz 3: 1315 MHz
           4: 1385 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile
           version: 4.2 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (5.8% used)
           ID-1: /dev/sda model: ST500LM012_HN size: 500.1GB
Partition: ID-1: / size: 454G used: 24G (6%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 4.17GB used: 0.21GB (5%)
           fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 236 Uptime: 1 day Memory: 1562.5/3823.9MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Post Reply

Return to “Cinnamon”