Page 1 of 1

default Chinese font changed in LM 19, very hard to read - where can I configure it?

Posted: Thu Sep 13, 2018 2:06 pm
by cinnabert
I use my system in Chinese and English, English as the system language, but Chinese/English for input. fcitx is my input system of choice. Simple/Traditional Chinese language packs are all installed, fcitx Chinese input works.

However: I upgraded from Linux Mint 18.3 Cinnamon to LM 19 Cinnamon and had to discover that the default Chinese font has changed. Now It is very hard to read, especially on HiDPi (examples from my terminal and a website).

I googled the hell out of this problem, but I can't figure out where the configuration file for this is. Where on earth do I decide which font is used, but only for the Chinese fonts?
  • This site suggests to adapt something in /etc/fonts/font.conf (which others and the file itself warn against).
  • Some suggest editing ~/.config/fontconfig/, but the folder fontconfig doesn't exist on my (nearly freshly installed) LM. I created it, added some file as the second link suggest, but it didn't work.
  • I found a file in /usr/share/fontconfig/conf.avail called 70-fonts-noto-cjk.conf, but I'm not sure what to do with it.
Do you have any solution to this?

TL;DR: If I have a second, non-Latin language installed on LM 19 Cinnamon which I use parallel to the system default, where do I configure its default font?

Bonus question: a change to the default Chinese font might be a thing to do in a further release, should I suggest it?

Re: default Chinese font changed in LM 19, very hard to read - where can I configure it?

Posted: Tue Oct 02, 2018 7:56 pm
by jaymot
Preferences/Fonts?

Re: default Chinese font changed in LM 19, very hard to read - where can I configure it?

Posted: Sat Jan 19, 2019 10:33 pm
by mintgary
I just ran into the same problem two days ago. I noticed the 64-language-selector-prefer.conf file has been removed from /etc/fonts/conf.avail directory. You can change the terminal Chinese font by creating you own 64-language-selector-prefer.conf file. Here's how I did it.

First, create the 64-language-selector-prefer.conf file.

Code: Select all

sudo touch /etc/fonts/conf.avail/64-language-selector-prefer.conf
xed admin:///etc/fonts/conf.avail/64-language-selector-prefer.conf
Past the following into xed:

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <alias>
        <family>sans-serif</family>
        <prefer>
            <family>Noto Sans CJK TC</family>
            <family>Noto Sans CJK SC</family>
            <family>Noto Sans CJK JP</family>
            <family>Noto Sans CJK KR</family>
        </prefer>
    </alias>
    <alias>
        <family>serif</family>
        <prefer>
            <family>Noto Serif CJK TC</family>
            <family>Noto Serif CJK SC</family>
            <family>Noto Serif CJK JP</family>
            <family>Noto Serif CJK KR</family>
        </prefer>
    </alias>
    <alias>
        <family>monospace</family>
        <prefer>
            <family>Noto Sans Mono CJK TC</family>
            <family>Noto Sans Mono CJK SC</family>
            <family>Noto Sans Mono CJK JP</family>
            <family>Noto Sans Mono CJK KR</family>
        </prefer>
    </alias>
</fontconfig>
If you use Simplified Chinese, make sure 'Noto Sans Mono CJK SC' preceeds 'Noto Sans Mono CJK TC' in the three <prefer></prefer> sectiions.

Save the file and close xed.

Next, create a symbolic link in the /etc/fonts/conf.d dirctory:

Code: Select all

cd /etc/fonts/conf.d
sudo ln -s ../conf.avail/64-language-selector-prefer.conf 64-language-selector-prefer.conf
Log out then login. The Chinese font in the terminal should be changed to Noto Sans CJK. I hope it helps.