NTFS Partition does not activate even with automount, until clicking drive in file manager

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
4RainButterfly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 04, 2018 4:30 pm

NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by 4RainButterfly »

I'm running Linux Mint 19, Cinnamon. The same problem was on mint 18 and both Mate and Cinnamon.

The issue: I have a drive partitioned. One is formatted NTFS for windows and linux boot boot.
In Mint, the shared Data partition is set to automount on startup, however I cannot launch any applications, nor do any of the Launchers do not appear...

As soon as I open the file manager and click the partition drive name, the partition becomes available. Now all the programs can be loaded, and all launchers work.
What is going on? It is automounted - I checked Disks and Mount Options (nosuid,nodev,nofail,x-gvfs-show). Why is it now available immediately?

I enjoy mint but this is becoming quite bothersome.
Any help is appreciated.
ajgringo619
Level 8
Level 8
Posts: 2067
Joined: Thu Mar 01, 2018 8:36 pm
Location: San Diego, California, USA

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by ajgringo619 »

Can you post your /etc/fstab?
Mint 19.3 XFCE [kernel 5.4.0-48-generic]
Ryzen 7 2700X Eight-Core w/16 GB RAM
AMD Radeon R9 290 w/4GB RAM
Image
User avatar
phd21
Level 19
Level 19
Posts: 9677
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by phd21 »

Hi 4RainButterfly,

How did you set this partition to "automount"?

This method should work on any drive partition using any file system that is installed in your Linux system including Linux file systems (ext4, btrfs, etc...), MS Windows (fat32, NTFS, exfat (install exfat stuff), etc...), even Mac OS (install drivers).

If you are using the nice "disks" application, click the drive on the left, click partition on the right-side that you always want available, click the "gear" icon below, select edit mount options, turn off the button for automount or session at the top, check "automount at startup" and "show in user interface", maybe change the "indentify as" box to the disk's label (if it has one), note what is in the "mount point" box, click ok. The drive will automatically be mounted and identified from then on in file managers and elsewhere as whatever was in the "mount point" box. This also updates the "fstab" drive and partition control file for you, restart your computer afterward.

If the drive has a Linux filesystem (ext4, btrfs, etc..) then you will also have to give yourself (user) permission to read and write to the drive.

Run the console terminal command below (you can copy and paste it) to give your user permission to all mounted drives and their partitions. If you only want to give the user permission to a specific drive's partition then add the "mount point" partition's identifier name or label to the end of the command.

Code: Select all

sudo chown -R $USER:$USER /media/$USER/
or

Code: Select all

sudo chown -R $USER:$USER /mnt/

Hope this helps ...
.
"Disks" screen 1
"Disks" screen 1
.
"Disks" screen 2
"Disks" screen 2
Last edited by phd21 on Sun May 05, 2019 5:34 pm, edited 10 times in total.
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
4RainButterfly
Level 1
Level 1
Posts: 5
Joined: Thu Oct 04, 2018 4:30 pm

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by 4RainButterfly »

@phd21

Thank you! This is exactly what I needed. It solved the issue 100%. I think Mint should have this by default because this was quite an advanced config to play with , in order to get it working how I expected. I appreciate your help!
User avatar
phd21
Level 19
Level 19
Posts: 9677
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by phd21 »

Hi 4RainButterfly,

You are very welcome...
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
User avatar
Sundowner
Level 1
Level 1
Posts: 14
Joined: Sun Mar 13, 2016 11:58 pm

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by Sundowner »

Nice mini-tutorial phd21.
RayJ0G
Level 1
Level 1
Posts: 1
Joined: Thu Dec 27, 2018 2:54 pm
Location: Canada

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by RayJ0G »

Hi PHD1,Found your post to 4RainButterfly most interesting and helpfull. I am a newbie so I am not sure if it is OK to
tag along this post as my problem is somehow linked to it - I did run the chown command as suggested and rebooted - did check with my userid no change - I had read-only access to Win NTFS partition before and after. Logged in with another user-id and to my surprise all partitions were mounted and accessible in read-only mode (this includes EFI, NTFS, Ext4 & swap!). But no access to modify, delete or change files on the WIN NTFS partition which is where I (&many more users I guess) store my data so it is accessible by both OS's. How can we unlock this NTFS partition? Using administrator rights does nothing.
User avatar
phd21
Level 19
Level 19
Posts: 9677
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by phd21 »

Hi RayJ0G,

Just noticed that your reply was not answered, sorry about that.

I no longer use MS Windows since I can do everything I used to do in MS Windows in my Linux Mint system.

But, I have an NTFS (MS Windows files system) on a drive partition and on my USB backup drives for compatibility with other operating systems and devices and because I did not want to deal with Linux permissions (although that is not hard to do).

I have never had issues accessing my NTFS partitions because they do not need permissions from Linux systems. The only time I have read about that being a problem is if people are dual-booting Linux Mint with MS Windows and their MS Windows system was not completely shut down before they booted into their Linux system, do not use MS Windows suspend or hibernate.

Make sure you have these packages installed, and they are usually installed by default.

Code: Select all

sudo apt install ntfs-3g fuse
Here are some related links:

Why does my NTFS partition mount as read only? - Ask Ubuntu
https://askubuntu.com/questions/70281/w ... -read-only

mount - NTFS volumes read-only since update - Ask Ubuntu ("dirty" Ms Windows partition, run chkdsk)
https://askubuntu.com/questions/1111236 ... nce-update

Linux version of running "chkdsk" or "check disk" on a ntfs file system is "ntfsfix" and some other commands or applications, replace the "aX" in commands showing "/dev/sdaX" with the actual drive partition's designation which you can find using the "lsblk -f" command or "disks" application or a partition manager editor.

Also, normally you cannot run disk repairs on a mounted (in-use) drive partition, so you may have to unmount (umount) that drive's partition before running a check disk repair.

List all connected drives and their partitions and the type of file systems on them. Ex: my NTFS partition on my main drive is "sda4"

Code: Select all

lsblk -f
or

Code: Select all

sudo fdisk -l
unmount

Code: Select all

sudo umount /dev/sdaX
NTFS check

Code: Select all

sudo ntfsfix /dev/sdaX
To re-mount a drive for access, just bring up your file manager and click the drive (may have to click refresh or redisplay), or logout and back in, use "disks", use the system tray icon for "removable drives" or "device notifications" and click the triangle to the right of a drive and or its partition, etc...

Code: Select all

sudo mount /dev/sdaX
How to Fix a Corrupted Windows NTFS Filesystem With Ubuntu
https://www.makeuseof.com/tag/fix-corru ... em-ubuntu/

You can also use a bootable CD/DVD disc or USB Stick of MiniTool Partition Wizard to fix Ms Windows drives and their partitions.

Hope this helps ...
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
User avatar
Portreve
Level 10
Level 10
Posts: 3277
Joined: Mon Apr 18, 2011 12:03 am
Location: Florida

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by Portreve »

phd21 wrote:
Thu Oct 04, 2018 5:04 pm
If you are using the nice "disks" application, click the drive on the left, click partition on the right-side that you always want available, click the "gear" icon below, select edit mount options, turn off the button for automount or session at the top, check "automount at startup" and "show in user interface", maybe change the "indentify as" box to the disk's label (if it has one), note what is in the "mount point" box, click ok. The drive will automatically be mounted and identified from then on in file managers and elsewhere as whatever was in the "mount point" box. This also updates the "fstab" drive and partition control file for you, restart your computer afterward.
Thank you so much! I just turned my "old" SSD system drive into a partitioned Timeshift / Data Storage drive after having installed a new WD Black NVME M.2 drive, and for the life of me I couldn't figure out why those drives wouldn't show up when my external HDDs do and always have.
Please remember to mark your fixed problem [SOLVED].

Running Linux Mint Cinnamon 20.0.

Those who can make you believe absurdities can make you commit atrocities.
— Voltaire
User avatar
phd21
Level 19
Level 19
Posts: 9677
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: NTFS Partition does not activate even with automount, until clicking drive in file manager

Post by phd21 »

Hi Portreve,

You are very welcome.

As you are probably already aware, giving your drive partitions an easy to identify name for a volume label before mounting them will make using them in your system and various apps much easier; you can use the disks app to change the volume label as well. I have also noticed that some applications like some multimedia streaming apps do not like the Linux default mounting folder under the user name, so using a generic folder name like /mnt is preferred.
Phd21: Mint 20 and 19.2 Cinnamon & xKDE (Mint Xfce + Kubuntu KDE) & KDE Neon 64-bit (new based on Ubuntu 20.04) Awesome OS's, Dell Inspiron I5 7000 (7573) 2 in 1 touch screen, Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram, Intel 4 Graphics.
Post Reply

Return to “Cinnamon”