AutoShutdown on Low Battery not available

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
User avatar
AZgl1500
Level 9
Level 9
Posts: 2764
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

AutoShutdown on Low Battery not available

Post by AZgl1500 » Mon Oct 15, 2018 3:20 pm

Last night, I pulled the power cord as I needed to be "mobile between my recliner and my office" with the laptop.

back to the recliner again, and I just up and closed the lid, and laid the laptop down like I always do. it is never powered off, just close the lid.

Well, after my night time required ZZZZZzzzz session ended, I get the laptop, open the lid, and "NOTHING???"

ARGH!!!

yes, I got a whole lot of errors in the file system, as the reboot went thru and fixed things.
I hate that....

so, then in further reading before posting this thread, I read this viewtopic.php?f=208&t=279097
and read that in Cinnamon, some Power Management options have been lost.... shutdown being one of them.

so, I installed the Battery Monitor applet and remember having done that before, but it got lost along the way with my experiments in trying different OS versions.

But, here is my Problem, I still cannot choose to make the system Power Down Automatically when the Critical Low Battery level is reached....
Kernel: 4.15.0-36-generic x86_64 (64 bit) Desktop: Cinnamon 3.6.7
Distro: Linux Mint 18.3 Sylvia

Do nothing is the only option I have.


Image

User avatar
smurphos
Level 8
Level 8
Posts: 2040
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: AutoShutdown on Low Battery not available

Post by smurphos » Tue Oct 16, 2018 12:28 am

AZgl1500 wrote:
Mon Oct 15, 2018 3:20 pm
so, then in further reading before posting this thread, I read this viewtopic.php?f=208&t=279097
and read that in Cinnamon, some Power Management options have been lost.... shutdown being one of them.
That thread says nothing about lost Power Management options - the OP in that thread just wants a more in your face low battery notification than the default one which is very innocuous and isn't very reliable.

Shutdown immediately is an option on my machine on 19 as it was on 18.3. So if it's missing there's likely an issue with kernel support for the feature on your hardware or you may need to flick some switches in Bios to ensure ACPI is active.......

User avatar
AZgl1500
Level 9
Level 9
Posts: 2764
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: AutoShutdown on Low Battery not available

Post by AZgl1500 » Tue Oct 16, 2018 12:39 am

It used to be eons ago, have not thought about it at all, until that thread came up, about the Battery Monitor.
I installed that fix, but it obviously did not fix the AutoShutdown on Critical Battery.

Don't think anything unusual is in Grub, except for trying to make USB mouse AutoSuspend work, which so far, is working, thanks to you.

Code: Select all

# If you change this file, run 'sudo update-grub' afterwards to update
#
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=6
# force it to show
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# parameters for non-recovery boot only:
GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 usbcore.autosuspend=-1 enable_mtrr_cleanup mtrr_spare_reg_nr=10 mtrr_gran_size=32M mtrr_chunk_size=64M"
# parameters for all boots:
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
# GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
# GRUB_INIT_TUNE="480 440 1"

# RAM info
# enable_mtrr_cleanup mtrr_spare_reg_nr=1 mtrr_gran_size=32M mtrr_chunk_size=128M
# gran_size: 32M 	chunk_size: 64M 	num_reg: 10  	lose cover RAM: 46M
# enable_mtrr_cleanup mtrr_spare_reg_nr=10 mtrr_gran_size=32M mtrr_chunk_size=64M >>>> this gives an error 'mtrr not found'


User avatar
smurphos
Level 8
Level 8
Posts: 2040
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: AutoShutdown on Low Battery not available

Post by smurphos » Tue Oct 16, 2018 2:09 am

AZgl1500 wrote:
Tue Oct 16, 2018 12:39 am
Don't think anything unusual is in Grub, except for trying to make USB mouse AutoSuspend work, which so far, is working, thanks to you.
Thanks for the credit but I'm pretty sure it was gm10 who helped you with that fix.... :D

User avatar
AZgl1500
Level 9
Level 9
Posts: 2764
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: AutoShutdown on Low Battery not available

Post by AZgl1500 » Tue Oct 16, 2018 2:34 am

that is why I have to take notes, my AutoRememberer is broke :lol:

Post Reply

Return to “Cinnamon”