I fail to assign full permission to my automount ntfs directory

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon
Post Reply
sina
Level 1
Level 1
Posts: 3
Joined: Tue Aug 13, 2013 11:35 am
Location: Now,Iran,Maku
Contact:

I fail to assign full permission to my automount ntfs directory

Post by sina » Sun Nov 04, 2018 7:32 pm

Hello everyone,

After several years, I decided to return to Linux Mint Cinnamon desktop from Manjaro Linux. Apparently, one thing that I used to see working in every Linux experience that I had is failing when I try on Linux Mint Cinnamon 19 tara. I am editing the

Code: Select all

/etc/fstab
and add the following line to automount my NTFS partition.

Code: Select all

UUID=some_ID /media/pie ntfs rw,auto,users,exec,umask=003,gid=46,uid=1000 0 0
And then I operate the following code to give the full permission to the directory "/media/pie".

Code: Select all

 sudo chmod -R 755(or 777)  /media/pie/
or

Code: Select all

sudo chmod -R o+rw /media/pie/
but none of them helped me with creating or deleting a folder or file in "pie" directory. When I perform "ls -l" the output is,

Code: Select all

drwxrwxr--  1 sina plugdev 4096 Nov  2 18:38 pie

and when I try to change the ownership of group to sina, by operating,

Code: Select all

sudo chown -R sina:sina /media/pie

executing "ls -l" shows exactly the same thing as before. What am I missing that I fail?

User avatar
WharfRat
Level 20
Level 20
Posts: 12460
Joined: Thu Apr 07, 2011 8:15 pm

Re: I fail to assign full permission to my automount ntfs directory

Post by WharfRat » Sun Nov 04, 2018 7:50 pm

You can chmod and chown til the cows come home and permissions will not change because the ntfs filesystem does not store that information :wink:
ImageImage

all41
Level 14
Level 14
Posts: 5249
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: I fail to assign full permission to my automount ntfs directory

Post by all41 » Sun Nov 04, 2018 7:58 pm

WharfRat wrote:
Sun Nov 04, 2018 7:50 pm
You can chmod and chown til the cows come home and permissions will not change because the ntfs filesystem does not store that information :wink:
Not even cows with superpower
Proud to be a supporter and monthly contributor to Mint.

sina
Level 1
Level 1
Posts: 3
Joined: Tue Aug 13, 2013 11:35 am
Location: Now,Iran,Maku
Contact:

Re: I fail to assign full permission to my automount ntfs directory

Post by sina » Sun Nov 04, 2018 8:01 pm

Is this a recent thing!? Because I was used to put my automount directory either in /mnt or /media .

User avatar
phd21
Level 18
Level 18
Posts: 8172
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: I fail to assign full permission to my automount ntfs directory

Post by phd21 » Sun Nov 04, 2018 8:21 pm

Hi sina,

I just read your post and the good replies to it. Here are my thoughts on this as well.

You do not need permissions to mount or use NTFS filesystems, but you do need to mount them. The easiest method to mount partitions is using the "Disks" application, see link below. You may have to first remove any "fstab" entries that you manually entered for partitions other than your boot partition.

[SOLVED] I can not delete files on the second hard drive
viewtopic.php?f=90&t=280878

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

altair4
Level 19
Level 19
Posts: 9502
Joined: Tue Feb 03, 2009 10:27 am

Re: I fail to assign full permission to my automount ntfs directory

Post by altair4 » Mon Nov 05, 2018 7:50 am

The way you are mounting your ntfs partition is inconsistent with the way you want permissions.

The fstab entry will have owner=sina, group=plugdev, and permissions of 774. sina and members of the plugdev group will be able to read and write to the partition but others will not be able to do anything since an even number ( 4 ) will not allow everyone else access to the folder. Permissions numbers on directories always have to be odd to allow access.

If you want permissions to be 755 the umask needs to be 022 ( 777-022=755 ).
If you want permissions to be 777 the umask needs to be 000 ( 777-000=777 ).
Note: If you don't add the umask option at all it defaults to 000.

If you want the group to be the same as the user the gid needs to be 1000 ( gid=1000 ).

Remember that unlike a Linux filesystem NTFS has no Linux permissions or ownership bits to set which is why chown or chmod has no affect. Linux handles this by creating a "view" that makes it appear to have Linux permissions but they are set at mount time not after mount and they are immutable at that point.

And remember that the Disks utility knows nothing about users, umask, windows_names, uid, gid, or a plethora of other options implicitly. You will need to add them to the list of options explicitly which you might as well do by editing fstab directly.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Post Reply

Return to “Cinnamon”