Cinnamon crashes to Fallback mode on startup[SOLVED]

Please post suggestions for improvement of Cinnamon on:
https://github.com/linuxmint/Cinnamon
Post Reply
wnmc
Level 1
Level 1
Posts: 13
Joined: Thu Dec 06, 2018 6:33 pm

Cinnamon crashes to Fallback mode on startup[SOLVED]

Post by wnmc »

I have been reading all through these topics and cant find an answer. I login and it says cinnamon desktop crashed try to restart yes or no. I have pressed yes several times and nothing, so I hit no and it goes to Fallback mode. I am running Linux Mint 19 Tara 32-bit Kernel: 4.15.0-42-generic i686
bits: 32 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1)
Distro: Linux Mint 19 Tara

Graphics: Card: Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200]
bus-ID: 01:05.0
Display Server: x11 (X.Org 1.19.6 )
drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
Resolution: 1440x900@59.94hz
OpenGL: renderer: ATI RS480
version: 2.1 Mesa 18.0.5 Direct Render: Yes
If you have any idea as to what is wrong i would Greatly appreciate help.

Thank You
Last edited by wnmc on Sat Dec 29, 2018 9:12 pm, edited 1 time in total.

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 496
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Cinnamon crashes to Fallback mode on startup

Post by Joe2Shoe »

This can happen when Mesa/OpenGL is updated via the Update Manager. It did to me on one of my laptops with the same video card you have.

The "FIX" was to use Timeshift and revert to a previous "snapshot" of LM, before Mesa/OpenGL was updated, then do not update them.
Also, in Grub, I believe I tried "nomodeset".
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

wnmc
Level 1
Level 1
Posts: 13
Joined: Thu Dec 06, 2018 6:33 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by wnmc »

l will try the nomodeset option at boot. I dont have an timeshift earlier than that.

Thank You

wnmc
Level 1
Level 1
Posts: 13
Joined: Thu Dec 06, 2018 6:33 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by wnmc »

Still not working. Crashes to fallback mode.

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 496
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Cinnamon crashes to Fallback mode on startup

Post by Joe2Shoe »

Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200]
The same video chipset in my Dell Inspiron 1501.
I, also, had the same issue as you, plus most times the screen was unreadable, then it would stop.
A quick fix is to reboot the pc, then Press & Hold the Shift key immediately until the Grub menu appears.
Select the second choice (Advances options for LM).
Then select the Recovery option.
Press Enter, then press Enter for OK if necessary, twice.
The PC will boot, then you can adjust the settings in Grub, etc.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 496
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Cinnamon crashes to Fallback mode on startup

Post by Joe2Shoe »

OK, I pulled my Dell Inspiron 1501 out from under the bed, it has the same video chipset as yours.
BTW, this laptop is running LM19 Mate 64-bit without any problems whatsoever.
The laptop starts up with vertical colored lines & will not successfully boot into LM and boots to Fallback mode.

This is my fix: (the answer is in the Grub)
1. Boot the laptop.
2. Press & Hold the "Shift" key immediately after the BIOS screen finishes, until the Grub menu appears.
3. Select Advanced Options for LM, then press Enter.
4. Select "Recovery Mode", then press Enter.
4. Laptop boots to "Recovery Mode".
5. Edit Grub in Terminal: sudo gedit /etc/default/grub
6. Enable the following line (or add if not listed):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
7. Disable all other "GRUB_CMDLINE_LINUX_DEFAULT="xxxxxx" lines by adding "#" and a space, before the lines.
8. Click "Save".
9. Update Grub in Terminal: sudo update-grub.
10. In Terminal: reboot
11. If Grub menu appears, select "normal boot".
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

wnmc
Level 1
Level 1
Posts: 13
Joined: Thu Dec 06, 2018 6:33 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by wnmc »

OK I will try this. I'm on a different laptop right now so I can read this and edit the other one at same time. Once I get LM 19 setup and its stable, I will install over Win 10 on this one.

Again Thank you for all the help.

Will post my results soon...
If this doesn't work, I will Install LM 19 MATE and give it a try.

wnmc
Level 1
Level 1
Posts: 13
Joined: Thu Dec 06, 2018 6:33 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by wnmc »

It didn't work, I am downloading LM 19 64-bit MATE. I just want something to work right. I bought Linux Mint 17 on CD from amazon. I was told no updates anymore and to install 18 or higher. Thank You for all the help.

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 496
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Cinnamon crashes to Fallback mode on startup

Post by Joe2Shoe »

OK, I will pull out that Dell again and check the Grub setup.
Be back later.

BTW: Is that a Dell laptop?

version: 2.1 Mesa 18.0.5
I believe that the version of Mesa is the problem, because when I updated OpenGL/Mesa to 18.0.5 my laptop did the same thing again.
I believe that's the problem, as that video chip can't handle the newer Mesa version.
---

OK, I do have OpenGL v.2.1 and Mesa v.18.0.5 installed on that laptop, boots normally. Updating OpenGL/Mesa to a higher version will cause the same problem.

Here is my Grub file:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
# GRUB_CMDLINE_LINUX_DEFAULT="reboot=acpi"
# GRUB_CMDLINE_LINUX_DEFAULT="reboot=efi"
# GRUB_CMDLINE_LINUX_DEFAULT="reboot=pci"
# GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
---

The only "GRUB_CMDLINE_LINUX_DEFAULT" line that is active is:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

You may want to add that line, and comment (#) the others (4) below it (as shown in the example above), but leave "GRUB_CMDLINE_LINUX" as is.
Then update Grub in the Terminal: sudo update-grub
Then reboot: reboot
Good luck.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

muriz23
Level 1
Level 1
Posts: 3
Joined: Tue Dec 11, 2018 7:56 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by muriz23 »

I just installed the new cinnamon 19 and, it says the same thing on my. Do you recommend to re do mint and just get rid of everything start over? will the problem come back again?

[/quote]

wnmc
Level 1
Level 1
Posts: 13
Joined: Thu Dec 06, 2018 6:33 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by wnmc »

I installed LM 19 64-bit MATE and everything seems to be working fine. Thanks for the help. Greatly appreciated.

logitwood12
Level 1
Level 1
Posts: 6
Joined: Wed Dec 12, 2018 2:43 am

Re: Cinnamon crashes to Fallback mode on startup

Post by logitwood12 »

I'm having this issue too, is there a way to fix this? I'm using the latest version of Linux Mint: Cinnamon Edition: 19 (Tara)
Here are my pc specs:

System: Host: ricky-MacBookPro Kernel: 4.15.0-42-generic x86_64 bits: 64 gcc: 7.3.0
Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu1) dm: lightdm Distro: Linux Mint 19 Tara
Machine: Device: laptop System: Apple product: MacBookPro5 5 v: 1.0 serial: N/A
Mobo: Apple model: Mac-F2268AC8 serial: N/A
UEFI: Apple v: MBP55.88Z.00AC.B03.0906151708 date: 06/15/09
Chassis: type: 10 v: Mac-F2268AC8 serial: N/A
Battery BAT0: charge: 6.3 Wh 100.0% condition: 6.3/62.9 Wh (10%) volts: 12.4/10.9
model: SMP bq20z451 serial: N/A status: Full
CPU: Dual core Intel Core2 Duo P8700 (-MCP-) arch: Penryn rev.10 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 10082
clock speeds: min/max: 798/2527 MHz 1: 1630 MHz 2: 1591 MHz
Graphics: Card: NVIDIA C79 [GeForce 9400M] bus-ID: 02:00.0 chip-ID: 10de:0863
Display Server: x11 (X.Org 1.19.6 ) drivers: fbdev,nouveau (unloaded: modesetting,vesa)
Resolution: 1280x800@76.00hz
OpenGL: renderer: N/A version: N/A Direct Render: N/A
Audio: Card NVIDIA MCP79 High Def. Audio driver: snd_hda_intel bus-ID: 00:08.0 chip-ID: 10de:0ac0
Sound: Advanced Linux Sound Architecture v: k4.15.0-42-generic
Network: Card-1: NVIDIA MCP79 Ethernet driver: forcedeth port: 21e0 bus-ID: 00:0a.0 chip-ID: 10de:0ab0
IF: enp0s10 state: down mac: <filter>
Card-2: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller
driver: wl bus-ID: 03:00.0 chip-ID: 14e4:432b
IF: wlp3s0 state: up mac: <filter>
Drives: HDD Total Size: 500.1GB (3.0% used)
ID-1: /dev/sda model: ST500LM000 size: 500.1GB serial: <filter>
Partition: ID-1: / size: 223G used: 13G (6%) fs: ext4 dev: /dev/sda3
ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID: System: supported: N/A
No RAID devices: /proc/mdstat, md_mod kernel module present
Unused Devices: none
Sensors: System Temperatures: cpu: 68.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb [arch=amd64] http: //dl.google.com/linux/chrome/deb/ stable main
Active apt sources in file: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list
deb http: //ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
deb-src http: //ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
Active apt sources in file: /etc/apt/sources.list.d/linuxuprising-java-bionic.list
deb http: //ppa.launchpad.net/linuxuprising/java/ubuntu bionic main
deb-src http: //ppa.launchpad.net/linuxuprising/java/ubuntu bionic main
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http: //packages.linuxmint.com tara main upstream import backport
deb http: //fireball-public.phys.wvu.edu/mirror/ubuntu bionic main restricted universe multiverse
deb http: //fireball-public.phys.wvu.edu/mirror/ubuntu bionic-updates main restricted universe multiverse
deb http: //fireball-public.phys.wvu.edu/mirror/ubuntu bionic-backports main restricted universe multiverse
deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb http: //archive.canonical.com/ubuntu/ bionic partner
Active apt sources in file: /etc/apt/sources.list.d/official-source-repositories.list
deb-src http: //packages.linuxmint.com tara main upstream import backport
deb-src http: //fireball-public.phys.wvu.edu/mirror/ubuntu bionic main restricted universe multiverse
deb-src http: //fireball-public.phys.wvu.edu/mirror/ubuntu bionic-updates main restricted universe multiverse
deb-src http: //fireball-public.phys.wvu.edu/mirror/ubuntu bionic-backports main restricted universe multiverse
deb-src http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb-src http: //archive.canonical.com/ubuntu/ bionic partner
Active apt sources in file: /etc/apt/sources.list.d/spotify.list
deb http: //repository.spotify.com stable non-free
Info: Processes: 202 Uptime: 1 min Memory: 665.0/7719.9MB
Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0 Client: Unknown python3.6 client inxi: 2.3.56

BretAB
Level 1
Level 1
Posts: 9
Joined: Tue Feb 05, 2019 1:56 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by BretAB »

Joe2Shoe wrote:
Mon Dec 10, 2018 7:59 pm
OK, I pulled my Dell Inspiron 1501 out from under the bed, it has the same video chipset as yours.
BTW, this laptop is running LM19 Mate 64-bit without any problems whatsoever.
The laptop starts up with vertical colored lines & will not successfully boot into LM and boots to Fallback mode.

This is my fix: (the answer is in the Grub)
1. Boot the laptop.
2. Press & Hold the "Shift" key immediately after the BIOS screen finishes, until the Grub menu appears.
3. Select Advanced Options for LM, then press Enter.
4. Select "Recovery Mode", then press Enter.
4. Laptop boots to "Recovery Mode".
5. Edit Grub in Terminal: sudo gedit /etc/default/grub
6. Enable the following line (or add if not listed):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
7. Disable all other "GRUB_CMDLINE_LINUX_DEFAULT="xxxxxx" lines by adding "#" and a space, before the lines.
8. Click "Save".
9. Update Grub in Terminal: sudo update-grub.
10. In Terminal: reboot
11. If Grub menu appears, select "normal boot".
Hi,
I also have an "Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200] The same video chipset in my Dell Inspiron 1501". I could boot the Mint v19.1 64bit Cinnamon ISO, bus also received the "Fallback" error. I then installed it to SSD without error, but immediately after login still received "Fallback" error also. Only solution that I worked for my hardware was to install MATE instead of Cinnamon.
Regards . . .

OnAir
Level 1
Level 1
Posts: 2
Joined: Sun Mar 24, 2019 10:05 am

Re: Cinnamon crashes to Fallback mode on startup[SOLVED]

Post by OnAir »

Hi
I was suffering the same issue with a mid-2010 Macbook, which has nvidia 320M graphics, 4gb RAM, 120gb SSD.
Mint Cinnamon 19,1 64-bit crashes to fallback mode every time using the nouveau graphics driver even when mint is fully updated.
And when I tried the proprietary nvidia additional driver i just booted to a black screen every time.

So I did install Mint Mate and it did work with nouveau graphics driver. However I would not call that a solution to this thread.
How can installing Mint Mate be the solution to problems with Mint Cinnamon :P
I didnt like Mate Mint, I cant get it to look the way I want, plus again when I tried to install the nvidia driver it just booted to a black screen.

Then I found this thread:
https://askubuntu.com/questions/264247/ ... 573#613573

I followed the exact steps in Terminal as instructed, takes under 5 minutes. This got the proprietary nvidia driver working in Mint Mate

So - I reinstalled Mint Cinnamon, fully updated it still with the nouveau graphics driver and still crashing to fallback at boot.
Then I followed the instructions in the link again and switched to the proprietary nvidia driver.
Hey presto - Cinnamon does not crash and the nvidia driver works. The first reboot came up with a garbled screen but every subsequent restart works fine.

I think this will be a solution to those of you out there with macbooks and nvidia graphics anyway, and there may be some clues in this to help others.
Maybe this will also give the Mint Cinnamon developers some good info to build the solution into future releases.

BretAB
Level 1
Level 1
Posts: 9
Joined: Tue Feb 05, 2019 1:56 pm

Re: Cinnamon crashes to Fallback mode on startup

Post by BretAB »

BretAB wrote:
Tue Feb 05, 2019 5:19 pm
Joe2Shoe wrote:
Mon Dec 10, 2018 7:59 pm
OK, I pulled my Dell Inspiron 1501 out from under the bed, it has the same video chipset as yours.
BTW, this laptop is running LM19 Mate 64-bit without any problems whatsoever.
The laptop starts up with vertical colored lines & will not successfully boot into LM and boots to Fallback mode.

This is my fix: (the answer is in the Grub)
1. Boot the laptop.
2. Press & Hold the "Shift" key immediately after the BIOS screen finishes, until the Grub menu appears.
3. Select Advanced Options for LM, then press Enter.
4. Select "Recovery Mode", then press Enter.
4. Laptop boots to "Recovery Mode".
5. Edit Grub in Terminal: sudo gedit /etc/default/grub
6. Enable the following line (or add if not listed):
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
7. Disable all other "GRUB_CMDLINE_LINUX_DEFAULT="xxxxxx" lines by adding "#" and a space, before the lines.
8. Click "Save".
9. Update Grub in Terminal: sudo update-grub.
10. In Terminal: reboot
11. If Grub menu appears, select "normal boot".
Hi,
I also have an "Advanced Micro Devices [AMD/ATI] RS480M [Mobility Radeon Xpress 200] The same video chipset in my Dell Inspiron 1501". I could boot the Mint v19.1 64bit Cinnamon ISO, bus also received the "Fallback" error. I then installed it to SSD without error, but immediately after login still received "Fallback" error also. Only solution that I worked for my hardware was to install MATE instead of Cinnamon.
Regards . . .
Hi,

I'd like to offer some kudos to the Mint Tessa dev team: Whoopee! You fixed my Mint Mate hanging on Quit issue! I don't know what you did, but the hang / freeze on Quit on my trusty old Dell Inspiron 1501 is fixed. Over the last year or so I had become accustomed to having to use the laptop's power-off button to manually shut it down (instead of the desktop menu's "Quit" button) . But every now and then, I'd let it try to shut itself down via Quit, only to be disappointed when it still hung at the shutdown logo.

Note that in about the last week or two, the shutdown and even restart now works. Up until a couple days ago, the Quit button would shut it down almost immediately with no animated Mint shutdown graphic visible. Today, after some routine software updating, I used the Quit button, and the animated shutdown graphic was visible longer, with the green dots progressing left to right as normal. It took about maybe 10 seconds, then it powered off nicely.

KUDOS TO THE MINT DEV TEAM !!! THANK YOU : )

Regards . . .

barryw
Level 1
Level 1
Posts: 8
Joined: Tue Aug 16, 2016 12:52 am

Re: Cinnamon crashes to Fallback mode on startup[SOLVED]

Post by barryw »

I have the same issue on a HP p7-1010a with nvidia GeForce GT 545 graphics.
Although not a real solution I have found if I login to Mate first then logout (not shutdown) of Mate and then login to Cinnamon it then comes up.

Post Reply

Return to “Cinnamon”